
<!DOCTYPE html>
<!--[if lt IE 7]>  <html lang="en" class="no-js lt-ie9 lt-ie8 lt-ie7" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]> <html lang="en" class="no-js lt-ie10 lt-ie9 lt-ie8" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]> <html lang="en" class="no-js lt-ie10 lt-ie9" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js lt-ie10" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
<!-- metas -->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<title>Scaled-down Scala variant cuts ties to the JVM | JavaWorld</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="canonical" href="http://www.infoworld.com/article/3180823/application-development/scaled-down-scala-variant-cuts-ties-to-the-jvm.html"/>
<meta itemprop="url" content="http://www.javaworld.com/article/3181872/application-development/scaled-down-scala-variant-cuts-ties-to-the-jvm.html"/>
<meta name="description" content="Taking advantage of the LLVM compiler platform, Scala Native expands language’s opportunities on resource-constrained devices"/>
<meta name="news_keywords" content="Java,Scala"/>
<meta name="DC.date.issued" content="2017-03-15T03:00-05:00"/>
<meta name="date" content="2017-03-15"/>
<link rel="amphtml" href="http://www.javaworld.com/article/3181872/application-development/scaled-down-scala-variant-cuts-ties-to-the-jvm.amp.html"/>
<meta property="og:title" content="Scaled-down Scala variant cuts ties to the JVM">
<meta property="og:image" content="http://images.techhive.com/images/article/2017/03/scissors-100713530-large.3x2.jpeg"/>
<meta property="og:image:width" content="700"/>
<meta property="og:image:height" content="467"/>
<meta itemprop="image" content="http://images.techhive.com/images/article/2017/03/scissors-100713530-large.3x2.jpeg">
<meta itemprop="thumbnailURl" content="http://images.techhive.com/images/article/2017/03/scissors-100713530-large.3x2.jpeg"/>
<link rel="image_src" href="http://images.techhive.com/images/article/2017/03/scissors-100713530-large.3x2.jpeg"/>
<meta name="twitter:image" content="http://images.techhive.com/images/article/2017/03/scissors-100713530-large.3x2.jpeg"/>
<meta property="og:type" content="article"/>
<meta name="author" content="Paul Krill">
<meta property="og:site_name" content="JavaWorld"/>
<meta property="fb:app_id" content="196366870381968"/>
<meta property="og:url" content="http://www.javaworld.com/article/3181872/application-development/scaled-down-scala-variant-cuts-ties-to-the-jvm.html">
<meta name="twitter:url" content="http://www.javaworld.com/article/3181872/application-development/scaled-down-scala-variant-cuts-ties-to-the-jvm.html">
<!-- Add to article pages only -->
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@javaworldcom">
<meta property="og:description" content="Taking advantage of the LLVM compiler platform, Scala Native expands language’s opportunities on resource-constrained devices">
<meta name="twitter:description" content="Taking advantage of the LLVM compiler platform, Scala Native expands language’s opportunities on resource-constrained devices">
<meta name="rating" content="General">
<meta name="robots" content="NOODP,NOYDIR"/>
<!-- Sailthru -->
<meta name="sailthru.tags" content="application-development,scripting-jvm-languages,development-tools,open-source-tools,paul-krill,news,short"/>
<meta name="sailthru.image.thumb" content="http://core5.staticworld.net/images/article/2017/03/scissors-100713530-small.jpeg"/>
<meta name="sailthru.image.full" content="http://core2.staticworld.net/images/article/2017/03/scissors-100713530-large.3x2.jpeg"/>
<meta name="displaytype" content="article"/>
<meta name="source" content="infoworld"/>
<meta name="category" content="application development,scripting and jvm languages,development tools,open source"/>
<meta name="storytype" content="news"/>
<!-- pagination -->
<style>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</style>
<!-- css -->
<link rel="stylesheet" href="/www.idge/css/normalize.css?v=20170316112046"/>
<link rel="stylesheet" href="/www.idge/css/prettify.css?v=20170316112046"/>
<link rel="stylesheet" href="/www.idge.ans/js/select2-3.5.0/select2.css"/>
<link rel="stylesheet" href="/www.idge/css/article.css?v=20170316112046"/>
<link rel="stylesheet" href="/www.idge/css/print.css?v=20170316112046" media="print"/>
<link rel="stylesheet" href="/www.idge.jvw/css/article.css?v=20170316112046"/>
<link rel="stylesheet" href="/www.idge/css/webfonts/ss-social.css?v=20170316112046"/>
<link rel="stylesheet" href="/www.idge/css/webfonts/ss-standard.css?v=20170316112046"/>
<!--[if lte IE 8]>  
		<link href="/www.idge/css/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]-->
<link href="/www/css/ecom.css?v=20170316112046" rel="stylesheet">
<link href="http://fonts.googleapis.com/css?family=PT+Sans:400,700|PT+Sans+Narrow:400,700" rel="stylesheet" type="text/css"/>
<!--  fav and touch icons -->
<link rel="shortcut icon" type="image/x-icon" href="/www.idge.jvw/favicon.ico"/>
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="/www.idge.jvw/touchicon_144.gif"/>
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="/www.idge.jvw/touchicon_114.gif"/>
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="/www.idge.jvw/touchicon_72.gif"/>
<link rel="apple-touch-icon-precomposed" sizes="57x57" href="/www.idge.jvw/touchicon_57.gif"/>
<link rel="apple-touch-icon" href="/www.idge.jvw/images/JVW_logo_300x300.png"/>
<!-- js -->
<script src="/www.idge/js/jquery/jquery-1.10.2.min.js"></script>
<script src="/www/js/init_device.js?v=20170316112046"></script>
<!-- google_dfp needs jquery defined first -->
<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20170316112046"></script>
<script type="text/javascript">if(adLayer==null||adLayer=='undefined'){var adLayer=[];}adLayer["itemType"]="article";</script>
<script src="/www/js/ads/narf_prebid.js?v=20170316112046"></script>
<!-- LiveRamp Sources -->
<script type="text/javascript" src="//storage.googleapis.com/cdn.pippio.com/sdk/pippio.min.js" async></script>
<script src="/www/js/utils/liveRamp.js?v=20170316112046"></script>
<!-- End of LiveRamp -->
<script type="text/javascript">try{IDG.GPT.unitName="/8456/IDG.US_E_JavaWorld.com";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.unitName=IDG.GPT.unitName+"/"+"application-development_section";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}var global_ShowSuper=true;var global_ShowHero=false;var url=window.location.href;if(url.indexOf("?")>1){url=url.split('?')[0];}try{IDG.GPT.addTarget("URL",encodeURIComponent(url));}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("zone",'article/application-development');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("articleId",'3181872');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("type",'news');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("typeId",'2');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("templateType",'article-default');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categoryIds",[3646,3249,3465,3248]);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categorySlugs",['application-development','scripting-jvm-languages','development-tools','open-source-tools']);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{if(null!=IDG.GPT.getQsVal("env")){IDG.GPT.addTarget("env",IDG.GPT.getQsVal("env").replace(/\W/g,""));}}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("author",'Paul Krill');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("page_type",'');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("insiderContent",'false');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}</script>
<script type="text/javascript">console.log("PROXIMIC RESPONSE: PAGE-LEVEL");(function(){try{var proximic_data={"data":["300003","131100","121100","112200","131119","131120","240000","240002","240003","240004","240001","240005","240006","240007","240008","240009","240011","240012","240013","240014","240017","240015","240016","g8g6ah","e2co9k","20f4sh","r03wnl","z7xuj9","bkwp85","enwcef","44ywyv","bsuu95","3i8pvm","xks7sj","yn3dkv","x8eev1","7grvv1","agtqg7","agt9m3","9v0tiu","pcz604","m853gr","32xt66","n2qz3z","8hdk5f","500192","500235","500238","500247"]};IDG.GPT.addTarget("proximic",proximic_data.data);}catch(e){console.log("Error: "+e);}})();</script>
<script type="text/javascript"></script>
<script src="/www.idge/js/thm_pre.js?v=20170316112046"></script>
<script>var isMobile=(typeof IDG.DEVICE!=='undefined')?IDG.DEVICE.isMobile():false;try{IDG.GPT.addBiddingParams("yieldbotPsn",(isMobile?"7541":"c5a9"));IDG.GPT.addBiddingParams("appnexusPlacementId",(isMobile?"6451477":"6353206"));}catch(e){console.log("Error in adding bidding params: "+e);}</script>
<script type="text/javascript" src="/www/js/ads/prebid_gpt_launcher.js?v=20170316112046"></script>
<script src="/www.idge.ans/js/select2-3.5.0/select2.js"></script>
<script>$(document).ready(function(){$("select#country").select2({placeholder:"country",minimumResultsForSearch:Infinity,allowClear:true});$("#jobPosition").select2({placeholder:"position",minimumResultsForSearch:Infinity,allowClear:true});$("#jobFunction").select2({placeholder:"function",minimumResultsForSearch:Infinity,allowClear:true});$("#companySize").select2({placeholder:"company size",minimumResultsForSearch:Infinity,allowClear:true});$("#industry").select2({placeholder:"industry",minimumResultsForSearch:Infinity,allowClear:true});});</script>
<script>var brandCode="jvw";var brandName="JavaWorld";var regDebugLog=false;var regApiUrl=" http://regdev.idge.int/api/ ";var tokenPrefix='www';var tokenSuffix='.com/insider/token?';var brandDomain=".javaworld.com";var insiderContentType="article";var notEmptyArticle=false;var notEmptyMediaResource=false;var isInsiderPremium=false;var isResourceInsiderPremium=false;regApiUrl="http://reg.idgenterprise.com/api/";regDebugLog=false;tokenPrefix="http://www";tokenSuffix="/insider/token";notEmptyArticle=true;</script>
<script src="/www/js/utils/alc_hashes.js?v=20170316112046"></script>
<script src="/www/js/insider/insider_reg_api.js?v=20170316112046"></script>
<script src="/www/js/insider/jquery.maskedinput-1.4.min.js"></script>
<script>$(document).ready(function(){if(typeof(IDG.insiderReg.readCookie('nsdr'))!=='undefined'){$('#welcome-message').show();IDG.insiderReg.personalize();}else{$('.signin-register').show();}});</script>
<!-- All JavaScript at the bottom, except for Modernizr which enables HTML5 elements & feature detects -->
<script src="/www.idge/js/mule/modernizr.js?v=20170316112046"></script>
<!-- Begin Eloqua Tracking -->
<script type="text/javascript" src="/www/js/analytics/eloqua/elqCfg.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqImg.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqFCS.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqScr.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqIDG.js"></script>
<script type="text/javascript">IDG=window.IDG||{};IDG.PageInfo=IDG.PageInfo||{};IDG.PageInfo=function(){return{eloqua_type:"article",eloqua_topic:"development"};}();var elqCustomerGUID="";if(this.GetElqCustomerGUID&&typeof GetElqCustomerGUID==="function"){elqCustomerGUID=GetElqCustomerGUID();}IDG.Eloqua.invoke_flash();</script>
<!-- End Eloqua Tracking -->
<script type="text/javascript">var g_arrModules=new Array();</script>
<script src="http://a.postrelease.com/serve/load.js?async=true"></script>
<script>dataLayer=[{'primaryCategory':'Java App Dev','articleType':'News','articleId':'3181872','articleTitle':'Scaled-down Scala variant cuts ties to the JVM','blogName':'','parselyEnabled':'','parselyDomain':'','ga_enabled':'true','viglinksId':'','geolocEnabled':'true'}];</script>
<script type="text/javascript">var _sf_async_config={};_sf_async_config.uid=29363;_sf_async_config.path="/article/3181872/application-development/scaled-down-scala-variant-cuts-ties-to-the-jvm.html";_sf_async_config.title="Scaled-down Scala variant cuts ties to the JVM | JavaWorld";_sf_async_config.domain="javaworld.com";if(window.location.href.indexOf("video")&&true){_sf_async_config.playerdomain=_sf_async_config.domain.replace("www.","");}_sf_async_config.useCanonical=true;_sf_async_config.sections="application-development";_sf_async_config.authors="Paul Krill";</script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-MMJKZ9" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-MMJKZ9');</script>
<!-- End Google Tag Manager -->
</head>
<body id="article3181872" class="article javaworld">
<!-- BEGIN PAGE HEADER -->
<header id="banner">
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.main-header').insertBefore($('#banner .ad'));}</script>
<div class="topics-wrap">
<section class="topics">
<nav id="scrollable">
<!-- blx4 #670 blox4.raw_link_list  -->
<ul>
<li class="header">Trending<span class="colon">:</span></li>
<li><a href="/category/careers/">Programming Careers</a></li>
<li><a href="/category/learn-java/">Learn Java</a></li>
<li><a href="/category/mobile-java/">Mobile Java</a></li>
<li><a href="/category/java-app-dev/">Java App Dev</a></li>
<li><a href="/blog/open-source-java-projects/">Open Source Java </a></li>
<li><a href="/category/developer-tools-ide/">Development Tools</a></li>
<li><a href="/blog/java-101/">Java 101</a></li>
<li><a href="/resources">Resources/White Papers</a></li>
</ul>
</nav>
<div class="fading-gradient"></div>
<nav class="tools">
<ul class="user">
<li class="search-icon"><a href="#search" id="search-btn"><i class="ss-icon">Search</i></a></li>
</ul>
<ul class="social">
<li><a href="https://twitter.com/javaworldcom" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
<li><a href="http://www.linkedin.com/company/javaworld-com" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
<li><a href="https://www.facebook.com/pages/JavaWorld/107993545895326" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>
<li><a href="https://plus.google.com/117974570132126965756/posts" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>
<li><a href="/about/rss.html" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
<li class="more-social"><i class="ss-icon ss-ellipsis"></i></li>
</ul>
</nav>
</section>
</div>
<div id="sticky-anchor"></div>
<section id="sticky-head" class="main">
<div class="wrapper">
<div class="masthead">
<button><i class="ss-icon ss-rows"></i></button>
<a href="/"><span class="ir logo">javaworld</span></a>
<!--
	            	<img class="print-only" src="/www.idge.jvw/images/javaworld-logo-print.png">
	            	-->
<img class="print-only" src="http://idge.staticworld.net/jvw/javaworld-logo-print.png">
</div>
<div id="reading-tools-wrapper">
<nav class="tools">
<ul class="user">
</ul>
</nav>
</div>
<div class="insider-signin">
<span class="signin-register">
<a href="/learn-about-insider/"><span class="insider"></span></a> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-signin')" class="js-open-modal signin" data-modal-id="insider-popup">Sign In</a> <span class="divider">|</span> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-form-short')" class="js-open-modal register" data-modal-id="insider-popup">Register</a>
</span>
<div id="welcome-message" class="insider-list">
<div id="insider-selector">
<div id="insider-welcome" class="label"></div>
<div class="stories">
<div class="personalization">Hi<span id="person-first-name"></span>! Here are the latest Insider stories.</div>
<ul>
<li><a href="/article/3177967/cloud-computing/serverless-computing-freedom-for-devs-at-last.html">Serverless computing: Freedom for devs at last</a></li>
<li><a href="/article/3173685/application-development/the-best-go-language-ides-and-editors.html">The best Go language IDEs and editors</a></li>
<li><a href="/article/3171300/java-language/java-101-interfaces-in-java.html">Java 101: Interfaces in Java</a></li>
<li><a href="/article/3152819/application-development/5-rock-solid-linux-distros-for-developers.html">5 rock-solid Linux distros for developers</a></li>
</ul>
<div class="sign-out-link">
<a class="more-insider" href="/insider/">More Insider</a>
<a class="sign-out" href="javascript://" onclick="IDG.insiderReg.logout()">Sign Out</a>
</div>
</div>
</div>
</div>
</div>
<script>$('.signin-register').hide();$('#welcome-message').hide();</script>
</div>
</section>
<section class="tools-expand  ">
<form class="search" id="search-form" action="/search">
<label for="search-box">Search for</label>
<input type="text" name="query" id="banner-search-term" value="" class="searchbox-input-class"/>
<input type="submit" id="banner-search-submit" value="Go"/>
<input type="hidden" name="contentType" value="article,resource"/>
<div class="search-suggest">Suggestions for you</div>
</form>
<div class="user">
<form>
<label for="login-email">Insider email</label> <input id="login-email" type="text"/>
</form>
</div>
</section>
<div id="sticky-anchor-nav"></div>
<nav id="sticky-nav" class="main">
<ul class="topnav">
<li><a href="/category/core-java/" class="hasChildren">Core Java<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/core-java/">All Core Java</a></li>
<li><a href="/category/agile-development/">Agile Development</a></li>
<li><a href="/category/java-concurrency/">Java Concurrency</a></li>
<li><a href="/category/java-language/">Java Language</a></li>
<li><a href="/category/java-platform/">Java Platform</a></li>
<li><a href="/category/security/">Java Security</a></li>
<li><a href="/category/careers/">Programming Careers</a></li>
<li><a href="/category/testing-debugging/">Testing and Debugging</a></li>
</ul>
</li>
<li><a href="/category/enterprise-java/" class="hasChildren">Enterprise Java<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/enterprise-java/">All Enterprise Java</a></li>
<li><a href="/category/big-data/">Big Data</a></li>
<li><a href="/category/cloud-computing/">Cloud Computing</a></li>
<li><a href="/category/analytics/">Data Analytics</a></li>
<li><a href="/category/development-tools/">Development Tools</a></li>
<li><a href="/category/apis/">Java APIs</a></li>
<li><a href="/category/application-development/">Java App Dev</a></li>
<li><a href="/category/web-development/">Java Web Development</a></li>
<li><a href="/category/open-source-tools/">Open Source</a></li>
<li><a href="/category/scripting-jvm-languages/">Scripting and JVM Languages</a></li>
</ul>
</li>
<li><a href="/category/learn-java/" class="hasChildren">Learn Java<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/learn-java/">All Learn Java</a></li>
<li><a href="/category/design-patterns/">Design Patterns</a></li>
</ul>
</li>
<li><a href="/category/mobile-java/" class="hasChildren">Mobile Java<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/mobile-java/">All Mobile Java</a></li>
<li><a href="/category/android/">Java Android Developers</a></li>
<li><a href="/category/ios/">Java iOS Developers</a></li>
</ul>
</li>
</ul>
<ul class="secondary">
<li><a href="/news/">News</a></li>
<li><a href="/feature/">Features</a></li>
<li><a href="/howto/">How-Tos</a></li>
<li><a href="/blogs/">Blogs</a></li>
<li><a href="/resources/">Resources/White Papers</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
</ul>
</nav>
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('div.insider-signin').prependTo('section.topics nav.tools');}</script>
<script>$(document).ready(function(){if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("nav ul li a.hasChildren").attr("href","#").addClass('notMobile');$('nav#sticky-nav ul.secondary').addClass('topnav');}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("nav#sticky-nav > ul").switchClass("topnav","primary");}});</script>
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('#sticky-anchor, section.main, section.topics, section.tools-expand, #sticky-anchor-nav, nav.main').insertBefore($('#banner .ad'));$(document).ready(function(){$('#banner section.tools-expand').addClass('top-margin');});}</script>
</header>
<script>$(document).ready(function(){$('body').addClass('insider-plus');var headerHeight=$('header#banner').height();$('header#banner nav#sticky-nav.main.no-stick').css("top",headerHeight);if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var stickyHeaderHeight=$('section.topics').height()+$('#sticky-head.main').height();stickyHeaderHeight=stickyHeaderHeight-8;}var supportsOrientationChange="onorientationchange"in window,orientationEvent=supportsOrientationChange?"orientationchange":"resize";if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){window.addEventListener(orientationEvent,function(){var top=$('section#sticky-head.main').offset().top;if(top<170){top=0;}else{top=top-50;}if(window.orientation==90||window.orientation==-90){window.scrollTo(0,top);}},false);}if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&$thm.deviceHeight()<768){if($('html').hasClass('touch')){$('#insider-popup.modal-box .modal-body').addClass('short');}else{$('#insider-popup.modal-box .modal-body').addClass('short-desk');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){window.addEventListener(orientationEvent,function(){var top=$('section#sticky-head.main').offset().top;if(top<50){top=5;}else{top=top-40;}if(window.orientation==90||window.orientation==-90){window.scrollTo(0,top);}},false);}var ua=navigator.userAgent.toLowerCase();var isAndroid=ua.indexOf("android")>-1;window.addEventListener(orientationEvent,function(){if(isAndroid&&(screen.width==600||screen.width==960)){location.reload(true);}},false);if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.desktop)&&!$('html').hasClass('touch')){$("ul.social li.more-social").mouseenter(function(){$('ul.social > li').addClass('display-icon');});$("ul.social").mouseleave(function(){$('ul.social > li').removeClass('display-icon');});};if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&$('html').hasClass('touch')){$("ul.social li.more-social").click(function(){$('ul.social > li').toggleClass('display-icon');});};$('.searchbox-input-class').each(function(){$(this).change(function(){var qStr=$(this).val();if($(this).val().indexOf('@')!=-1){qStr=qStr.replace(/@/g,' ');$(this).val(qStr);}});});});function sticky_relocate(){var headerHeight=$('header#banner').height();var winHeight=$(window).height();if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.wide)){winHeight=winHeight-40;if(window.orientation==90||window.orientation==-90){winHeight=winHeight+50;}}else if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.wide)){winHeight=winHeight+40;}else{winHeight=winHeight+10;}$('#banner nav#sticky-nav.main').css("height",winHeight);if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var window_top=$(window).scrollTop();var div_top=$('#sticky-anchor').offset().top;if(window_top>div_top){$('#sticky-head').addClass('stick');$('#page-wrapper').addClass('top-pad');$('#banner .ad').addClass('top-margin');}else{$('#sticky-head').removeClass('stick');$('#page-wrapper').removeClass('top-pad');$('#banner .ad').removeClass('top-margin');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('section.topics').addClass('stick-topics');$('#sticky-head').addClass('stick-head');$('#page-wrapper').addClass('top-pad');$('#banner .ad').addClass('top-margin');$('#banner section.tools-expand').addClass('search');var window_top=$(window).scrollTop();var div_top=$('#sticky-anchor').offset().top+30;if(window_top>div_top){$('#sticky-head').addClass('stick');$('.topics.stick-topics, #search-form').addClass('remove');$('li.search-icon').fadeOut("fast");}else{$('#sticky-head').removeClass('stick');$('.topics.stick-topics, #search-form').removeClass('remove');$('li.search-icon').fadeIn("fast");}}if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){if($('#sticky-head').hasClass('stick')){var stickyHeaderHeight=$('section.main').height();stickyHeaderHeight=52;$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').addClass('stick');$('#sticky-nav').removeClass('no-stick');}else{stickyHeaderHeight=$('header#banner').height();$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').removeClass('stick');$('#sticky-nav').addClass('no-stick');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var stickyHeaderHeight=$('section.topics').height()+$('#sticky-head.main.stick-head').height();stickyHeaderHeight=stickyHeaderHeight-8;$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').addClass('stick');if($('#sticky-head').hasClass('stick')){$('#sticky-head.stick').siblings('#sticky-nav').addClass('nav-stick');$('#sticky-head').siblings('#sticky-nav').removeClass('no-stick');}else{$('#sticky-head').siblings('#sticky-nav').removeClass('nav-stick');$('#sticky-head').siblings('#sticky-nav').addClass('no-stick');}}}$(function(){$(window).scroll(sticky_relocate);sticky_relocate();});</script>
<div id="insider-popup" class="modal-box ">
<div class="insider-modal-wrapper">
<div class="modal-header-title">
<div class="modal-banner-insider"><span class="insider"></span></div>
<div class="modal-close close">×</div>
</div>
<div class="modal-body">
<script>$(document).ready(function(){$('a[data-link]').click(function(){var dataLink=$(this).attr('data-link');var toKeep='div[data-link="'+dataLink+'"]';$('div[data-link]').not(toKeep).hide();if($(this).hasClass('link-transition')){$(toKeep).fadeIn(800);}else{$(toKeep).show();}return false;});});</script>
</div>
<div class="modal-footer">
<div class="modal-close close-btn">Close</div>
</div>
</div>
</div>
<script>$(document).ready(function(){var appendthis=("<div class='modal-overlay modal-close'></div>");if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').css({top:10,left:0});}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').height($(document).height());$('.modal-box').css('top','0');}var userAg=navigator.userAgent;$('a[data-modal-id]').click(function(e){e.preventDefault();$('body').append(appendthis);$('.modal-overlay').fadeTo(500,0.9);$('.modal-overlay').height($(document).height());var modalBox=$(this).attr('data-modal-id');if($(".modal-box").hasClass('triggered')||(userAg.indexOf("Firefox")!=-1)){$('#'+modalBox).fadeIn($(this).data());}else{if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('#'+modalBox).toggle('slide',{direction:'up'},800);}else{$('#'+modalBox).toggle('slide',{direction:'left'},600);}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("html, body").animate({scrollTop:0},700);$('a.btn.continue-on').click(function(){$('html, body').animate({scrollTop:0},500);});return false;}if(navigator.userAgent.match(/(iPad)/)){$("html, body").animate({scrollTop:0},500);}});$(".modal-close, .modal-overlay").click(function(){$('.select2-drop').css('display','none');$(".modal-overlay").fadeOut(500,function(){$(".modal-overlay").remove();});if($(".modal-box").hasClass('triggered')||(userAg.indexOf("Firefox")!=-1)){$(".modal-box").fadeOut(500);}else{if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').toggle('slide',{direction:'up'},800);}else{$('.modal-box').toggle('slide',{direction:'left'},600);}}});});</script>
<!-- END PAGE HEADER -->
<div id="page-wrapper" class="page-wrapper">
<div id="skinAdTarget"></div>
<section role="main">
<article itemscope itemtype="http://schema.org/NewsArticle">
<div class="ticker-ad ad">
<div id="ticker" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("ticker","true");$('#ticker').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: ticker - [971 1115]");</script>
</div>
<!-- Events Header -->
<!-- //end Events Header -->
<header class='cat'>
<nav class="breadcrumbs horiz">
<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
<li><a href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
<li><a href="/category/enterprise-java/" itemprop="url"><span itemprop="title">Enterprise Java</span></a></li>
<li><a href="/category/application-development/" itemprop="url"><span itemprop="title">Java App Dev</span></a></li>
</ul>
</nav>
<div class="category"><a href="/news" itemprop="genre">News</a></div>
<h1 itemprop="headline">Scaled-down Scala variant cuts ties to the JVM</h1>
<section class="deck viewability">
<h2 itemprop="description">Taking advantage of the LLVM compiler platform, Scala Native expands language's opportunities on resource-constrained devices</h2>
</section>
<div class="cat-social">
<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">
<li class="sosh">
<a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.javaworld.com%2Farticle%2F3181872%2Fapplication-development%2Fscaled-down-scala-variant-cuts-ties-to-the-jvm.html&via=javaworldcom&text=Scaled-down+Scala+variant+cuts+ties+to+the+JVM" target="_blank" onclick="sharingTrack('Twitter-vert', 'twshare')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/twitter.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.javaworld.com%2Farticle%2F3181872%2Fapplication-development%2Fscaled-down-scala-variant-cuts-ties-to-the-jvm.html" target="_blank" onclick="sharingTrack('Facebook-vert', 'fblike')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/facebook.svg"/>
</a>
</li>
<li class="sosh">
<a href="http://www.linkedin.com/shareArticle?url=http%3A%2F%2Fwww.javaworld.com%2Farticle%2F3181872%2Fapplication-development%2Fscaled-down-scala-variant-cuts-ties-to-the-jvm.html&title=Scaled-down+Scala+variant+cuts+ties+to+the+JVM" target="_blank" onclick="sharingTrack('LinkedIn-vert')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/linkedin.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.javaworld.com%2Farticle%2F3181872%2Fapplication-development%2Fscaled-down-scala-variant-cuts-ties-to-the-jvm.html" target="_blank" onclick="sharingTrack('GooglePlus-vert', 'googplus')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/gplus.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="http://reddit.com/submit?url=http%3A%2F%2Fwww.javaworld.com%2Farticle%2F3181872%2Fapplication-development%2Fscaled-down-scala-variant-cuts-ties-to-the-jvm.html&title=Scaled-down+Scala+variant+cuts+ties+to+the+JVM" target="_blank" onclick="sharingTrack('Reddit-vert')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/reddit.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="http://www.stumbleupon.com/submit?url=http%3A%2F%2Fwww.javaworld.com%2Farticle%2F3181872%2Fapplication-development%2Fscaled-down-scala-variant-cuts-ties-to-the-jvm.html" target="_blank" onclick="sharingTrack('ShareStumbleupPrint-vert')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/stumbleupon.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="#email" id="email-icon">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/mail.svg"/>
</a>
</li>
<li class="sosh hide print">
<a href="javascript:window.print();">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/print.svg"/>
</a>
</li>
<li class="more">
<div class="more-icon" onclick="document.getElementById('share-tool').className = 'expand';"></div>
</li>
</ul>
</div>
<!-- Begin Eloqua Tracking -->
<script type="text/javascript" src="/www/js/analytics/eloqua/elqCfg.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqImg.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqFCS.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqScr.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqIDG.js"></script>
<script type="text/javascript">IDG=window.IDG||{};IDG.PageInfo=IDG.PageInfo||{};IDG.PageInfo=function(){return{eloqua_type:"article",eloqua_topic:"development"};}();var elqCustomerGUID="";if(this.GetElqCustomerGUID&&typeof GetElqCustomerGUID==="function"){elqCustomerGUID=GetElqCustomerGUID();}IDG.Eloqua.invoke_flash();</script>
<!-- End Eloqua Tracking -->
<script type="text/javascript">var isValidEmailAddress=isValidEmailAddress||function(emailAddress){var pattern=new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);return pattern.test(emailAddress);};function encodeQueryData(params){var ret=[];for(var paramKey in params){ret.push(encodeURIComponent(paramKey)+"="+encodeURIComponent(params[paramKey]));}return ret.join("&");}function bindEmailModal(){$('#emailModal').on("click",".close-btn",function(event){event.preventDefault();$('#emailModal').hide();$("#emailModal .eml-friend").show();$(".eml-friend-success").hide();$(".eml-friend-error").hide();$('#emailModal').fadeOut(200);$('#email-to').val('');$('#email-from').val('');$('#name').val('');$('#personalization').val('');$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");});$('#emailModal').on("submit","form",function(event){event.preventDefault();var $form=$(this);var action=$form.attr('action');var formData=$form.serialize();var emailFrom=$('#email-from').val();var emailTo=$('#email-to').val();var uresponse=$('#recaptcha_response_field').val()
$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");if(isValidEmailAddress(emailFrom)&&isValidEmailAddress(emailTo)&&uresponse!=""){var eloquaParam={AssetCountforCurrentCampaign:"1",AssetName:"",AssetTopic:"",AssetType:"",BuyingCycle:"",C_Address1:"",C_Address2:"",C_BusPhone:"",C_City:"",C_Company_Size1:"",C_Country:"",C_EmailAddress:"",C_FirstName:"",C_Industry1:"",C_Job_Role1:"",C_LastName:"",C_State_Prov:"",C_Zip_Postal:"",ClientName:"",ProgramName:"",brand:"",elqFormName:"CentralRegistrationMasterForm",formId:"3062313",elqSiteId:1856,elqCustomerGUID:elqCustomerGUID,elqCookieWrite:0,friend_email:emailFrom,friend_article_title:"Scaled-down Scala variant cuts ties to the JVM",friend_taxo:"Enterprise Java",friend_source:"InfoWorld",friend_article_url:"http://www.javaworld.com/article/3181872/application-development/scaled-down-scala-variant-cuts-ties-to-the-jvm.html",device_platform:navigator.userAgent};$.ajax("http://now.eloqua.com/e/f2.aspx",{type:'GET',data:eloquaParam,success:function(data,textStatus,xhr){},error:function(xhr,textStatus,errorThrown){}});var eloquaParamMini={elqCustomerGUID:elqCustomerGUID,friend_taxo:"Enterprise Java",friend_source:"InfoWorld",device_platform:navigator.userAgent};formData+="&"+encodeQueryData(eloquaParamMini);$.ajax(action,{type:'POST',data:formData,success:function(data,textStatus,xhr){if(data=='no-match'){Recaptcha.reload();$('#eml-friend-captcha-message').html("Invalid recaptcha - please re-enter the text below.");}else{$("#emailModal .eml-friend").hide();$(".eml-friend-success").fadeIn(800);}},error:function(xhr,textStatus,errorThrown){$("#emailModal .eml-friend").hide();$(".eml-friend-error").fadeIn(800);}});}else{if(uresponse==""){$('#eml-friend-captcha-message').html("Please type the text below.");}if(!isValidEmailAddress(emailTo)){$('#eml-to-address-message').html("Please enter a valid email address.");}if(!isValidEmailAddress(emailFrom)){$('#eml-from-address-message').html("Please enter a valid email address.");}}});}$(document).ready(function(){$(document).on("click","#email-icon",function(event){event.preventDefault();if(typeof Recaptcha=='undefined'){$.ajax({url:"//www.google.com/recaptcha/api/js/recaptcha_ajax.js",dataType:'script',cache:true,success:function(){Recaptcha.create("6LdPbfsSAAAAAB89GpzHsyYe-AGzZXYy9K_4KAnF","recaptcha_widget_div",{theme:"clean",callback:Recaptcha.focus_response_field});bindEmailModal();sharingTrack('Email-vert');$('#emailModal').fadeIn(800);}});}else{Recaptcha.reload();sharingTrack('Email-vert');$('#emailModal').fadeIn(800);}});});</script>
<div class="modal eml-friend-wrapper" id="emailModal" style="display:none;">
<form class="eml-friend" action="/eloquaemail/article?eloqua=true&id=3181872">
<input type="hidden" name="title" value="Scaled-down Scala variant cuts ties to the JVM"/>
<input type="hidden" name="url" value="http://www.javaworld.com/article/3181872/application-development/scaled-down-scala-variant-cuts-ties-to-the-jvm.html"/>
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Email a friend</h3>
<div class="input-row">
<div id="eml-to-address-message" class="error-msg"></div>
<h4 class="input-label">To</h4>
<input id="email-to" value="" placeholder="Email address (required)" type="email" name="recipients" tabindex="1">
<p class="addl-text">Use commas to separate multiple email addresses</p>
</div>
<hr/>
<div class="input-row">
<div id="eml-from-address-message" class="error-msg"></div>
<h4 class="input-label">From</h4>
<input id="name" value="" placeholder="Name (optional)" type="text" name="name" tabindex="2">
</div>
<div class="input-row">
<input id="email-from" value="" placeholder="Email address (required)" type="email" name="sender" tabindex="3">
</div>
<div class="input-row">
<textarea name="message" placeholder="Check out this article I found on JavaWorld." id="personalization" tabindex="4"></textarea>
</div>
<hr/>
<div class="input-row">
<div id="eml-friend-captcha-message" class="error-msg"></div>
</div>
<div id="recaptcha_widget_div"></div>
<noscript>
<iframe src="http://www.google.com/recaptcha/api/noscript?k=6LdPbfsSAAAAAB89GpzHsyYe-AGzZXYy9K_4KAnF" height="300" width="500" frameborder="0"></iframe><br>
<textarea id="recaptcha_challenge_field" name="recaptcha_challenge_field" rows="3" cols="40">
		     </textarea>
<input id="recaptcha_response_field" type="hidden" name="recaptcha_response_field" value="manual_challenge">
</noscript>
<hr/>
<div class="submit">
<input type="submit" value="Send" class="input-submit" tabindex="5">
<a href="/about/privacy.html" class="submit-privacy" target="_blank">Privacy Policy</a>
</div>
</form>
<div class="eml-ty eml-friend-success" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Thank you</h3>
<p class="msg-sent">Your message has been sent.</p>
</div>
<div class="eml-friend-error" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Sorry</h3>
<p class="msg-sent">There was an error emailing this page.</p>
</div>
</div>
</div>
<div class="cat byline vcard author with-image">
<div class="byline-wrapper">
<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
<a href="/author/Paul-Krill/" rel="author" title="Paul Krill"><img class="bylineImage  imgId100356327 " src="http://core0.staticworld.net/images/article/2014/07/paulkrill_crop-100356327-byline.jpg" width="34" width="34" alt="Paul Krill" itemprop="image"/></a>
By <span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Paul-Krill/"><span itemprop="name">Paul Krill</span></a></span>
</p>
<p class="dateline">
Editor at Large,
<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name"><a href="http://www.infoworld.com/" rel="nofollow" target="new">InfoWorld</a></span></span> <span class="divider break">|</span>
<span class="pub-date" class='break-date' itemprop="datePublished" content="2017-03-15T03:00-0700">Mar 15, 2017 3:00 AM
PT
</span>
</p>
</div>
</div>
<div class="ad viewability">
<div id="topleaderboard" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("topleaderboard","true");$('#topleaderboard').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: topleaderboard - [971 1115]");</script>
</div>
</header>
<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
<meta itemprop="representativeOfPage" content="1">
<img src="http://images.techhive.com/images/article/2017/03/scissors-100713530-large.jpeg" alt="Scaled-down Scala variant cuts ties to the JVM" itemprop="contentUrl"/>
<figcaption>
Credit:<span itemprop="copyrightHolder">
<a href="https://pixabay.com/en/scissor-hand-tool-cutting-sewing-1794088/" target="_blank" rel="nofollow">saeedkebriya</a>
</span>
</figcaption>
</figure>
<section class="epo cat-narrow" id="drr-top-ad">
<!-- Related -->
<div class="related-promo-wrapper">
<div class="promo apart">
<div class="hed">More like this</div>
<ul class="">
<li class="clearfix with-image">
<a href="/article/3069945/scripting-jvm-languages/scala-language-moves-closer-to-bare-metal.html"><img class="carousel.idgeImage  imgId100265318 " src="http://core5.staticworld.net/images/article/2014/05/industrial-metal-background-104829789-100265318-carousel.idge.jpg" alt="industrial metal background 104829789" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3069945/scripting-jvm-languages/scala-language-moves-closer-to-bare-metal.html">Scala language moves closer to bare metal</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3160526/application-development/infoworlds-2017-technology-of-the-year-award-winners.html"><img class="small.3x2Image  imgId100705414 " src="http://core0.staticworld.net/images/article/2017/01/toy2017-intro-final-100705414-small.3x2.jpg" alt="InfoWorld Technology of the Year 2017" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3160526/application-development/infoworlds-2017-technology-of-the-year-award-winners.html">InfoWorld&#039;s 2017 Technology of the Year Award winners</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3139912/scripting-jvm-languages/scala-upgrade-brings-closer-alignment-with-java-8.html"><img class="small.3x2Image  imgId100691546 " src="http://core5.staticworld.net/images/article/2016/11/16423912726_378c0907c7_k-100691546-small.3x2.jpg" alt="alignment balls" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3139912/scripting-jvm-languages/scala-upgrade-brings-closer-alignment-with-java-8.html">Scala upgrade brings closer alignment with Java 8 </a></div>
</div>
</li>
</ul>
</div>
</div>
<div class="ad">
<div id="topimu" class="adunit ad-container">
</div>
<script type="text/javascript">if($(window).width()>=930){IDG.GPT.addDisplayedAd("topimu","true");$('#topimu').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: topimu - [971 1115]");}</script>
</div>
</section>
<section class="bodee">
<div class="ad placement">
<!--  Begin gpt-skin/gpt-pin/inread -->
<div id="inread" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("inread","true");IDG.GPT.displayGoogleTagSlot('inread');</script>
<!--  End gpt-skin/gpt-pin/inread -->
</div>
<script type="text/javascript">$(document).ready(function(){$('.articleBloxAd').filter(":visible").each(function(index,item){var id=$(item).attr('id');var divClass=$(item).attr('class');var adString=IDG.GPT.getLazyAdCode();$(item).replaceWith("<div id=\""+id+"\" class=\"lazyload_blox_ad "+divClass+"\">"+adString+"</div>");});try{$("div.lazyload_blox_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});}catch(exception){console.log("error loading lazyload_ad "+exception);}});</script>
<script type="text/javascript">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</script>
<div id="drr-container" class='cat ' itemprop="articleBody">
<div class="lazyload_ad">
<code type="text/javascript">
<!--
			document.write('<div id="gpt-pin" class=" ad-container">');
			IDG.GPT.addDisplayedAd("gpt-pin", "true");
			IDG.GPT.addLazyloadedAd("gpt-pin", "true");
			document.write('</div>');
			
				
					IDG.GPT.displayGoogleTagSlot('gpt-pin');
				
				
			
			if (Object.keys(IDG.GPT.companions).length > 0) {
				IDG.GPT.refreshAd('gpt-pin');
			}
			//-->
</code>
</div>
<p>
<a href="http://www.infoworld.com/article/3068669/application-development/scala-language-moves-closer-to-bare-metal.html">Scala Native</a>, which brings the Scala language closer to bare metal by leveraging LLVM compiler infrastructure, has been released, expanding opportunities for the platform on smaller devices.
</p><p>
The project, which features an optimizing ahead-of-time compiler, has reached feature-completeness, said Denys Shabalin, who has been in charge of Scala Native. Unlike the reference implementation of Scala, which generates bytecode to run on top of the Java Virtual Machine, the Scala Native toolchain produces stand-alone native executables. Shabalin noted that "this opens the door for Scala to be used in environments where [a] full-blown virtual machine is usually an overkill: command-line tools, resource-constrained hardware applications, video games, etc."
</p><p>
Scala Native's key is the compiler generating LLVM intermediate representation, used to produce efficient platform-dependent machine code. The project also features a lightweight managed runtime and support for the entire Scala language with "neglible" semantic differences, Shabalin said. The 0.1 release offered this week supports existing Scala IDEs and integrates with the sbt build tool, and the core subset of JDK base libraries is supported as well.
</p><p>
Billed as a general-purpose language supporting functional and object-oriented paradigms, Scala itself also has been previously tweaked to compile to JavaScript <a href="http://www.infoworld.com/article/2898434/javascript/scalajs-lets-you-compile-scala-to-javascript.html">via Scala.js</a>. LLVM, meanwhile, features modular compiler and toolchain technologies, attempting to support both static and dynamic compilation of arbitrary programming languages. It just moved <a href="http://www.infoworld.com/article/3180344/application-development/llvm-coroutines-come-to-c-await-swift-and-rust.html">to a 4.0.0 release this week</a>, featuring improved performance and experimental support for coroutines, which can be an alternative to threading.
</p><aside class="nativo-promo smartphone" id=""> </aside>
<p class="orig">This story, "Scaled-down Scala variant cuts ties to the JVM" was originally published by
<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name"><a href="http://www.infoworld.com/" rel="nofollow" target="new">InfoWorld</a></span></span>.</p>
<div class="end-note">
</div>
</div>
<div class="apart-alt tags">
<span class="related">Related: </span>
<ul>
<li><a href="/category/application-development">Java App Dev</a></li>
<li><a href="/category/scripting-jvm-languages">Scripting and JVM Languages</a></li>
<li><a href="/category/development-tools">Development Tools</a></li>
<li><a href="/category/open-source-tools">Open Source</a></li>
</ul>
</div>
<div class="byline vcard author end-byline">
<div class="author-info">
<p class="bio">Paul Krill is an editor at large at InfoWorld, whose coverage focuses on application development.</p>
</div><!-- end .author-info -->
<div class="brand-social">
<div class="follow-text">Follow</div>
<ul class="social-links">
<li>
<a href="/author/Paul-Krill/">
<i class="ss-icon ss-user"></i>
</a>
</li>
<li>
<a href="mailto:paul_krill@infoworld.com">
<i class="ss-icon ss-mail"></i>
</a>
</li>
<li>
<a href="https://twitter.com/pjkrill" class="twitter-follow" target="_blank">
<i class="ss-icon ss-social ss-twitter"></i>
</a>
</li>
<li>
<a href="https://plus.google.com/108289165450818957590" class="googleplus-follow" target="_blank">
<i class="ss-icon ss-social ss-googleplus"></i>
</a>
</li>
<li>
<a href="/author/Paul-Krill/index.rss" class="rss">
<i class="ss-icon ss-social ss-rss"></i>
</a>
</li>
</ul>
</div>
</div>
<script src="/www/js/video/embedder.js?v=20170316112046"></script>
</section><!-- /.bodee -->
<div class="six-column" id="recommended">
<div class="head">Recommended</div>
<ul>
<li class=" first">
<figure class="well-img">
<a href="/article/3114167/development-tools/choosing-your-java-ide.html"><img class="lazy carousel.idgeImage  imgId100681048 " data-original="http://core4.staticworld.net/images/article/2016/09/jw-java-ides-100681048-carousel.idge.jpg" alt="JavaWorld Java IDEs review, September 2016"/></a>
</figure>
<div class="post-cont">
<div class="title">
<a href="/article/3114167/development-tools/choosing-your-java-ide.html">Eclipse, NetBeans, or IntelliJ? Choose your Java IDE</a>
</div>
</div>
</li>
<li class=" ">
<figure class="well-img">
<a href="/article/3148705/application-development/osgi-at-the-uks-biggest-science-lab.html"><img class="lazy small.3x2Image  imgId100703839 " data-original="http://core2.staticworld.net/images/article/2017/01/diamond-light-source-synchrotron-main-100703839-small.3x2.jpg" alt="diamond light source synchrotron main chamber"/></a>
</figure>
<div class="post-cont">
<div class="title">
<a href="/article/3148705/application-development/osgi-at-the-uks-biggest-science-lab.html">OSGi at the UK's biggest science lab</a>
</div>
</div>
</li>
<li class=" ">
<figure class="well-img">
<a href="/article/3104621/mobile-java/android-studio-for-beginners-part-2-explore-and-code-the-app.html"><img class="lazy smallImage  imgId100678712 " data-original="http://core2.staticworld.net/images/article/2016/08/android-beginners2-100678712-small.jpg" alt="android beginners2"/></a>
</figure>
<div class="post-cont">
<div class="title">
<a href="/article/3104621/mobile-java/android-studio-for-beginners-part-2-explore-and-code-the-app.html">Android Studio for beginners: Code the app</a>
</div>
</div>
</li>
<li class=" ">
<figure class="well-img">
<a href="/article/3123117/development-tools/open-source-java-projects-jenkins-with-docker-part-1.html"><img class="lazy carousel.idgeImage  imgId100685229 " data-original="http://core2.staticworld.net/images/article/2016/09/357376583_8381f9d690_z-100685229-carousel.idge.jpg" alt="CI/CD with Jenkins and Docker, Part 1"/></a>
</figure>
<div class="post-cont">
<div class="title">
<a href="/article/3123117/development-tools/open-source-java-projects-jenkins-with-docker-part-1.html">Jenkins with Docker, Part 1</a>
</div>
</div>
</li>
<li class="sponsored first">
<div class="item-eyebrow">
Video/Webcast
<br><span class="sponsored">Sponsored</span>
</div>
<div class="post-cont">
<div class="title">
<a href="http://resources.javaworld.com/ccd/assets/126995/detail">Building Cognitive IoT-Robotics-Mobile Messaging with Java, Watson and MobileFirst on Bluemix</a>
</div>
</div>
<p>Extending the value of your Java applications means more than just moving to the cloud. Business...</p>
</li>
</ul>
</div><!-- /.six-column -->
<section id="funnel">
<section class="popular-brand-cols">
<section class="popular-col">
<div class="promo with-eyebrow with-image">
<div class="eyebrow">Popular on JavaWorld</div>
<div class="sized-img"><a href="/article/3114167/development-tools/choosing-your-java-ide.html"><img class="lazy carousel.idgeImage  imgId100681048 " data-original="http://core4.staticworld.net/images/article/2016/09/jw-java-ides-100681048-carousel.idge.jpg" alt="JavaWorld Java IDEs review, September 2016" itemprop="image"/></a></div>
<div class="hed featured"><a href="/article/3114167/development-tools/choosing-your-java-ide.html">Eclipse, NetBeans, or IntelliJ? Choose your Java IDE</a></div>
<p>Find out what to look for in a Java IDE and get tips for deciding which of the top three--Eclipse,...</p>
<ul>
<li class="clearfix">
<a href="/article/3104621/mobile-java/android-studio-for-beginners-part-2-explore-and-code-the-app.html"><img class="lazy smallImage  imgId100678712 " data-original="http://core2.staticworld.net/images/article/2016/08/android-beginners2-100678712-small.jpg" alt="android beginners2" itemprop="image"/></a>
<div class="hed"><a href="/article/3104621/mobile-java/android-studio-for-beginners-part-2-explore-and-code-the-app.html">Android Studio for beginners: Code the app</a></div>
</li>
<li class="clearfix">
<a href="/article/3094782/open-source-tools/open-source-java-projects-docker-swarm.html"><img class="lazy carousel.idgeImage  imgId100671315 " data-original="http://core0.staticworld.net/images/article/2016/07/jw-dockerswarm-100671315-carousel.idge.jpg" alt="jw dockerswarm" itemprop="image"/></a>
<div class="hed"><a href="/article/3094782/open-source-tools/open-source-java-projects-docker-swarm.html">Open source Java projects: Docker Swarm</a></div>
</li>
</ul>
</div><!-- /.promo -->
<div class="promo newsletter with-eyebrow">
<!-- blx4 #680 blox4.html  -->
<div class="eyebrow">Newsletters</div> <div class="hed">Stay up to date on the latest tutorials and Java community news posted on JavaWorld</div> <p>Get our Enterprise Java newsletter</p> <form action="/newsletters/signup.html" method="post"> <input type="email" name="email" placeholder="Enter your email address"> <button class="btn" type="submit">GO</button> </form>
</div><!--  ./promo newsletter -->
<div class="promo with-image">
<div class="sized-img"><a href="/article/3062899/big-data/lightning-fast-nosql-with-spring-data-redis.html"><img class="lazy carousel.idgeImage  imgId100662713 " data-original="http://core3.staticworld.net/images/article/2016/05/rollercoaster-100662713-carousel.idge.jpg" alt="Redis NoSQL" itemprop="image"/></a></div>
<div class="hed"><a href="/article/3062899/big-data/lightning-fast-nosql-with-spring-data-redis.html">Lightning fast NoSQL with Spring Data Redis</a></div>
<p>Redis isn't your typical NoSQL data store, and that's exactly why it hits the sweet spot for certain...</p>
</div>
<div class="promo with-image">
<div class="sized-img"><a href="/article/3160526/application-development/infoworlds-2017-technology-of-the-year-award-winners.html"><img class="lazy medium.3x2Image  imgId100705414 " data-original="http://core4.staticworld.net/images/article/2017/01/toy2017-intro-final-100705414-medium.3x2.jpg" alt="InfoWorld Technology of the Year 2017" itemprop="image"/></a></div>
<div class="hed"><a href="/article/3160526/application-development/infoworlds-2017-technology-of-the-year-award-winners.html">InfoWorld&#039;s 2017 Technology of the Year Award winners</a></div>
<p>InfoWorld editors and reviewers pick the year's best hardware, software, development tools, and cloud...</p>
</div>
</section>
<section class="brand-col">
<div class="ad">
<div class="lazyload_ad">
<code type="text/javascript">
<!--
				IDG.GPT.IMUCounter = IDG.GPT.IMUCounter + 1;
				document.write('<div class="ad-container" id="' + IDG.GPT.getIMUSlotName() + '">'); 
				IDG.GPT.defineGoogleTagSlot(IDG.GPT.getIMUSlotName(), IDG.GPT.slots["topimu"], false);
				document.write('</div>');
				$('#' + IDG.GPT.getIMUSlotName()).responsiveAd({screenSize:'971 1115', scriptTags: []});
				if (Object.keys(IDG.GPT.companions).length > 0) {
					IDG.GPT.refreshAd(IDG.GPT.getIMUSlotName());
				}
			//-->
</code>
</div>
</div>
<div class="promo list" data-placement-id="">
<div class="eyebrow">
Popular Resources
</div>
<ul>
<li>
<div class="item-eyebrow">Video/Webcast<br/><span class="sponsored">Sponsored</span></div>
<div class="title">
<a href="http://resources.javaworld.com/ccd/assets/126995/detail">Building Cognitive IoT-Robotics-Mobile Messaging with Java, Watson and MobileFirst on Bluemix</a>
</div>
</li>
<li>
<div class="item-eyebrow">White Paper</div>
<div class="title">
<a href="http://resources.javaworld.com/ccd/assets/126992/detail">IBM Bluemix - From Idea to Application</a>
</div>
</li>
<li>
<div class="item-eyebrow">White Paper</div>
<div class="title">
<a href="http://resources.javaworld.com/ccd/assets/126985/detail">Microservices Without the Hassle of Infrastructure</a>
</div>
</li>
<li>
<div class="item-eyebrow">Video/Webcast<br/><span class="sponsored">Sponsored</span></div>
<div class="title">
<a href="http://resources.javaworld.com/ccd/assets/126988/detail">OpenWhisk Hello World Demonstration</a>
</div>
</li>
<li>
<div class="item-eyebrow">Video/Webcast<br/><span class="sponsored">Sponsored</span></div>
<div class="title">
<a href="http://resources.javaworld.com/ccd/assets/126997/detail">PointSource Shortens Scrum Meetings by 50 Percent with IBM DevOps Services for Bluemix</a>
</div>
</li>
</ul>
<form action="/resources/search" method="get">
<input type="text" name="query" placeholder="Search Resources" class="searchbox-input-class">
<!--  add additional dto options here -->
<input type="hidden" name="rid" value="2"/>
<input type="hidden" name="chld" value="true"/>
<button class="btn" type="submit">Go</button>
</form>
</div>
</section>
</section>
<section class="featured-col">
<!-- blx4 #676 blox4.link_list  -->
<div class="promo with-eyebrow with-image">
<div class="eyebrow">Featured Stories</div>
<div class="sized-img"><a href="/article/3180779/security/google-tries-to-beat-aws-at-cloud-security.html"><img class="lazy medium.3x2Image  imgId100692505 " data-original="http://core4.staticworld.net/images/article/2016/11/cloud-security-100692505-medium.3x2.jpg" alt="cloud security" itemprop="image"/></a></div>
<div class="hed featured"><a href="/article/3180779/security/google-tries-to-beat-aws-at-cloud-security.html">Google tries to beat AWS at cloud security</a></div>
<p>New tools that protect enterprise applications running on Google Cloud Platform may help take the...</p>
</div>
<div class="promo with-image">
<div class="sized-img">
<a href="/article/3172592/java-language/type-dependency-in-java-part-1.html"><img class="lazy medium.3x2Image  imgId100711646 " data-original="http://core2.staticworld.net/images/article/2017/03/variances-flickr-100711646-medium.3x2.jpg" alt="Type dependency and variances in Java " itemprop="image"/></a>
</div>
<div class="hed">
<a href="/article/3172592/java-language/type-dependency-in-java-part-1.html">Type dependency in Java, Part 1</a>
</div>
<p>Covariance and contravariance might seem esoteric, but you'll need these concepts more than ever as the...</p>
</div>
<div class="promo with-image">
<div class="sized-img">
<a href="/article/3180700/javascript/nginx-javascript-is-ready-for-prime-time.html"><img class="lazy medium.3x2Image  imgId100707389 " data-original="http://core4.staticworld.net/images/article/2017/02/16258492451_3a097a932a_k-100707389-medium.3x2.jpg" alt="JavaScript code" itemprop="image"/></a>
</div>
<div class="hed">
<a href="/article/3180700/javascript/nginx-javascript-is-ready-for-prime-time.html">Nginx JavaScript is ready for prime time</a>
</div>
<p>The Nginx Plus R12 server can be programmed using NginScript, a JavaScript-based tool </p>
</div>
<div class="promo with-image">
<div class="sized-img">
<a href="/article/3180847/application-development/googles-go-popularity-doesnt-translate-to-the-enterprise.html"><img class="lazy medium.3x2Image  imgId100703709 " data-original="http://core2.staticworld.net/images/article/2017/01/4536148364_b8df8836d0_b-100703709-medium.3x2.jpg" alt="Golang go puzzle pieces" itemprop="image"/></a>
</div>
<div class="hed">
<a href="/article/3180847/application-development/googles-go-popularity-doesnt-translate-to-the-enterprise.html">Google Go&#039;s popularity doesn&#039;t translate to the enterprise</a>
</div>
<p>Developers heartily recommend Go, but businesses have been slow on the uptake </p>
</div>
</section>
</section>
<div class="lazyload_ad">
<code type="text/javascript">
<!--
			document.write('<div id="ciu" class=" ad-container">');
			IDG.GPT.addDisplayedAd("ciu", "true");
			IDG.GPT.addLazyloadedAd("ciu", "true");
			document.write('</div>');
			
				
				
					$('#ciu').responsiveAd({screenSize:'971 1115', scriptTags: []});
				
			
			if (Object.keys(IDG.GPT.companions).length > 0) {
				IDG.GPT.refreshAd('ciu');
			}
			//-->
</code>
</div>
<section id="resources-sponsored-links">
<section class="sponsored-links">
<div class="head">Sponsored Links</div>
</section>
</section>
</article>
</section><!-- /role=main -->
</div><!-- /#page-wrapper -->
<footer>
<section class="brand" itemscope itemtype="http://schema.org/Organization">
<link itemprop="url" href="http://www.javaworld.com">
<a href="/"><span class="logo">JavaWorld</span></a>
<span class="tagline"> JavaWorld is the original independent resource for Java developers, architects, and managers.</span>
<span class="follow">
<label>Follow us</label>
<ul>
<li><a href="https://twitter.com/javaworldcom" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
<li><a href="http://www.linkedin.com/company/javaworld-com" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
<li><a href="https://www.facebook.com/pages/JavaWorld/107993545895326" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>
<li><a href="https://plus.google.com/117974570132126965756/posts" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>
<li><a href="/about/rss.html" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
</ul>
</span>
</section>
<section class="topics">
<nav id="ft1">
<ul>
<li><a href="/category/core-java/">Core Java</a>
</li>
<li class="selected"><a href="/category/enterprise-java/" class="active">Enterprise Java</a>
</li>
<li><a href="/category/learn-java/">Learn Java</a>
</li>
<li><a href="/category/mobile-java/">Mobile Java</a>
</li>
</ul>
</nav>
<nav id="ft2">
<ul>
<li><a href="/howto">How-Tos</a></li>
<li><a href="/feature">Features</a></li>
<li><a href="/news">News</a></li>
<li><a href="/blogs">Blogs</a></li>
<li><a href="/resources">Resources</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
</ul>
</nav>
</section>
<section class="about">
<div class="wrapper">
<nav class="tertiary" id="ft3">
<ul>
<li><a href="/about/about.html">About Us</a>
<li><a href="/about/contactus.html">Contact</a>
<li><a href="/about/privacy.html">Privacy Policy</a>
<li><a href="http://www.idgenterprise.com/reach/javaworld/" target="_blank" rel="nofollow">Advertising</a>
<li><a href="http://careers.idg.com/" target="_blank" rel="nofollow">Careers at IDG</a>
<li><a href="/about/sitemap.html">Site Map</a>
<li><a href="/about/adchoices.html">Ad Choices</a>
<li><a href="/about/affiliates.html">E-commerce Affiliate Relationships</a>
</ul>
</nav>
</div>
</section>
<section class="copyright">
<div class="wrapper">
<p><a href="/about/copyright.html">Copyright</a> &copy; 2017 IDG Communications, Inc.</p>
<div class="network">
<div id="network-selector">
<div class="label">Explore the IDG Network <i class="ss-icon tick">descend</i></div>
<ul>
<li><a href="http://www.cio.com" target="_blank" rel="nofollow">CIO</a></li>
<li><a href="http://www.computerworld.com" target="_blank" rel="nofollow">Computerworld</a></li>
<li><a href="http://www.csoonline.com" target="_blank" rel="nofollow">CSO</a></li>
<li><a href="http://www.greenbot.com" target="_blank" rel="nofollow">Greenbot</a></li>
<li><a href="http://www.idc.com" target="_blank" rel="nofollow">IDC</a></li>
<li><a href="http://www.idg.com" target="_blank" rel="nofollow">IDG</a></li>
<li><a href="http://www.idgconnect.com" target="_blank" rel="nofollow">IDG Connect</a></li>
<li><a href="http://www.idgknowledgehub.com" target="_blank" rel="nofollow">IDG Knowledge Hub</a></li>
<li><a href="http://www.idgtechnetwork.com" target="_blank" rel="nofollow">IDG TechNetwork</a></li>
<li><a href="http://www.idg.tv" target="_blank" rel="nofollow">IDG.TV</a></li>
<li><a href="http://www.idgventures.com" target="_blank" rel="nofollow">IDG Ventures</a></li>
<li><a href="http://www.infoworld.com" target="_blank" rel="nofollow">Infoworld</a></li>
<li><a href="http://www.itnews.com" target="_blank" rel="nofollow">IT News</a></li>
<li><a href="http://www.itwhitepapers.com" target="_blank" rel="nofollow">ITwhitepapers</a></li>
<li><a href="http://www.itworld.com" target="_blank" rel="nofollow">ITworld</a></li>
<li><a href="http://www.javaworld.com" target="_blank" rel="nofollow">JavaWorld</a></li>
<li><a href="http://www.linuxworld.com" target="_blank" rel="nofollow">LinuxWorld</a></li>
<li><a href="http://www.macworld.com" target="_blank" rel="nofollow">Macworld</a></li>
<li><a href="http://www.networkworld.com" target="_blank" rel="nofollow">Network World</a></li>
<li><a href="http://www.pcworld.com" target="_blank" rel="nofollow">PC World</a></li>
<li><a href="http://www.techconnect.com" target="_blank" rel="nofollow">TechConnect</a></li>
<li><a href="http://www.techhive.com" target="_blank" rel="nofollow">TechHive</a></li>
</ul>
</div><!-- /#network-selector -->
</div><!-- /.network -->
</div><!-- /.wrapper -->
</section>
</footer>
<script src="/www/js/analytics/mouse_down.js?v=20170316112046"></script>
<script src="/www/js/jquery/jquery-ui.js?v=20170316112046"></script>
<script src="/www/js/jquery/jquery.dfp.min.js?v=20170316112046"></script>
<script src="/www.idge/js/FTScroller_plugins.js?v=20170316112046"></script>
<script src="/www.idge/js/mule/shortstack_nav.js?v=20170316112046"></script>
<script src="/www.idge/js/jquery/jt-scrollable.min.js?v=20170316112046"></script>
<div id="mobilewelcomead" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("mobilewelcomead","true");$('#mobilewelcomead').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: mobilewelcomead - [971 1115]");</script>
<script src="/www/js/analytics/tracking.js?v=20170316112046"></script>
<script src="/www/js/autocomplete.js?v=20170316112046"></script>
<script type="text/javascript">$(document).ready(function(){var listItems=$('#scrollable ul li');var listWidth=0;for(var i=0;i<listItems.length;i++){listWidth=listWidth+$(listItems[i]).outerWidth();}$('#scrollable ul').width(listWidth+100);var trackPointerEvents=window.navigator.msPointerEnabled;if(!trackPointerEvents){var scroller=new FTScroller(document.getElementById('scrollable'),{scrollingY:false,bouncing:false,updateOnWindowResize:true,scrollbars:false});}});</script>
<script src="/www.idge/js/social_sidecar.js?v=20170316112046"></script>
<script src="/www/js/carousel-extend.js?v=20170316112046"></script>
<script src="/www.idge/js/jquery/plugins/jquery.colorbox-min.js?v=20170316112046"></script>
<script src="/www.idge/js/article.js?v=20170316112046"></script>
<script src="/www/js/prettify.js?v=20170316112046"></script>
<script src="/www.idge/js/jquery/responsive-tables.js?v=20170316112046"></script>
<script src="/www.idge/js/jquery/jquery.tablesorter.min.js?v=20170316112046"></script>
<script>$(document).ready(function(){$("table.tablesorter").tablesorter({widgets:['zebra']});$("table.tablesorter tbody tr").hover(function(){$(this).toggleClass("selected");});$("table.tablesorter thead tr th").each(function(){if($(this).find('.ss-icon').length<1){$(this).append('<i class="ss-icon"></i>');}});});</script>
<script src="/www/js/jquery/jquery.lazyload.min.js?v=20170316112046"></script>
<script src="/www.idge/js/global.js?v=20170316112046"></script>
<script src="/www/js/webfonts/ss-social.js?v=20170316112046"></script>
<script src="/www/js/webfonts/ss-standard.js?v=20170316112046"></script>
<script src="/www/js/analytics/brandAnalytics.js"></script>
<!-- Begin BlueKai Tag -->
<iframe name="__bkframe" height="0" width="0" frameborder="0" src="javascript:void(0)"></iframe>
<script type="text/javascript" src="http://tags.bkrtx.com/js/bk-coretag.js"></script>
<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
<!-- CryptoJS -->
<script src="/www/js/utils/md5.js"></script>
<script type="text/javascript" src="/www/js/analytics/idg_bk_coreapi.js?v=20170316112046"></script>
<script type="text/javascript">bk_allow_multiple_calls=true;var blueKaiId=14349;var blueKaiPort=10;var brandCode="jvw";var regUrl="http://regdev.idge.int/api/"
var daysToRefresh=30;var bk_debug_log=false;regUrl="http://reg.idgenterprise.com/api/";daysToRefresh=30;if(typeof(s)!='undefined'){bk_addPageCtx("pageType",(typeof(s.pageType)!='undefined')?s.pageType:'');}bk_addPageCtx("cmscatids","[3646,3249,3465,3248]");bk_addPageCtx("cmpy","[]");bk_addPageCtx('tid','2');bk_addPageCtx("purchaseintent","awareness");params=getUrlParams('phint');if(Object.keys(params).length>0){bk_addPageCtx("idg_eid",params['idg_eid']);bk_addPageCtx("newt",params['newt']);bk_addPageCtx("isnl","1");}try{IDG.bkCoreApi.start();}catch(e){bk_doJSTag(blueKaiId,blueKaiPort);if(window.console&&window.console.log){window.console.log("Error Occured While Processing Profile Siubmission")}}$('article, #slideshowCarousel').on('click','.product-list-price, .btn-amazon, .productLink',function(e){var $linkEl=$(e.target);var po=$linkEl.data('po');if($.inArray(po,['amazon','vendor','other'])>=0){if(po=='amazon'){var prCat=$linkEl.data('bkc');if(typeof prCat!='undefined'){bk_addPageCtx('event','AmazonClick'+prCat);}bk_addPageCtx('event','AmazonClickJavaAppDev');bk_addPageCtx('event','AmazonClickScriptingandJVMLanguages');bk_addPageCtx('event','AmazonClickDevelopmentTools');bk_addPageCtx('event','AmazonClickOpenSource');}var prMfr=$linkEl.data('bkmfr');if(typeof prMfr!='undefined'){bk_addPageCtx('event','eCommerceMFR'+prMfr);}var prVndr=$linkEl.data('bkvndr');if(typeof prVndr!='undefined'){bk_addPageCtx('event','eCommerceClickVendor'+prVndr);}bk_doJSTag(34202,1);}});</script>
<!-- End BlueKai Tag -->
<!-- Begin welcome ad overlay - gpt-overlay position  -->
<div id="superadunit" class="hidden">
<div class="ad">
<a href="javascript:unhide('superadunit');" id="superstitial-text">This ad will close in 20 seconds. Continue to site &raquo;</a>
<div id="gpt-overlay" class=" ad-container">
<script type="text/javascript">IDG.GPT.addDisplayedAd("gpt-overlay","true");IDG.GPT.displayGoogleTagSlot('gpt-overlay');</script>
</div>
</div>
</div>
<!--  End welcome ad overlay - gpt-overlay position -->
<div id="catfish" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("catfish","true");$('#catfish').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: catfish - [971 1115]");</script>
<!--  Begin gpt-skin/gpt-pin/inread -->
<div id="gpt-skin" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("gpt-skin","true");IDG.GPT.displayGoogleTagSlot('gpt-skin');</script>
<!--  End gpt-skin/gpt-pin/inread -->
<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js?v=20170316112046"></script>
<script type="text/javascript">$("div.lazyload_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});</script>
<script type='text/javascript'>g_arrModules['']=true;g_arrModules['Article Detail:Top:Breadcrumb']=true;g_arrModules['Article Detail:Social Sharing Vertical']=true;g_arrModules['Article Detail:Left:Recommended']=true;g_arrModules['Article Detail:Funnel:Popular Articles']=true;g_arrModules['']=true;g_arrModules['Article Detail:Funnel:Sponsored Blog Posts']=true;g_arrModules['Article Detail:Funnel:Module Resources']=true;g_arrModules['Article Detail:Funnel:Homepage Top Story']=true;g_arrModules['Article Detail:Funnel:Funnel Crawl']=true;</script>
<!-- Begin comScore Tag -->
<script>var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"6035308",c3:"",c5:"Java App Dev",c6:"Article: News",c15:"3181872"});(function(){var s=document.createElement("script"),el=document.getElementsByTagName("script")[0];s.async=true;s.src=(document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s,el);})();</script>
<noscript>
<img src="http://b.scorecardresearch.com/p?c1=2&c2=6035308&cv=2.0&cj=1"/>
</noscript>
<!-- End comScore Tag -->
<script language="JavaScript" type="text/javascript">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</script>
<!-- SiteCatalyst code version: H.26.2.
Copyright 1996-2013 Adobe, Inc. All Rights Reserved
More info available at http://www.omniture.com -->
<script language="JavaScript" type="text/javascript" src="/www.idge/js/analytics/s_code.js?v=20170316112046"></script>
<script language="JavaScript" type="text/javascript" id="omniVars">g_sOmnitureReportSuite=typeof g_sOmnitureReportSuite!='undefined'&&g_sOmnitureReportSuite?g_sOmnitureReportSuite:"idgjavaworld";s.pageName="InfoWorld:article:news:Application Development:3181872:Scaled-down Scala variant cuts ties to the JVM";s.pageType="";if(typeof omnitureChannel!='undefined'){s.channel=omnitureChannel;}s.prop1="source:infoworld";s.eVar1="D=c1";s.prop2="content type:news";s.eVar2="D=c2";s.prop3="display type:article:news";s.eVar3="D=c3";s.prop4="1 days";s.eVar4="D=c4";s.prop6="";s.prop7="";s.eVar7="D=c7";s.prop9="category:application development";s.eVar9="D=c9";s.prop11="published:15-Mar-17";s.eVar11="D=c11";s.prop12="aid:3181872";s.eVar12="D=c12";s.prop13="";s.eVar13="D=c13";s.prop14="author:paul krill";s.eVar14="D=c14";s.prop15="page number:1";s.eVar15="D=c15";s.prop17="uri:/article/3181872/application-development/scaled-down-scala-variant-cuts-ties-to-the-jvm.html";s.eVar17="D=c17";s.prop18="";s.eVar18="D=c18";s.prop24=getLoginStatusForOmniture();s.eVar24="D=c24";s.prop28=getTrackingToken('tk')?"tokens:"+getTrackingToken('tk'):"";s.eVar28="D=c28";s.prop37="rpn:jvw:news:infoworld:article:news:application development:3181872:scaled-down scala variant cuts ties to the jvm";s.eVar37="D=c37";s.prop39="";s.eVar39="D=c39";s.prop40="";try{s.prop41=IDG.GPT.getDisplayedAds(',')+','+IDG.GPT.getOtherAds(',');s.prop42=IDG.GPT.getModules(',');s.eVar42="D=c42";}catch(e){console.log("error in setting omniture vars: "+e);}s.prop53="3646";s.eVar53="D=c53";s.prop54="application development,scripting and jvm languages,development tools,open source";s.eVar30="D=c54";s.eVar33=s.prop55="3646,3249,3465,3248";s.eVar33="D=c55";s.prop56="";s.eVar40="D=c56";s.prop61="";s.eVar10="D=c61";s.prop63="awareness";s.prop74="architecture";s.eVar58="D=c74";s.prop75="software-development";s.eVar60="D=c75";s.prop58="architecture:software-development";s.eVar59="D=c58";var sModules='';for(var i in g_arrModules){if(g_arrModules[i]&&i!=''){sModules+=i+',';}}sModules=sModules.replace(/,$/,'');s.prop42=sModules;s.eVar42="D=c42";s.events="";s.events=s.apl(s.events,'event33',',');s.eVar41="15-Mar-17";s.list3=s.prop42+","+s.eVar42;for(var p in s){if(s[p]&&p.match(/^(prop|ceVar)\d+$/)){s[p]=s[p].toLowerCase();}}s.campaign=s.getQueryParam('cid');var s_code=s.t();if(s_code)document.write(s_code)</script>
<script language="JavaScript" type="text/javascript">if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')</script><noscript><img src="http://idgenterprise.d1.sc.omtrdc.net/b/ss/idgjavaworld/1/H.25--NS/0" height="1" width="1" border="0" alt=""/></noscript><!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: H.26.2. -->
<script type="text/javascript">$thm.logPlEvent({"b":"jvw","e":"view","t":"article","id":"3181872"});</script>
<div id="loginModal"></div>
<div id="logoffModal"></div>
<script type="text/javascript">(function(){function loadHorizon(){var s=document.createElement('script');s.type='text/javascript';s.async=true;s.src=location.protocol+'//ak.sail-horizon.com/horizon/v1.js';var x=document.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);}loadHorizon();var oldOnLoad=window.onload;window.onload=function(){if(typeof oldOnLoad==='function'){oldOnLoad();}Sailthru.setup({domain:'horizon.javaworld.com',useStoredTags:false});};if(console!=undefined){console.log('SAIL-23 fired Horizon');}})();</script>
</body>
</html>