
<!DOCTYPE html>
<!--[if lt IE 7]>  <html lang="en" class="lt-ie9 lt-ie8 lt-ie7" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]> <html lang="en" class="lt-ie10 lt-ie9 lt-ie8" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]> <html lang="en" class="lt-ie10 lt-ie9" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="lt-ie10" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
<!-- ad-related js -->
<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
<script src="/www/js/init_device.js"></script>
<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20180507013149"></script>
<script type="text/javascript">if(adLayer==null||adLayer=='undefined'){var adLayer=[];}adLayer["itemType"]="article";</script>
<script type="text/javascript">try{IDG.GPT.unitName="/8456/IDG.US_E_JavaWorld.com";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.unitName=IDG.GPT.unitName+"/"+"java_section";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}var global_ShowSuper=true;var global_ShowHero=false;var url=window.location.href;if(url.indexOf("?")>1){url=url.split('?')[0];}try{IDG.GPT.addTarget("URL",encodeURIComponent(url));}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("zone",'article/java-language');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("channel",'core-java,enterprise-java');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("articleId",'3270926');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("type",'news');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("typeId",'2');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("templateType",'article-default');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categoryIds",[3469,3217,3248,3646]);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categorySlugs",['java-language','java-platform','open-source-tools','application-development']);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{if(null!=IDG.GPT.getQsVal("env")){IDG.GPT.addTarget("env",IDG.GPT.getQsVal("env").replace(/\W/g,""));}}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("author",'Paul Krill');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("page_type",'');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("tagNames",'Oracle,Eclipse');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("insiderContent",'false');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}</script>
<script type="text/javascript"></script>
<script src="/www.idge/js/thm_pre.js?v=20180507013149"></script>
<script type="text/javascript">(function(){try{var proximic_data={"data":["300003","131100","121100","112200","131119","131112","240000","240002","240003","240004","240001","240005","240006","240007","240008","240009","240011","240012","240013","240014","240017","240015","240016","e2co9k","20f4sh","r03wnl","folvaf","bkwp85","enwcef","44ywyv","bsuu95","xks7sj","x8eev1","agtqg7","7grvv1","agt9m3","9v0tiu","qh9ovz","pcz604","skl8g2","wq79u8","li8svo","500088","500192","500247","500235","500238"]};IDG.GPT.addTarget("proximic",proximic_data.data);}catch(e){console.log("Error: "+e);}})();</script>
<script>var isMobile=(typeof IDG.DEVICE!=='undefined')?IDG.DEVICE.isMobile():false;try{IDG.GPT.addBiddingParams("yieldbotPsn",(isMobile?"7541":"c5a9"));IDG.GPT.addBiddingParams("appnexusPlacementId",(isMobile?"6451477":"6353206"));IDG.GPT.addBiddingParams("TriLiftPrefix","javaworld_ros_");}catch(e){console.log("Error in adding bidding params: "+e);}</script>
<script src="/www/js/ads/narf_prebid.js?v=20180507013149"></script>
<script type="text/javascript" src="/www/js/ads/gpt_starter.js?1234"></script>
<script type="text/javascript" src="/www/js/ads/gpt_launcher.js"></script>
<!-- metas -->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<title>Java will no longer have ‘major’ releases | JavaWorld</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="canonical" href="https://www.infoworld.com/article/3269859/java/java-will-no-longer-have-major-releases.html"/>
<meta itemprop="url" content="https://www.javaworld.com/article/3270926/java-language/java-will-no-longer-have-major-releases.html"/>
<meta name="description" content="The twice-yearly Java releases will get new version numbers, but they won’t have the degree of change that whole version numbers have historically indicated"/>
<meta name="news_keywords" content="Java 10,Java 11"/>
<meta name="DC.date.issued" content="2018-05-08T03:00-05:00"/>
<meta name="date" content="2018-05-08"/>
<link rel="amphtml" href="https://www.javaworld.com/article/3270926/java-language/java-will-no-longer-have-major-releases.amp.html"/>
<meta property="og:title" content="Java will no longer have ‘major’ releases">
<meta property="og:description" content="The twice-yearly Java releases will get new version numbers, but they won’t have the degree of change that whole version numbers have historically indicated">
<meta property="og:image" content="https://images.techhive.com/images/article/2017/02/intel_coffee_lake_figurative_image-100708700-large.3x2.jpg"/>
<meta property="og:image:width" content="700"/>
<meta property="og:image:height" content="467"/>
<meta itemprop="image" content="https://images.techhive.com/images/article/2017/02/intel_coffee_lake_figurative_image-100708700-large.3x2.jpg">
<meta itemprop="thumbnailURl" content="https://images.techhive.com/images/article/2017/02/intel_coffee_lake_figurative_image-100708700-large.3x2.jpg"/>
<link rel="image_src" href="https://images.techhive.com/images/article/2017/02/intel_coffee_lake_figurative_image-100708700-large.3x2.jpg"/>
<meta name="twitter:image" content="https://images.techhive.com/images/article/2017/02/intel_coffee_lake_figurative_image-100708700-large.3x2.jpg"/>
<meta property="og:type" content="article"/>
<meta name="author" content="Paul Krill">
<meta property="og:site_name" content="JavaWorld"/>
<meta property="fb:app_id" content="196366870381968"/>
<meta property="og:url" content="https://www.javaworld.com/article/3270926/java-language/java-will-no-longer-have-major-releases.html">
<!-- Use Twitter Summary Card with Large Image for articles and videos -->
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@javaworldcom">
<meta name="twitter:description" content="The twice-yearly Java releases will get new version numbers, but they won’t have the degree of change that whole version numbers have historically indicated">
<meta name="rating" content="General">
<meta name="robots" content="NOODP,NOYDIR"/>
<meta name="msvalidate.01" content="04917178B598F0648B9BAD693FEC29A3"/>
<!-- Sailthru -->
<meta name="sailthru.tags" content="java-language,java-platform,open-source-tools,application-development,oracle,eclipse,paul-krill,news,short"/>
<meta name="sailthru.image.thumb" content="https://images.techhive.com/images/article/2017/02/intel_coffee_lake_figurative_image-100708700-small.jpg"/>
<meta name="sailthru.image.full" content="https://images.techhive.com/images/article/2017/02/intel_coffee_lake_figurative_image-100708700-large.3x2.jpg"/>
<meta name="sailthru.title" content="Java will no longer have ‘major’ releases"/>
<meta name="sailthru.description" content="The twice-yearly Java releases will get new version numbers, but they won’t have the degree of change that whole version numbers have historically indicated"/>
<meta name="displaytype" content="article"/>
<meta name="source" content="infoworld"/>
<meta name="category" content="java,java platform,open source,software development"/>
<meta name="storytype" content="news"/>
<meta name="tags" content="oracle,eclipse"/>
<!-- pagination -->
<link id="mobile-size" rel="stylesheet" href="/www.idge/css/inline-header-mobile.css?v=20180507013149"/>
<script>if(window.matchMedia("(min-width: 768px)").matches){document.getElementById('mobile-size').insertAdjacentHTML('afterend','<link id="desktop-size" rel="stylesheet" href="/www.idge/css/inline-header.css?v=20180507013149" />');}</script>
<link rel="stylesheet" href="/www.idge.jvw/css/inline-header.css?v=20180507013149"/>
<!-- css -->
<link rel="stylesheet" href="/www.idge/css/normalize.css"/>
<link rel="stylesheet" href="/www.idge/css/prettify.css"/>
<link rel="stylesheet" href="/www.idge.ans/js/select2-3.5.0/select2.css"/>
<link rel="stylesheet" href="/www/css/article.css?v=20180507013149"/>
<link rel="stylesheet" href="/www.idge/css/insider-promo-styles.css?v=20180507013149"/>
<link rel="stylesheet" href="/www.idge/css/print.css" media="print"/>
<link rel="stylesheet" href="/www.idge.jvw/css/article.css?v=20180507013149"/>
<link rel="stylesheet" href="/www.idge/css/webfonts/ss-social.css"/>
<link rel="stylesheet" href="/www.idge/css/webfonts/ss-standard.css"/>
<!--[if lte IE 8]>  
		<link href="/www.idge/css/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]-->
<link href="//fonts.googleapis.com/css?family=PT+Sans:400,700|PT+Sans+Narrow:400,700" rel="stylesheet" type="text/css"/>
<!--  fav and touch icons -->
<link rel="shortcut icon" type="image/x-icon" href="/www.idge.jvw/favicon.ico"/>
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="/www.idge.jvw/touchicon_144.gif"/>
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="/www.idge.jvw/touchicon_114.gif"/>
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="/www.idge.jvw/touchicon_72.gif"/>
<link rel="apple-touch-icon-precomposed" sizes="57x57" href="/www.idge.jvw/touchicon_57.gif"/>
<link rel="apple-touch-icon" href="/www.idge.jvw/images/JVW_logo_300x300.png"/>
<!-- LiveRamp Sources -->
<script type="text/javascript" src="//storage.googleapis.com/cdn.pippio.com/sdk/pippio.min.js" async></script>
<script src="/www/js/utils/liveRamp.js"></script>
<!-- End of LiveRamp -->
<script src="/www.idge.ans/js/select2-3.5.0/select2.js"></script>
<script>$(document).ready(function(){$("select#country").select2({placeholder:"country",minimumResultsForSearch:Infinity,allowClear:true});$("#jobPosition").select2({placeholder:"position",minimumResultsForSearch:Infinity,allowClear:true});$("#jobFunction").select2({placeholder:"function",minimumResultsForSearch:Infinity,allowClear:true});$("#companySize").select2({placeholder:"company size",minimumResultsForSearch:Infinity,allowClear:true});$("#industry").select2({placeholder:"industry",minimumResultsForSearch:Infinity,allowClear:true});});</script>
<script>var brandCode="jvw";var brandName="JavaWorld";var regDebugLog=false;var regApiUrl="https://regdev.idge.int/api/";var tokenPrefix='www';var tokenSuffix='.com/insider/token?';var brandDomain=".javaworld.com";var insiderContentType="article";var notEmptyArticle=false;var notEmptyMediaResource=false;var isInsiderPremium=false;var isResourceInsiderPremium=false;regApiUrl="https://reg.idgenterprise.com/api/";regDebugLog=false;tokenPrefix="http://www";tokenSuffix="/insider/token";notEmptyArticle=true;</script>
<script src="/www/js/utils/alc_hashes.js"></script>
<script src="/www/js/insider/insider_reg_api.js?v=20180507013149"></script>
<script src="/www/js/insider/jquery.maskedinput-1.4.min.js"></script>
<script>$(document).ready(function(){if(typeof(IDG.insiderReg.readCookie('nsdr'))!=='undefined'){$('#welcome-message').show();IDG.insiderReg.personalize();}else{$('.signin-register').show();}});</script>
<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
<script src="/www/js/ads/ads.js"></script>
<script>var insiderSignedIn=document.cookie.indexOf("nsdr")>-1;var dlJobFunction='';var dlJobPosition='';var dlIndustry='';if(insiderSignedIn){var insiderToken=IDG.insiderReg.readCookie("nsdr");var tokens=IDG.insiderReg.readCookieProperty(insiderToken);if(!(tokens['jobPosition']===undefined)){dlJobPosition=tokens['jobPosition'];}if(!(tokens['jobFunction']===undefined)){dlJobFunction=tokens['jobFunction'];}if(!(tokens['industry']===undefined)){dlIndustry=tokens['industry'];}}insiderSignedIn=insiderSignedIn.toString();var sincePublished='0 days';sincePublished=sincePublished.split(" ")[0];dataLayer=[{'articleId':'3270926','articleDisplayId':'1','articleTitle':'Java will no longer have ‘major’ releases','articleType':'News','audience':'enterprise','author':'Paul Krill','blogName':'','brandpost':'false','categoryIdList':'3469,3217,3248,3646','categoryIdPrimary':'3469','contentStrategy':'','contentType':'news','datePublished':'2018-05-08','dateUpdated':'','daysSincePublished':sincePublished,'daysSinceUpdated':'','displayType':'article','environment':'production','ga_enabled':'true','gaTrackingId':'UA-300704-19','geolocEnabled':'true','industry':dlIndustry,'insiderSignedIn':insiderSignedIn,'isBlog':'false','isInsiderContent':'false','isICN':'false','jobFunction':dlJobFunction,'jobPosition':dlJobPosition,'oneRegPlacementID':oneRegPlacementID,'pageNumber':'1','platform':'Web','primaryCategory':'java','primaryCategoryList':'java,java platform,open source,software development','property':'javaworld','propertyCountry':'US','purchaseIntent':'awareness','sailthruCustomerId':'8a7950ccf4b505820f4688ea815011b6','skimlinksId':'','source':'infoworld','sponsorName':'','tags':'oracle,eclipse','videoAutoplay':'false','articleHasVideo':'false'}];</script>
<script type="text/javascript">var _sf_async_config={};_sf_async_config.uid=29363;_sf_async_config.path="/article/3270926/java-language/java-will-no-longer-have-major-releases.html";_sf_async_config.title="Java will no longer have ‘major’ releases | JavaWorld";_sf_async_config.domain="javaworld.com";if(window.location.href.indexOf("video")&&true){_sf_async_config.playerdomain=_sf_async_config.domain.replace("www.","");}_sf_async_config.useCanonical=true;_sf_async_config.sections="java-language";_sf_async_config.authors="Paul Krill";</script>
<script>var dataLayer=window.dataLayer=window.dataLayer||[];var adBlockStatus='false';function AdBlockEnabled(){var ad=document.createElement('ins');ad.className='AdSense';ad.style.display='block';ad.style.position='absolute';ad.style.top='-1px';ad.style.height='1px';if(document.body!=null){document.body.appendChild(ad);var isAdBlockEnabled=!ad.clientHeight;document.body.removeChild(ad);}return isAdBlockEnabled;}if(AdBlockEnabled()!=undefined){adBlockStatus=AdBlockEnabled().toString();}if(document.body==null){if(window.canRunAds===undefined){adBlockStatus='true';}else{adBlockStatus='false';}}dataLayer.push({'adBlockStatus':adBlockStatus});</script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-MMJKZ9" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-MMJKZ9');</script>
<!-- End Google Tag Manager -->
<script src="https://www.google.com/recaptcha/api.js" async defer></script>
<script async src="//js-sec.indexww.com/ht/p/187051-164251026496775.js"></script>
</head>
<body id="article3270926" class="article javaworld">
<!-- Begin welcome ad overlay - gpt-overlay position  -->
<div id="superadunit" class="hidden">
<div class="ad">
<div class="ad-header">
<div class="brand-logo"></div>
<a href="javascript:unhide('superadunit');" id="superstitial-text">Close Ad</a>
</div>
<div id="gpt-overlay" class=" ad-container">
<script type="text/javascript">IDG.GPT.addDisplayedAd("gpt-overlay","true");IDG.GPT.displayGoogleTagSlot('gpt-overlay');</script>
</div>
</div>
</div>
<!--  End welcome ad overlay - gpt-overlay position -->
<!-- BEGIN PAGE HEADER -->
<header id="banner">
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.main-header').insertBefore($('#banner .ad'));}</script>
<div class="topics-wrap">
<section class="topics">
<nav id="scrollable">
</nav>
<div class="fading-gradient"></div>
<nav class="tools">
<ul class="user">
<li class="search-icon"><a href="#search" id="search-btn"><i class="ss-icon">Search</i></a></li>
</ul>
<ul class="social">
<li><a href="https://twitter.com/javaworldcom" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
<li><a href="http://www.linkedin.com/company/javaworld-com" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
<li><a href="https://www.facebook.com/pages/JavaWorld/107993545895326" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>
<li><a href="https://plus.google.com/117974570132126965756/posts" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>
<li><a href="/index.rss" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
<li class="more-social"><i class="ss-icon ss-ellipsis"></i></li>
</ul>
</nav>
</section>
</div>
<div id="sticky-anchor"></div>
<section id="sticky-head" class="main">
<div class="wrapper">
<div class="masthead">
<button><i class="ss-icon ss-rows"></i></button>
<a href="/"><span class="ir logo">javaworld</span></a>
<!--
	            	<img class="print-only" src="/www.idge.jvw/images/javaworld-logo-print.png">
	            	-->
<img class="print-only" src="//idge.staticworld.net/jvw/javaworld-logo-print.png">
</div>
<div id="reading-tools-wrapper">
<nav class="tools">
<ul class="user">
</ul>
</nav>
</div>
<div class="insider-signin">
<span class="signin-register">
<a href="/learn-about-insider/"><span class="insider"></span></a> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-signin')" class="js-open-modal signin" data-modal-id="insider-popup">Sign In</a> <span class="divider">|</span> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-form-short')" class="js-open-modal register" data-modal-id="insider-popup">Register</a>
</span>
<div id="welcome-message" class="insider-list">
<div id="insider-selector">
<div id="insider-welcome" class="label"></div>
<div class="stories">
<div class="personalization">Hi<span id="person-first-name"></span>! Here are the latest Insider stories.</div>
<ul>
<li><a href="/article/3269522/application-development/the-5-best-programming-languages-for-ai-development.html">The 5 best programming languages for AI development</a></li>
<li><a href="/article/3264349/cloud-computing/aws-lambda-tutorial-get-started-with-serverless-computing.html">AWS Lambda tutorial: Get started with serverless computing</a></li>
<li><a href="/article/3262672/application-development/cosmos-db-review-database-for-a-small-planet.html">Cosmos DB review: Database for a small planet</a></li>
<li><a href="/article/3258886/open-source-tools/github-tutorial-get-started-with-github.html">GitHub tutorial: Get started with GitHub</a></li>
</ul>
<div class="sign-out-link">
<a class="more-insider" href="/insider/">More Insider</a>
<a class="sign-out" href="javascript://" onclick="IDG.insiderReg.logout()">Sign Out</a>
</div>
</div>
</div>
</div>
</div>
<script>$('.signin-register').hide();$('#welcome-message').hide();</script>
</div>
</section>
<section class="tools-expand  ">
<form class="search" id="search-form" action="/search">
<label for="search-box">Search for</label>
<input type="text" name="query" id="banner-search-term" value="" class="searchbox-input-class"/>
<input type="submit" id="banner-search-submit" value="Go"/>
<input type="hidden" name="contentType" value="article,resource"/>
<div class="search-suggest">Suggestions for you</div>
</form>
<div class="user">
<form>
<label for="login-email">Insider email</label> <input id="login-email" type="text"/>
</form>
</div>
</section>
<div id="sticky-anchor-nav"></div>
<nav id="sticky-nav" class="main">
<ul class="topnav">
<li><a href="/category/core-java/" class="hasChildren">Core Java<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/core-java/">All Core Java</a></li>
<li><a href="/category/agile-development/">Agile Development</a></li>
<li><a href="/category/java-concurrency/">Java Concurrency</a></li>
<li><a href="/category/java-language/">Java Language</a></li>
<li><a href="/category/java-platform/">Java Platform</a></li>
<li><a href="/category/security/">Java Security</a></li>
<li><a href="/category/careers/">Programming Careers</a></li>
<li><a href="/category/testing-debugging/">Testing and Debugging</a></li>
</ul>
</li>
<li><a href="/category/enterprise-java/" class="hasChildren">Enterprise Java<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/enterprise-java/">All Enterprise Java</a></li>
<li><a href="/category/apis/">APIs</a></li>
<li><a href="/category/big-data/">Big Data</a></li>
<li><a href="/category/cloud-computing/">Cloud Computing</a></li>
<li><a href="/category/analytics/">Data Analytics</a></li>
<li><a href="/category/development-tools/">Development Tools</a></li>
<li><a href="/category/application-development/">Java App Dev</a></li>
<li><a href="/category/web-development/">Java Web Development</a></li>
<li><a href="/category/open-source-tools/">Open Source</a></li>
<li><a href="/category/scripting-jvm-languages/">Scripting and JVM Languages</a></li>
</ul>
</li>
<li><a href="/category/learn-java/" class="hasChildren">Learn Java<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/learn-java/">All Learn Java</a></li>
<li><a href="/category/design-patterns/">Design Patterns</a></li>
</ul>
</li>
<li><a href="/category/mobile-java/" class="hasChildren">Mobile Java<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/mobile-java/">All Mobile Java</a></li>
<li><a href="/category/android/">Java Android Developers</a></li>
<li><a href="/category/ios/">Java iOS Developers</a></li>
</ul>
</li>
</ul>
<ul class="secondary">
<li><a href="/news/">News</a></li>
<li><a href="/feature/">Features</a></li>
<li><a href="/howto/">How-Tos</a></li>
<li><a href="/blogs/">Blogs</a></li>
<li><a href="/resources/">Resources/White Papers</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
</ul>
</nav>
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('div.insider-signin').prependTo('section.topics nav.tools');}</script>
<script>$(document).ready(function(){if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("nav ul li a.hasChildren").attr("href","#").addClass('notMobile');$('nav#sticky-nav ul.secondary').addClass('topnav');}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("nav#sticky-nav > ul").switchClass("topnav","primary");}});</script>
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('#sticky-anchor, section.main, section.topics, section.tools-expand, #sticky-anchor-nav, nav.main').insertBefore($('#banner .ad'));$(document).ready(function(){$('#banner section.tools-expand').addClass('top-margin');});}</script>
</header>
<script>$(document).ready(function(){$('body').addClass('insider-plus');var headerHeight=$('header#banner').height();$('header#banner nav#sticky-nav.main.no-stick').css("top",headerHeight);if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var stickyHeaderHeight=$('section.topics').height()+$('#sticky-head.main').height();stickyHeaderHeight=stickyHeaderHeight-8;}var supportsOrientationChange="onorientationchange"in window,orientationEvent=supportsOrientationChange?"orientationchange":"resize";if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){window.addEventListener(orientationEvent,function(){var top=$('section#sticky-head.main').offset().top;if(top<170){top=0;}else{top=top-50;}if(window.orientation==90||window.orientation==-90){window.scrollTo(0,top);}},false);}if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&$thm.deviceHeight()<768){if($('html').hasClass('touch')){$('#insider-popup.modal-box .modal-body').addClass('short');}else{$('#insider-popup.modal-box .modal-body').addClass('short-desk');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){window.addEventListener(orientationEvent,function(){var top=$('section#sticky-head.main').offset().top;if(top<50){top=5;}else{top=top-40;}if(window.orientation==90||window.orientation==-90){window.scrollTo(0,top);}},false);}var ua=navigator.userAgent.toLowerCase();var isAndroid=ua.indexOf("android")>-1;window.addEventListener(orientationEvent,function(){if(isAndroid&&(screen.width==600||screen.width==960)){location.reload(true);}},false);if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.desktop)&&!$('html').hasClass('touch')){$("ul.social li.more-social").mouseenter(function(){$('ul.social > li').addClass('display-icon');});$("ul.social").mouseleave(function(){$('ul.social > li').removeClass('display-icon');});};if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&$('html').hasClass('touch')){$("ul.social li.more-social").click(function(){$('ul.social > li').toggleClass('display-icon');});};$('.searchbox-input-class').each(function(){$(this).change(function(){var qStr=$(this).val();if($(this).val().indexOf('@')!=-1){qStr=qStr.replace(/@/g,' ');$(this).val(qStr);}});});});function sticky_relocate(){var headerHeight=$('header#banner').height();var winHeight=$(window).height();if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.wide)){winHeight=winHeight-40;if(window.orientation==90||window.orientation==-90){winHeight=winHeight+50;}}else if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.wide)){winHeight=winHeight+40;}else{winHeight=winHeight+10;}$('#banner nav#sticky-nav.main').css("height",winHeight);if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var window_top=$(window).scrollTop();var div_top=$('#sticky-anchor').offset().top;if(window_top>div_top){$('#sticky-head').addClass('stick');$('#page-wrapper').addClass('top-pad');$('#banner .ad').addClass('top-margin');}else{$('#sticky-head').removeClass('stick');$('#page-wrapper').removeClass('top-pad');$('#banner .ad').removeClass('top-margin');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('section.topics').addClass('stick-topics');$('#sticky-head').addClass('stick-head');$('#page-wrapper').addClass('top-pad');$('#banner .ad').addClass('top-margin');$('#banner section.tools-expand').addClass('search');var window_top=$(window).scrollTop();var div_top=$('#sticky-anchor').offset().top+30;if(window_top>div_top){$('#sticky-head').addClass('stick');$('.topics.stick-topics, #search-form').addClass('remove');$('li.search-icon').fadeOut("fast");}else{$('#sticky-head').removeClass('stick');$('.topics.stick-topics, #search-form').removeClass('remove');$('li.search-icon').fadeIn("fast");}}if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){if($('#sticky-head').hasClass('stick')){var stickyHeaderHeight=$('section.main').height();stickyHeaderHeight=52;$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').addClass('stick');$('#sticky-nav').removeClass('no-stick');}else{stickyHeaderHeight=$('header#banner').height();$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').removeClass('stick');$('#sticky-nav').addClass('no-stick');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var stickyHeaderHeight=$('section.topics').height()+$('#sticky-head.main.stick-head').height();stickyHeaderHeight=stickyHeaderHeight-8;$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').addClass('stick');if($('#sticky-head').hasClass('stick')){$('#sticky-head.stick').siblings('#sticky-nav').addClass('nav-stick');$('#sticky-head').siblings('#sticky-nav').removeClass('no-stick');}else{$('#sticky-head').siblings('#sticky-nav').removeClass('nav-stick');$('#sticky-head').siblings('#sticky-nav').addClass('no-stick');}}}$(function(){$(window).scroll(sticky_relocate);sticky_relocate();});</script>
<div id="insider-popup" class="modal-box ">
<div class="insider-modal-wrapper">
<div class="modal-header-title">
<div class="modal-banner-insider"><span class="insider"></span></div>
<div class="modal-close close">×</div>
</div>
<div class="modal-body">
<script>$(document).ready(function(){$('a[data-link]').click(function(){var dataLink=$(this).attr('data-link');var toKeep='div[data-link="'+dataLink+'"]';$('div[data-link]').not(toKeep).hide();if($(this).hasClass('link-transition')){$(toKeep).fadeIn(800);}else{$(toKeep).show();}return false;});});</script>
</div>
<div class="modal-footer">
<div class="modal-close close-btn">Close</div>
</div>
</div>
</div>
<script>$(document).ready(function(){var appendthis=("<div class='modal-overlay modal-close'></div>");if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').css({top:10,left:0});}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').height($(document).height());$('.modal-box').css('top','0');}var userAg=navigator.userAgent;$('a[data-modal-id]').click(function(e){e.preventDefault();$('body').append(appendthis);$('.modal-overlay').fadeTo(500,0.9);$('.modal-overlay').height($(document).height());var modalBox=$(this).attr('data-modal-id');if($(".modal-box").hasClass('triggered')||(userAg.indexOf("Firefox")!=-1)){$('#'+modalBox).fadeIn($(this).data());}else{if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('#'+modalBox).toggle('slide',{direction:'up'},800);}else{$('#'+modalBox).toggle('slide',{direction:'left'},600);}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("html, body").animate({scrollTop:0},700);$('a.btn.continue-on').click(function(){$('html, body').animate({scrollTop:0},500);});return false;}if(navigator.userAgent.match(/(iPad)/)){$("html, body").animate({scrollTop:0},500);}});$(".modal-close, .modal-overlay").click(function(){$('.select2-drop').css('display','none');$(".modal-overlay").fadeOut(500,function(){$(".modal-overlay").remove();});if($(".modal-box").hasClass('triggered')||(userAg.indexOf("Firefox")!=-1)){$(".modal-box").fadeOut(500);}else{if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').toggle('slide',{direction:'up'},800);}else{$('.modal-box').toggle('slide',{direction:'left'},600);}}});});</script>
<!-- END PAGE HEADER -->
<div id="page-wrapper" class="page-wrapper">
<div id="skinAdTarget"></div>
<section role="main">
<article itemscope itemtype="http://schema.org/NewsArticle">
<div class="ticker-ad ad">
<div id="ticker" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("ticker","true");$('#ticker').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: ticker - [971 1115]");</script>
</div>
<!-- Events Header -->
<!-- //end Events Header -->
<header class='cat'>
<nav class="breadcrumbs horiz">
<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
<li><a href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
<li><a href="/category/core-java/" itemprop="url"><span itemprop="title">Core Java</span></a></li>
<li><a href="/category/java-language/" itemprop="url"><span itemprop="title">Java Language</span></a></li>
</ul>
</nav>
<div class="category"><a href="/news" itemprop="genre">News</a></div>
<h1 itemprop="headline">Java will no longer have ‘major’ releases</h1>
<section class="deck viewability">
<h3 itemprop="description">The twice-yearly Java releases will get new version numbers, but they won’t have the degree of change that whole version numbers have historically indicated</h3>
</section>
<div class="cat-social">
<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">
<li class="sosh">
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3270926%2Fjava-language%2Fjava-will-no-longer-have-major-releases.html&via=javaworldcom&text=Java+will+no+longer+have+%E2%80%98major%E2%80%99+releases" target="_blank">
<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3270926%2Fjava-language%2Fjava-will-no-longer-have-major-releases.html" target="_blank">
<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg"/>
</a>
</li>
<li class="sosh">
<a href="http://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3270926%2Fjava-language%2Fjava-will-no-longer-have-major-releases.html&title=Java+will+no+longer+have+%E2%80%98major%E2%80%99+releases" target="_blank">
<img class="sidecar-icon" src="//idge.staticworld.net/images/linkedin.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3270926%2Fjava-language%2Fjava-will-no-longer-have-major-releases.html" target="_blank">
<img class="sidecar-icon" src="//idge.staticworld.net/images/gplus.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="http://reddit.com/submit?url=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3270926%2Fjava-language%2Fjava-will-no-longer-have-major-releases.html&title=Java+will+no+longer+have+%E2%80%98major%E2%80%99+releases" target="_blank">
<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3270926%2Fjava-language%2Fjava-will-no-longer-have-major-releases.html" target="_blank">
<img class="sidecar-icon" src="//idge.staticworld.net/images/stumbleupon.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="#email" id="email-icon">
<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg"/>
</a>
</li>
<li class="sosh hide print">
<a href="javascript:window.print();">
<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg"/>
</a>
</li>
<li class="more">
<div class="more-icon" onclick="document.getElementById('share-tool').className = 'expand';"></div>
</li>
</ul>
</div>
<script type="text/javascript">var isValidEmailAddress=isValidEmailAddress||function(emailAddress){var pattern=new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);return pattern.test(emailAddress);};function encodeQueryData(params){var ret=[];for(var paramKey in params){ret.push(encodeURIComponent(paramKey)+"="+encodeURIComponent(params[paramKey]));}return ret.join("&");}function bindEmailModal(){$('#emailModal').on("click",".close-btn",function(event){event.preventDefault();$('#emailModal').hide();$("#emailModal .eml-friend").show();$(".eml-friend-success").hide();$(".eml-friend-error").hide();$('#emailModal').fadeOut(200);$('#email-to').val('');$('#email-from').val('');$('#name').val('');$('#personalization').val('');$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");});$('#emailModal').on("submit","form",function(event){event.preventDefault();var $form=$(this);var action=$form.attr('action');var formData=$form.serialize();var emailFrom=$('#email-from').val();var emailTo=$('#email-to').val();var uresponse=$('#g-recaptcha-response').val();$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");if(isValidEmailAddress(emailFrom)&&isValidEmailAddress(emailTo)&&uresponse!=""){$.ajax(action,{type:'POST',data:formData,success:function(data,textStatus,xhr){$("#emailModal .eml-friend").hide();$(".eml-friend-success").fadeIn(800);},error:function(xhr,textStatus,errorThrown){$("#emailModal .eml-friend").hide();$(".eml-friend-error").fadeIn(800);}});}else{if(uresponse==""){$('#eml-friend-captcha-message').html("Please verify you're not a robot!");}if(!isValidEmailAddress(emailTo)){$('#eml-to-address-message').html("Please enter a valid email address.");}if(!isValidEmailAddress(emailFrom)){$('#eml-from-address-message').html("Please enter a valid email address.");}}});}$(document).ready(function(){$(document).on("click","#email-icon",function(event){event.preventDefault();bindEmailModal();$('#emailModal').fadeIn(800);});});</script>
<div class="modal eml-friend-wrapper" id="emailModal" style="display:none;">
<form class="eml-friend" action="/eloquaemail/article?eloqua=false&id=3270926">
<input type="hidden" name="title" value="Java will no longer have ‘major’ releases"/>
<input type="hidden" name="url" value="https://www.javaworld.com/article/3270926/java-language/java-will-no-longer-have-major-releases.html"/>
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Email a friend</h3>
<div class="input-row">
<div id="eml-to-address-message" class="error-msg"></div>
<h4 class="input-label">To</h4>
<input id="email-to" value="" placeholder="Email address (required)" type="email" name="recipients" tabindex="1">
<p class="addl-text">Use commas to separate multiple email addresses</p>
</div>
<hr/>
<div class="input-row">
<div id="eml-from-address-message" class="error-msg"></div>
<h4 class="input-label">From</h4>
<input id="name" value="" placeholder="Name (optional)" type="text" name="name" tabindex="2">
</div>
<div class="input-row">
<input id="email-from" value="" placeholder="Email address (required)" type="email" name="sender" tabindex="3">
</div>
<div class="input-row">
<textarea name="message" placeholder="Check out this article I found on JavaWorld." id="personalization" tabindex="4"></textarea>
</div>
<hr/>
<div class="input-row">
<div id="eml-friend-captcha-message" class="error-msg"></div>
<script src="https://www.google.com/recaptcha/api.js" async defer></script>
<div class="g-recaptcha" data-sitekey="6LczmkcUAAAAANEO7J277KwH6Kzp6BEQjPTWP4S4"></div>
</div>
<hr/>
<div class="submit">
<input type="submit" value="Send" class="input-submit" tabindex="5">
<a href="/about/privacy.html" class="submit-privacy" target="_blank">Privacy Policy</a>
</div>
</form>
<div class="eml-ty eml-friend-success" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Thank you</h3>
<p class="msg-sent">Your message has been sent.</p>
</div>
<div class="eml-friend-error" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Sorry</h3>
<p class="msg-sent">There was an error emailing this page.</p>
</div>
</div>
</div>
<div class="cat byline vcard author with-image">
<div class="byline-wrapper">
<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
<a href="/author/Paul-Krill/" rel="author" title="Paul Krill"><img class="bylineImage  imgId100356327 " src="https://images.techhive.com/images/article/2014/07/paulkrill_crop-100356327-byline.jpg" width="34" width="34" alt="Paul Krill" itemprop="image"/></a>
<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Paul-Krill/"><span itemprop="name">Paul Krill</span></a></span>
</p>
<p class="dateline">
Editor at Large,
<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name"><a href="http://www.infoworld.com/" rel="nofollow" target="_blank">InfoWorld</a></span><meta itemprop="logo" content="https://www.javaworld.com/www.idge.jvw/images/JVW_logo_300x300.png"/></span> <span class="divider break">|</span>
<span class="pub-date" class='break-date' itemprop="datePublished" content="2018-05-08T03:00-0700">May 8, 2018 3:00 AM
PT
</span>
</p>
</div>
</div>
<div class="ad viewability">
<div id="topleaderboard" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("topleaderboard","true");$('#topleaderboard').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: topleaderboard - [971 1115]");</script>
</div>
</header>
<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
<meta itemprop="representativeOfPage" content="1"/>
<meta itemprop="height" content="466"/>
<meta itemprop="width" content="700"/>
<img src="https://images.techhive.com/images/article/2017/02/intel_coffee_lake_figurative_image-100708700-large.jpg" alt="Java will no longer have ‘major’ releases" itemprop="contentUrl" itemprop="url"/>
<figcaption>
<span class="credit" itemprop="copyrightHolder">
Amenic181 / Thinkstock
</span>
</figcaption>
</figure>
<section class="epo cat-narrow" id="drr-top-ad">
<!-- Related -->
<div class="related-promo-wrapper">
<div class="promo apart">
<div class="hed">More like this</div>
<ul class="">
<li class="clearfix with-image">
<a href="/article/3266372/core-java/java-11-roadmap-the-new-features-you-can-expect.html"><img class="small.3x2Image  imgId100711157 " src="https://images.techhive.com/images/article/2017/02/1280px-java_ring-100711157-small.3x2.jpeg" alt="java ring" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3266372/core-java/java-11-roadmap-the-new-features-you-can-expect.html">Java 11 roadmap: The new features you can expect</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3252154/java-language/oracle-extends-java-jdk-8-updates-to-2019.html"><img class="small.3x2Image  imgId100732880 " src="https://images.idgesg.net/images/article/2017/08/3_defer-creators-update-100732880-small.3x2.jpg" alt="Keyboard with blue update button" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3252154/java-language/oracle-extends-java-jdk-8-updates-to-2019.html">Oracle extends Java JDK 8 updates to 2019</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3269446/java-language/oracle-sets-date-for-end-of-java-8-updates.html"><img class="carousel.idgeImage  imgId100656550 " src="https://images.techhive.com/images/article/2016/04/1024px-endofroadsign-margate-100656550-carousel.idge.jpg" alt="end of road sign" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3269446/java-language/oracle-sets-date-for-end-of-java-8-updates.html">Oracle sets date for end of Java 8 updates</a></div>
</div>
</li>
</ul>
</div>
</div>
<div class="ad top-ad">
<div id="topimu" class="adunit ad-container">
</div>
<script type="text/javascript">if($(window).width()>=930){IDG.GPT.addDisplayedAd("topimu","true");$('#topimu').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: topimu - [971 1115]");}</script>
</div>
</section>
<section class="bodee">
<div class="ad placement">
<!--  Begin gpt-skin/inread -->
<div id="inread" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("inread","true");IDG.GPT.displayGoogleTagSlot('inread');</script>
<!--  End gpt-skin/inread -->
</div>
<script>var dataLayer=window.dataLayer=window.dataLayer||[];dataLayer.push({'event':'loadTopCollectionModule'});</script>
<script type="text/javascript">$(document).ready(function(){$('.articleBloxAd').filter(":visible").each(function(index,item){var id=$(item).attr('id');var divClass=$(item).attr('class');var adString=IDG.GPT.getLazyAdCode();$(item).replaceWith("<div id=\""+id+"\" class=\"lazyload_blox_ad "+divClass+"\">"+adString+"</div>");});try{$("div.lazyload_blox_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});}catch(exception){console.log("error loading lazyload_ad "+exception);}});</script>
<script type="text/javascript">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</script>
<div id="drr-container" class='cat ' itemprop="articleBody">
<p>Remember when a new number meant a software release was a sighnificant, or major, one? For Java, that pattern is over. Java 9 was the last “major” release, Oracle says.</p><p>All versions after that—including the recently released <a href="https://www.infoworld.com/article/3230507/java/java-jdk-10-what-new-features-to-expect-in-the-next-java.html">Java 10</a> and the forthcoming <a href="https://www.infoworld.com/article/3265447/java/java-11-roadmap-the-new-features-you-can-expect.html">Java 11</a>—are what the industry typically calls “point releases,” because they were usually numbered x.1, x.2, and so on to indicate an intermediate, more “minor” release. (Oracle has called those point releases “feature releases.”)</p><aside class="fakesidebar"><strong>[ The new Java is coming! Discover the <a href="https://www.infoworld.com/article/3265447/java-11-roadmap-the-new-features-you-can-expect.html">Java 11 JDK roadmap</a>. • The new Java versions are here! Learn everything you need to know about <a href="https://www.infoworld.com/article/3230507/java-jdk-10-what-new-features-to-expect-in-the-next-java.html">what’s new in Java SE 10</a> and <a href="https://www.infoworld.com/article/3198989/java/the-road-to-java-9-the-current-status.html">what’s new in Java EE 8</a>. | Keep up with hot topics in programming with InfoWorld’s <a href="https://www.infoworld.com/newsletters/signup.html">App Dev Report newsletter</a>. ]</strong></aside><aside class="fakesidebar"/><p>As of Java 10, Oracle has put <a href="https://www.infoworld.com/article/3223690/java/java-9-will-not-receive-long-term-support.html">Java on a twice-annual release schedule</a>, and although those releases get whole numbers in their versions, they’re more akin to point releases. Oracle recently declared, “There are no ‘major releases’ per se any more; that is now a legacy term. Instead, there is a steady stream of ‘feature releases.’”</p><p>Under the plan, moving from <a href="https://www.infoworld.com/article/3227244/java/java-9-is-here-everything-you-need-to-know.html">Java 9</a> to Versions 10 and 11 is similar to previous moves from <a href="https://www.infoworld.com/article/3269332/java/oracle-sets-date-for-end-of-java-8-updates.html">Java 8</a> to Java version 8u20 and 8u40. </p><aside class="nativo-promo nativo-promo-1 smartphone" id=""> </aside><p>Previously, it took about three years to move from Java 7 to 8 and then 9.</p><p>Oracle says that Java’s twice-yearly release schedule makes it easier for tools vendors to keep up with changes, because they will work with a stream of smaller updates. Upgrading of tools from Java from version 9 to 10 happened “almost overnight,” Oracle says, compared to the difficulties it said some tools vendors had making the move from Java 8 to 9.</p><p>For users who just want stability and can pass on new features of each “feature release,” Oracle is still holding onto that old three-year schedule for its long-term support (LTS) releases. Java 11 will be an LTS release, with commercial support available from Oracle for at least eight additional years.</p><aside id="fsb-2546" class="fakesidebar fakesidebar-auto fakesidebar-sponsored"><strong>[ <a href="https://pluralsight.pxf.io/c/321564/424552/7490?u=https%3A%2F%2Fwww.pluralsight.com%2Fpaths%2Fjava" rel="nofollow">Learn Java from beginning concepts to advanced design patterns in this comprehensive 12-part course!</a> ]</strong></aside>
<p class="orig">This story, "Java will no longer have ‘major’ releases" was originally published by
<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name"><a href="http://www.infoworld.com/" rel="nofollow" target="_blank">InfoWorld</a></span><meta itemprop="logo" content="https://www.javaworld.com/www.idge.jvw/images/JVW_logo_300x300.png"/></span>.</p>
<div class="end-note">
</div>
</div>
<script>$("a[data-product-id]").on('click',function(e){var e=e||window.event;var dataLayer=window.dataLayer=window.dataLayer||[];var prodName=$(this).attr("data-product-name");prodName=prodName.replace("\\'","'");if($(this).parents('.slideshow').length>0){var productLinkPosition="Slideshow";}else if($(this).parents('.product-sb').length>0){var productLinkPosition="Product Sidebar";}else if($(this).parents('.at-a-glance.top').length>0){var productLinkPosition="AAG Top";}else if($(this).parents('.at-a-glance').length>0){var productLinkPosition="AAG Bottom";}else if($(this).parents('.product-chart').length>0){var productLinkPosition="Product Chart";}else if($(this).parents('.product-list').length>0){var productLinkPosition="Product List";}else{var productLinkPosition="Body Text";}dataLayer.push({'event':'affiliateLink','eventCategory':'Affiliate Link','eventAction':'Click','eventLabel':''+e.target+'','productVendor':$(this).attr("data-bkvndr"),'productManufacturer':$(this).attr("data-bkmfr"),'productName':prodName,'productId':$(this).attr("data-product-id"),'productLinkPosition':productLinkPosition});});</script>
<script>$("#drr-container a").on('click',function(e){var dataLayer=window.dataLayer=window.dataLayer||[];var $clickEl=$(this);var clickUrl=$clickEl.attr("href");var clickParentsUntilDrr=$clickEl.parentsUntil("#drr-container");var clickText=$clickEl.text().trim();var linkLocation;var linkType;var regex=new RegExp("cio|csoonline|computerworld|itnews|itworld|infoworld|networkworld|javaworld|techconnect|techhive|macworld|pcworld|greenbot|gamestar","i");if(clickParentsUntilDrr.hasClass("fakesidebar")){linkLocation="FSB";}else if(clickParentsUntilDrr.hasClass("end-note")){linkLocation="End Note";}else{linkLocation="Body";}if(regex.test(clickUrl)){linkType="Internal";}else{linkType="External";}dataLayer.push({'event':'editBodyLink','eventCategory':'Editorial Body Links','eventAction':linkType,'eventLabel':linkLocation+" | "+clickText+" | "+clickUrl});});</script>
<div class="apart-alt tags">
<span class="related">Related: </span>
<ul>
<li><a href="/category/java-language">Java Language</a></li>
<li><a href="/category/java-platform">Java Platform</a></li>
<li><a href="/category/open-source-tools">Open Source</a></li>
<li><a href="/category/application-development">Java App Dev</a></li>
<li><a href="/tag/oracle/" rel="nofollow">Oracle</a></li>
<li><a href="/tag/eclipse/" rel="nofollow">Eclipse</a></li>
</ul>
</div>
<div class="byline vcard author end-byline">
<div class="author-info">
<p class="bio">Paul Krill is an editor at large at InfoWorld, whose coverage focuses on application development.</p>
</div><!-- end .author-info -->
<div class="brand-social">
<div class="follow-text">Follow</div>
<ul class="social-links">
<li>
<a href="/author/Paul-Krill/">
<i class="ss-icon ss-user"></i>
</a>
</li>
<li>
<a href="mailto:paul_krill@infoworld.com">
<i class="ss-icon ss-mail"></i>
</a>
</li>
<li>
<a href="https://twitter.com/pjkrill" class="twitter-follow" target="_blank">
<i class="ss-icon ss-social ss-twitter"></i>
</a>
</li>
<li>
<a href="https://plus.google.com/108289165450818957590" class="googleplus-follow" target="_blank">
<i class="ss-icon ss-social ss-googleplus"></i>
</a>
</li>
<li>
<a href="/author/Paul-Krill/index.rss" class="rss">
<i class="ss-icon ss-social ss-rss"></i>
</a>
</li>
</ul>
</div>
</div>
<script src="/www/js/video/embedder.js"></script>
</section><!-- /.bodee -->
<div class="six-column" id="recommended">
<div class="head">Recommended</div>
<ul>
<li class=" first">
<figure class="well-img">
<a href="/article/3114167/development-tools/choosing-your-java-ide.html"><img class="lazy carousel.idgeImage  imgId100681048 " data-original="https://images.techhive.com/images/article/2016/09/jw-java-ides-100681048-carousel.idge.jpg" alt="JavaWorld Java IDEs review, September 2016"/></a>
</figure>
<div class="post-cont">
<div class="title">
<a href="/article/3114167/development-tools/choosing-your-java-ide.html">Eclipse, NetBeans, or IntelliJ? Choose your Java IDE</a>
</div>
</div>
</li>
<li class=" ">
<figure class="well-img">
<a href="/article/3148705/application-development/osgi-at-the-uks-biggest-science-lab.html"><img class="lazy small.3x2Image  imgId100703839 " data-original="https://images.techhive.com/images/article/2017/01/diamond-light-source-synchrotron-main-100703839-small.3x2.jpg" alt="diamond light source synchrotron main chamber"/></a>
</figure>
<div class="post-cont">
<div class="title">
<a href="/article/3148705/application-development/osgi-at-the-uks-biggest-science-lab.html">OSGi at the UK's biggest science lab</a>
</div>
</div>
</li>
<li class=" ">
<figure class="well-img">
<a href="/article/3104621/mobile-java/android-studio-for-beginners-part-2-explore-and-code-the-app.html"><img class="lazy smallImage  imgId100678712 " data-original="https://images.techhive.com/images/article/2016/08/android-beginners2-100678712-small.jpg" alt="android beginners2"/></a>
</figure>
<div class="post-cont">
<div class="title">
<a href="/article/3104621/mobile-java/android-studio-for-beginners-part-2-explore-and-code-the-app.html">Android Studio for beginners: Code the app</a>
</div>
</div>
</li>
<li class=" ">
<figure class="well-img">
<a href="/article/3123117/development-tools/open-source-java-projects-jenkins-with-docker-part-1.html"><img class="lazy carousel.idgeImage  imgId100685229 " data-original="https://images.techhive.com/images/article/2016/09/357376583_8381f9d690_z-100685229-carousel.idge.jpg" alt="CI/CD with Jenkins and Docker, Part 1"/></a>
</figure>
<div class="post-cont">
<div class="title">
<a href="/article/3123117/development-tools/open-source-java-projects-jenkins-with-docker-part-1.html">Jenkins with Docker, Part 1</a>
</div>
</div>
</li>
<li class="sponsored first">
<figure class="well-img">
<div class="sized-img-teaser">
<a href="https://resources.javaworld.com/ccd/assets/147163/detail"><img class="lazy smallImage  imgId100748280 " data-original="https://images.idgesg.net/images/idge/imported/imageapi/2018/02/01/14/active20roles20-20identity-and-access-management-for-the-real-world-access-management-ebook-24720-100748280-small.png"/></a>
</div>
</figure>
<div class="item-eyebrow">
eBook
<br><span class="sponsored">Sponsored</span>
</div>
<div class="post-cont">
<div class="title">
<a href="https://resources.javaworld.com/ccd/assets/147163/detail">IAM for the Real World Access Management</a>
</div>
</div>
</li>
<li class="sponsored ">
<figure class="well-img">
<div class="sized-img-teaser">
<a href="https://resources.javaworld.com/ccd/assets/146407/detail"><img class="lazy smallImage  imgId100747360 " data-original="https://images.idgesg.net/images/idge/imported/imageapi/2018/01/22/16/logo-2-100747360-small.png"/></a>
</div>
</figure>
<div class="item-eyebrow">
White Paper
</div>
<div class="post-cont">
<div class="title">
<a href="https://resources.javaworld.com/ccd/assets/146407/detail">5 Lessons Your Business Can Learn from Business Process Automation Leaders</a>
</div>
</div>
</li>
</ul>
</div><!-- /.six-column -->
<div class="lazyload_ad">
<code type="text/javascript">
<!--
		document.write('<div id="ciu" class=" ad-container">');
		IDG.GPT.addDisplayedAd("ciu", "true");
		IDG.GPT.addLazyloadedAd("ciu", "true");
		document.write('</div>');
		$('#ciu').responsiveAd({screenSize:'971 1115', scriptTags: []});
		if (Object.keys(IDG.GPT.companions).length > 0 || IDG.GPT.disableInitialLoad) {
			IDG.GPT.refreshAd('ciu');
		}
		//-->
</code>
</div>
<link rel="stylesheet" href="/www.idge/css/sponsored-links.css?v=20180507013149"/>
<link rel="stylesheet" href="/www.idge.jvw/css/sponsored-links.css?v=20180507013149"/>
<section id="resources-sponsored-links">
<section class="sponsored-links">
<div class="head">Sponsored Links</div>
<ul class="first">
<li>
<a rel="nofollow" target="_blank" href="http://pubads.g.doubleclick.net/gampad/clk?id=4504608452&iu=/8456/IDG.US_E_CIO.com">
What are you doing to accelerate IT agility? Learn about the IT model that serves as a catalyst for digital transformation.
</a>
</li>
</ul><ul>
<li>
<a rel="nofollow" target="_blank" href="http://pubads.g.doubleclick.net/gampad/clk?id=4504608452&iu=/8456/IDG.US_E_CIO.com">
Unlock the potential of your data. How well are you harnessing information to improve business outcomes? A new CIO Playbook will help.
</a>
</li>
</ul>
</section>
</section>
</article>
</section><!-- /role=main -->
</div><!-- /#page-wrapper -->
<link rel="stylesheet" href="/www.idge/css/foot.css?v=20180507013149"/>
<link rel="stylesheet" href="/www.idge.jvw/css/foot.css?v=20180507013149"/>
<footer>
<section class="brand" itemscope itemtype="http://schema.org/Organization">
<link itemprop="url" href="http://www.javaworld.com">
<a href="/"><span class="logo">JavaWorld</span></a>
<span class="tagline"> JavaWorld is the original independent resource for Java developers, architects, and managers.</span>
<span class="follow">
<label>Follow us</label>
<ul>
<li><a href="https://twitter.com/javaworldcom" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
<li><a href="http://www.linkedin.com/company/javaworld-com" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
<li><a href="https://www.facebook.com/pages/JavaWorld/107993545895326" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>
<li><a href="https://plus.google.com/117974570132126965756/posts" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>
<li><a href="/index.rss" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
</ul>
</span>
</section>
<section class="topics">
<nav id="ft1">
<ul>
<li class="selected"><a href="/category/core-java/" class="active">Core Java</a>
</li>
<li><a href="/category/enterprise-java/">Enterprise Java</a>
</li>
<li><a href="/category/learn-java/">Learn Java</a>
</li>
<li><a href="/category/mobile-java/">Mobile Java</a>
</li>
</ul>
</nav>
<nav id="ft2">
<ul>
<li><a href="/howto">How-Tos</a></li>
<li><a href="/feature">Features</a></li>
<li><a href="/news">News</a></li>
<li><a href="/blogs">Blogs</a></li>
<li><a href="/resources">Resources</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
</ul>
</nav>
</section>
<section class="about">
<div class="wrapper">
<nav class="tertiary" id="ft3">
<ul>
<li><a href="/about/about.html">About Us</a>
<li><a href="/about/contactus.html">Contact</a>
<li><a href="/about/privacy.html">Privacy Policy</a>
<li><a href="http://www.idgenterprise.com/reach/javaworld/" target="_blank" rel="nofollow">Advertising</a>
<li><a href="https://www.idg.com/work-here/" target="_blank" rel="nofollow">Careers at IDG</a>
<li><a href="/about/adchoices.html">Ad Choices</a>
<li><a href="/about/affiliates.html">E-commerce Affiliate Relationships</a>
</ul>
</nav>
</div>
</section>
<section class="copyright">
<div class="wrapper">
<p><a href="/about/copyright.html">Copyright</a> &copy; 2018 IDG Communications, Inc.</p>
<div class="network">
<div id="network-selector">
<div class="label">Explore the IDG Network <i class="ss-icon tick">descend</i></div>
<ul>
<li><a href="https://www.cio.com" target="_blank" rel="nofollow">CIO</a></li>
<li><a href="https://www.computerworld.com" target="_blank" rel="nofollow">Computerworld</a></li>
<li><a href="https://www.csoonline.com" target="_blank" rel="nofollow">CSO</a></li>
<li><a href="https://www.gamestar.com" target="_blank" rel="nofollow">GameStar</a></li>
<li><a href="https://www.greenbot.com" target="_blank" rel="nofollow">Greenbot</a></li>
<li><a href="https://www.idc.com" target="_blank" rel="nofollow">IDC</a></li>
<li><a href="https://www.idg.com" target="_blank" rel="nofollow">IDG</a></li>
<li><a href="https://www.idgconnect.com" target="_blank" rel="nofollow">IDG Connect</a></li>
<li><a href="https://www.idgtechnetwork.com" target="_blank" rel="nofollow">IDG TechNetwork</a></li>
<li><a href="https://www.idg.tv" target="_blank" rel="nofollow">IDG.TV</a></li>
<li><a href="https://www.idgventures.com" target="_blank" rel="nofollow">IDG Ventures</a></li>
<li><a href="https://www.infoworld.com" target="_blank" rel="nofollow">Infoworld</a></li>
<li><a href="https://www.itnews.com" target="_blank" rel="nofollow">IT News</a></li>
<li><a href="https://www.itwhitepapers.com" target="_blank" rel="nofollow">ITwhitepapers</a></li>
<li><a href="https://www.itworld.com" target="_blank" rel="nofollow">ITworld</a></li>
<li><a href="https://www.javaworld.com" target="_blank" rel="nofollow">JavaWorld</a></li>
<li><a href="https://www.linuxworld.com" target="_blank" rel="nofollow">LinuxWorld</a></li>
<li><a href="https://www.macworld.com" target="_blank" rel="nofollow">Macworld</a></li>
<li><a href="https://www.networkworld.com" target="_blank" rel="nofollow">Network World</a></li>
<li><a href="https://www.pcworld.com" target="_blank" rel="nofollow">PCWorld</a></li>
<li><a href="https://www.techconnect.com" target="_blank" rel="nofollow">TechConnect</a></li>
<li><a href="https://www.techhive.com" target="_blank" rel="nofollow">TechHive</a></li>
</ul>
</div><!-- /#network-selector -->
</div><!-- /.network -->
</div><!-- /.wrapper -->
</section>
</footer>
<script src="/www/js/analytics/mouse_down.js"></script>
<script src="/www/js/jquery/jquery-ui.js"></script>
<script src="/www/js/jquery/jquery.dfp.min.js"></script>
<script src="/www.idge/js/mule/shortstack_nav.js"></script>
<div id="mobilewelcomead" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("mobilewelcomead","true");$('#mobilewelcomead').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: mobilewelcomead - [971 1115]");</script>
<script src="/www/js/analytics/tracking.js"></script>
<script src="/www/js/autocomplete.js"></script>
<script src="/www.idge/js/social_sidecar.js"></script>
<script src="/www.idge/js/jquery/plugins/jquery.colorbox-min.js"></script>
<script src="/www.idge/js/article.js?v=20180507013149"></script>
<script src="/www/js/prettify.js"></script>
<script src="/www.idge/js/jquery/responsive-tables.js"></script>
<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
<script>$(document).ready(function(){$("table.tablesorter").tablesorter({widgets:['zebra']});$("table.tablesorter tbody tr").hover(function(){$(this).toggleClass("selected");});$("table.tablesorter thead tr th").each(function(){if($(this).find('.ss-icon').length<1){$(this).append('<i class="ss-icon"></i>');}});});</script>
<script src="/www/js/jquery/jquery.lazyload.min.js"></script>
<script src="/www.idge/js/global.js?v=20180507013149"></script>
<script src="/www/js/webfonts/ss-social.js"></script>
<script src="/www/js/webfonts/ss-standard.js"></script>
<script src="/www/js/analytics/brandAnalytics.js"></script>
<!-- Begin BlueKai Tag -->
<iframe name="__bkframe" height="0" width="0" frameborder="0" src="javascript:void(0)"></iframe>
<script type="text/javascript" src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
<!-- CryptoJS -->
<script src="/www/js/utils/md5.js"></script>
<script type="text/javascript" src="/www/js/analytics/idg_bk_coreapi.js"></script>
<script type="text/javascript">bk_allow_multiple_calls=true;var blueKaiId=14349;var blueKaiPort=10;var brandCode="jvw";var regUrl="https://regdev.idge.int/api/"
var daysToRefresh=30;var bk_debug_log=false;regUrl="https://reg.idgenterprise.com/api/";daysToRefresh=30;if(typeof(s)!='undefined'){bk_addPageCtx("pageType",(typeof(s.pageType)!='undefined')?s.pageType:'');}bk_addPageCtx("cmscatids","[3469,3217,3248,3646]");bk_addPageCtx("cmpy","[]");bk_addPageCtx('tid','2');bk_addPageCtx("purchaseintent","awareness");params=getUrlParams('phint');if(Object.keys(params).length>0){bk_addPageCtx("idg_eid",params['idg_eid']);bk_addPageCtx("newt",params['newt']);bk_addPageCtx("isnl","1");}try{IDG.bkCoreApi.start();}catch(e){bk_doJSTag(blueKaiId,blueKaiPort);if(window.console&&window.console.log){window.console.log("Error Occured While Processing Profile Siubmission")}}$('article, #slideshowCarousel').on('click','.product-list-price, .btn-amazon, .productLink',function(e){var $linkEl=$(e.target);var po=$linkEl.data('po');if($.inArray(po,['amazon','vendor','other'])>=0){if(po=='amazon'){var prCat=$linkEl.data('bkc');if(typeof prCat!='undefined'){bk_addPageCtx('event','AmazonClick'+prCat);}bk_addPageCtx('event','AmazonClickJavaLanguage');bk_addPageCtx('event','AmazonClickJavaPlatform');bk_addPageCtx('event','AmazonClickOpenSource');bk_addPageCtx('event','AmazonClickJavaAppDev');}var prMfr=$linkEl.data('bkmfr');if(typeof prMfr!='undefined'){bk_addPageCtx('event','eCommerceMFR'+prMfr);}var prVndr=$linkEl.data('bkvndr');if(typeof prVndr!='undefined'){bk_addPageCtx('event','eCommerceClickVendor'+prVndr);}bk_doJSTag(34202,1);}});</script>
<!-- End BlueKai Tag -->
<div id="catfish" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("catfish","true");$('#catfish').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: catfish - [971 1115]");</script>
<!--  Begin gpt-skin/inread -->
<div id="gpt-skin" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("gpt-skin","true");IDG.GPT.displayGoogleTagSlot('gpt-skin');</script>
<!--  End gpt-skin/inread -->
<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>
<script type="text/javascript">$("div.lazyload_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});</script>
<script type='text/javascript'>$('#resources-sponsored-links').addClass('show');</script>
<!-- Begin comScore Tag -->
<script>var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"6035308",c3:"",c5:"Java Language",c6:"Article: News",c15:"3270926"});(function(){var s=document.createElement("script"),el=document.getElementsByTagName("script")[0];s.async=true;s.src=(document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s,el);})();</script>
<noscript>
<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035308&cv=2.0&cj=1"/>
</noscript>
<!-- End comScore Tag -->
<script type="text/javascript">$thm.logPlEvent({"b":"jvw","e":"view","t":"article","id":"3270926"});</script>
<div id="loginModal"></div>
<div id="logoffModal"></div>
<script type="text/javascript">a=top;f=self;if(a!=f){a.location=f.location;}</script>
</body>
</html>