












	
	
		
	
		
	
	
	
	


<!DOCTYPE html>
<!--[if lt IE 7]>  <html lang="en" class="lt-ie9 lt-ie8 lt-ie7" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]> <html lang="en" class="lt-ie10 lt-ie9 lt-ie8" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]> <html lang="en" class="lt-ie10 lt-ie9" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="lt-ie10" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]-->
	
	











<head>
	
	
	<!-- metas -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />		
	<title>Go Cloud aims to cement Golang in the cloud | JavaWorld</title>
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	
	
	<script>
	function getQueryVariable(variable) {
		var query = window.location.search.substring(1);
		var vars = query.split("&");
		for (var i=0;i<vars.length;i++) {
			var pair = vars[i].split("=");
			if(pair[0] == variable){return pair[1];}
		}
		return(false);
	}
	</script>
	
	<!-- ad-related js -->
	<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
	
	<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
	
	












<script>
!function(t,o,e){e=t.createElement(o),t=t.getElementsByTagName(o)[0],e.async=1,e.src="https://spiffymachine.com/v2/0/fitZYlVYjgmdd8GwapvOOGGtavCpllDPjbCa0vrD0xplLjdMGk-WUe9rrDX701LK5lbXw",t.parentNode.insertBefore(e,t)}(document,"script"),function(t,o){t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)}}(document,window,"script","admiral");!function(t,e,a,n){function o(t){try{return t=localStorage.getItem("v4ac1eiZr0"),t&&t.split(",")[4]>0}catch(e){}return!1}function r(){var n=o();if(n){var r=t[e].pubads();typeof r.setTargeting===a&&r.setTargeting("admiral-engaged","true")}}n=t[e]=t[e]||{},n.cmd=n.cmd||[],typeof n.pubads===a?r():typeof n.cmd.unshift===a?n.cmd.unshift(r):n.cmd.push(r)}(window,"googletag","function");;;;!function(t,e,a,n){function o(){if(!window.frames[n]){var e=t.body;if(e){var a=t.createElement("iframe");a.style="display:none",a.name=n,e.appendChild(a)}else setTimeout(o,5)}}function r(){for(var t=[],a=0;a<arguments.length;a++)t.push(arguments[a]);i.q=i.q||[],"ping"===t[0]?t[2]({gdprAppliesGlobally:e.__cmpGdprAppliesGlobally||!1,cmpLoaded:!1},!0):t.length&&i.q.push(t)}function c(t){try{return JSON.parse(t)}catch(e){}}function s(t){if(t){var e,a="__cmpCall",n="string"==typeof t.data&&t.data.indexOf(a)>=0;e=n?(c(t.data)||{})[a]:(t.data||{})[a],e&&i(e.command,e.parameter,function(a,o){var r={__cmpReturn:{returnValue:a,success:o,callId:e.callId}};t.source.postMessage(n?JSON.stringify(r):r,"*")})}}var i=e[a];o(),"function"!=typeof i&&(i=e[a]=r,e.addEventListener?e.addEventListener("message",s,!1):e.attachEvent&&e.attachEvent("onmessage",s))}(document,window,"__cmp","__cmpLocator");;
</script>

<script>
window.admiral = window.admiral || function() {(admiral.q = admiral.q || []).push(arguments)};
/*
var checkIfInEU = new Promise((resolve, reject) => {
    var promiseResolved = false;
    setTimeout(function(){
        console.log('GDPR checkIfInEU timeout reached promiseResolved',promiseResolved);
        if (!promiseResolved){
            promiseResolved=true;
            resolve();//in eu
            console.log('too slow; assuming you are EU');
        }
    },10000);

    window.admiral('after', 'cmp.loaded', function(e){
        if(promiseResolved)return;//timeout reached            
        promiseResolved = true;
        
        console.log('GDPR checkIfInEU - cmp.loaded',e);
        var isEuVisitor = e.euVisitor || false;             
        if (isEuVisitor)resolve();
        else reject();    
    });
});
*/

var consent = consent || {};
consent.isEU = consent.isEU || null;
consent.personalization = consent.personalization || null;
consent.ads = consent.ads || {};
consent.ads.queue = consent.ads.queue || [];

window.admiral('addEventListener', 'cmp.loaded', function(e){
	console.log('*****GDPR: EU user?', e);
	consent.isEU = e.euVisitor;
	if (!consent.isEU) {
		console.log('*****GDPR: not EU, run that queue!');
		consent.personalization=true;
		$(window).trigger("runConsent", [consent.ads.queue]);
	}	
	else if (e.consentKnown == true) {
		window.admiral('get', 'cmp.consent', function(e) {
			console.log('*****GDPR: we know your personalization setting (' + e.publisherPurposes['2'] + '), running queue.');
			consent.personalization = e.publisherPurposes['2'];
			$(window).trigger("runConsent", [consent.ads.queue]);
			bindReshowCmp();
		});
	}
	else {
		try {
	    	__cmp('getPublisherConsents',[],function(publisherConsents,success){
	    		if (typeof publisherConsents.standardPurposes['2'] !== 'undefined' && publisherConsents.standardPurposes['2']) {
	    			console.log('*****GDPR: personalization allowed, start running personalized ads');	
	    		}
	    		else if (typeof publisherConsents.standardPurposes['2'] !== 'undefined' && !publisherConsents.standardPurposes['2']) {
	    			console.log('*****GDPR: personalization not allowed, start running non-personalized ads');
	    		}
	    		consent.personalization = publisherConsents.standardPurposes['2'];
	    		$(window).trigger("runConsent", [consent.ads.queue]);
			});
	    		bindReshowCmp();
	    }
	    catch (e) {
	    	console.log(e);
	    }
	}
});

window.admiral('addEventListener', 'cmp.updated', function(e){
	__cmp('getPublisherConsents',[],function(publisherConsents,success){	
		console.log('*****GDPR: Consent updated (cmp.updated fired). personalization ok? ',typeof publisherConsents.standardPurposes['2'] !== 'undefined' && publisherConsents.standardPurposes['2'])
	});	
	$(window).trigger("runConsent", [consent.ads.queue]);
	
});

$(window).on("runConsent", function(event, queueToRun) {
		watchConsentQueue(queueToRun)
});

function runQueue(queue){
	for (var x=0;x<queue.length;x++) {
		var nextFn = queue.shift();
		nextFn();
		console.log('*****GDPR: running queue');
	}	
}

function watchConsentQueue(queue){
	setInterval(function() { runQueue(queue); },100);
}
function bindReshowCmp() {
	var url = document.location.pathname;
	if (url.indexOf("/about/member-preferences") > -1) {
		$(".cmpSettings").show();
		$(".reshowLink").on("click", function(e) {
			e.preventDefault();
			window.admiral('show','cmp.settings');
		});
	}
}
</script>



	
	
	
	<script src="/www/js/init_device.js"></script>
	
	
	
		














<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20180802113401"></script>

<script type="text/javascript">
	if (adLayer==null || adLayer=='undefined') {
		var adLayer=[];
	}
	
		
			adLayer["itemType"]="article";
		
		
	
</script>
	
<script type="text/javascript">
	// Set up ad related variables
	try {
		IDG.GPT.unitName = "/8456/IDG.US_E_JavaWorld.com";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}

	try {
		IDG.GPT.unitName = IDG.GPT.unitName + "/" + "application-development_section";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	// global variables
	var global_ShowSuper = true;
	var global_ShowHero = false;
	
	//XFP global targeting, more targeting thm_pre
	var url = window.location.href;
	if(url.indexOf("?")>1){
		url=url.split('?')[0];
	}
	

	try {
		IDG.GPT.addTarget("URL", encodeURIComponent(url));
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	try {IDG.GPT.addTarget("zone", 'article/development-tools');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("channel", 'enterprise-java');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("articleId", '3294703');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("type", 'news');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("typeId", '2');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("manufacturer", 'amazon');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("templateType", 'article-default');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	
	try {IDG.GPT.addTarget("categoryIds", [3465,3646,3249]);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("categorySlugs", ['development-tools','application-development','scripting-jvm-languages']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {IDG.GPT.addTarget("goldenIds", [287,241,281]);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {
		if (null != IDG.GPT.getQsVal("env")) {		
			IDG.GPT.addTarget("env", IDG.GPT.getQsVal("env").replace(/\W/g, "") );
		}
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	
	
		try {
			IDG.GPT.addTarget("author", 'Paul Krill');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
		

	try {
		IDG.GPT.addTarget("page_type", '');
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	

	
	
	
	
		try {
			IDG.GPT.addTarget("insiderContent", 'false');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
	
	
</script>



<script type="text/javascript">
	
	
	
	
		
		
		
		
		
		
		
		
	
</script>
  
<script src="/www.idge/js/thm_pre.js?v=20180802113401"></script>















	
		
	
	
	



	
		<script type="text/javascript">
			//console.log("PROXIMIC RESPONSE: PAGE-LEVEL");
			(function () {
			    try {
                    var proximic_data = {"data":["300003","112200","121100","131100","112212","240000","240002","240003","240004","240001","240005","240006","240007","240008","240009","240011","240012","240013","240014","240017","240015","240016","20f4sh","v4y9me","q1mw3z","enwcef","bkwp85","zy0t31","x8eev1","ibwrkt","9v0tiu","s9o5po","1o8fv9","skl8g2","li8svo","wu9nfp","e2co9k","r03wnl","folvaf","6vexzx","pytywb","44ywyv","9vsomj","rroqf7","xks7sj","ejqk9n","agtqg7","7grvv1","agt9m3","240saz","pcz604","itgwkk","500033","500037","500034","500035","500036","500220","500230","500234","500247","500221","500223","500233","500226","500238","500219","500218"]};
                    IDG.GPT.addTarget("proximic", proximic_data.data);
                }
                catch (e){
			        console.log("Error: " + e);
                }
			})();
		</script>
	
	



	
	



	<script>
		var isMobile = (typeof IDG.DEVICE !== 'undefined') ? IDG.DEVICE.isMobile() : false;
		
		
		
		
		
		
		


		
		try {
			// !!!Needed to disable this functionality to fix IDGMPM-15950!!!
			//IDG.GPT.disableInitialLoad = true;
			IDG.GPT.addBiddingParams("yieldbotPsn", (isMobile ? "7541" : "c5a9"));
			IDG.GPT.addBiddingParams("appnexusPlacementId", (isMobile ? "6451477" : "6353206"));
			
			
				IDG.GPT.addBiddingParams("TriLiftPrefix", "javaworld_ros_");
			
		}
		catch(e) {
			console.log("Error in adding bidding params: "+e);
		}
	</script>
	<script src="/www/js/ads/narf_prebid.js?v=20180802113401"></script>	


<script type="text/javascript" src="/www/js/ads/gpt_starter.js?1234"></script>

<script type="text/javascript" src="/www/js/ads/gpt_launcher.js"></script>

	
	
	
	
	
		
				
		
		
		
	

	<link rel="canonical" href="https://www.infoworld.com/article/3293417/development-tools/go-cloud-aims-to-cement-golang-in-the-cloud.html" />
	
	
		
	

	<meta itemprop="url" content="https://www.javaworld.com/article/3294703/development-tools/go-cloud-aims-to-cement-golang-in-the-cloud.html" />
	<meta name="description" content="Go Cloud offers generic APIs to build apps that can be ported across different clouds" />
	<meta name="news_keywords" content="Go Cloud,Golang" />
	
		
			<meta name="DC.date.issued" content="2018-07-27T03:00-05:00" />
			<meta name="date" content="2018-07-27" />
			
		
		
		
	
	
	<link rel="amphtml" href="https://www.javaworld.com/article/3294703/development-tools/go-cloud-aims-to-cement-golang-in-the-cloud.amp.html" />
	
		
		
		
			
			
				
			
			
			
		
	
	
		
		
			<meta property="og:title" content="Go Cloud aims to cement Golang in the cloud">
		
	
	<meta property="og:description" content="Go Cloud offers generic APIs to build apps that can be ported across different clouds">	
	
	
		
			<meta property="og:image" content="https://images.idgesg.net/images/article/2018/07/cloud_hand_touch_create_access_secure-clouds_reach_tech-job-100763725-large.3x2.jpg" />
			<meta property="og:image:width" content="700" />
			<meta property="og:image:height" content="467" />
			<meta itemprop="image" content="https://images.idgesg.net/images/article/2018/07/cloud_hand_touch_create_access_secure-clouds_reach_tech-job-100763725-large.3x2.jpg">
			<meta itemprop="thumbnailURl" content="https://images.idgesg.net/images/article/2018/07/cloud_hand_touch_create_access_secure-clouds_reach_tech-job-100763725-large.3x2.jpg" />
			<link rel="image_src" href="https://images.idgesg.net/images/article/2018/07/cloud_hand_touch_create_access_secure-clouds_reach_tech-job-100763725-large.3x2.jpg" />
			<meta name="twitter:image" content="https://images.idgesg.net/images/article/2018/07/cloud_hand_touch_create_access_secure-clouds_reach_tech-job-100763725-large.3x2.jpg" />
		
		
	
	
		
			<meta property="og:type" content="article" />
			
			
			
			
			
			
			
			
			
			<meta name="author" content="Paul Krill">
			
			
			
			
			
		
		 
		
	<meta property="og:site_name" content="JavaWorld" />
	<meta property="fb:app_id" content="196366870381968" />
	
		
			<meta property="og:url" content="https://www.javaworld.com/article/3294703/development-tools/go-cloud-aims-to-cement-golang-in-the-cloud.html">
		
		
	
	
	<!-- Use Twitter Summary Card with Large Image for articles and videos -->
	
		
				<meta name="twitter:card" content="summary_large_image">
		
		
	

	<meta name="twitter:site" content="@javaworldcom">
	<meta name="twitter:description" content="Go Cloud offers generic APIs to build apps that can be ported across different clouds">

	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	<meta name="rating" content="General">
	
	<meta name="robots" content="NOODP,NOYDIR" />
	
	
	
	
		<meta name="msvalidate.01" content="04917178B598F0648B9BAD693FEC29A3" />
	

	













	<!-- Sailthru -->
	
		<meta name="sailthru.tags" content="development-tools,application-development,scripting-jvm-languages,paul-krill,news,short"/>
	
		<meta name="sailthru.image.thumb" content="https://images.idgesg.net/images/article/2018/07/cloud_hand_touch_create_access_secure-clouds_reach_tech-job-100763725-small.jpg"/>
	
		<meta name="sailthru.image.full" content="https://images.idgesg.net/images/article/2018/07/cloud_hand_touch_create_access_secure-clouds_reach_tech-job-100763725-large.3x2.jpg"/>
	

	
	
		<meta name="sailthru.title" content="Go Cloud aims to cement Golang in the cloud"/>
	
	
	
		<meta name="sailthru.description" content="Go Cloud offers generic APIs to build apps that can be ported across different clouds" />
	

	
	<meta name="displaytype" content="article" />
	
	<meta name="source" content="infoworld" />
	
	<meta name="category" content="development tools,software development,scripting and jvm languages" />
	
	<meta name="storytype" content="news" />
	
	
	
	
	
		
	<!-- pagination -->
	
	
	
	
	
	
	
	
	
	
		<link id="mobile-size" rel="stylesheet" href="/www.idge/css/inline-header-mobile.css?v=20180802113401" />
		
		<script>
			if (window.matchMedia("(min-width: 768px)").matches) {
				document.getElementById('mobile-size').insertAdjacentHTML('afterend', '<link id="desktop-size" rel="stylesheet" href="/www.idge/css/inline-header.css?v=20180802113401" />');
			}
		</script>
		
			
				<link rel="stylesheet" href="/www.idge.jvw/css/inline-header.css?v=20180802113401" />
			
		
	
	
	<!-- css -->
	<link rel="stylesheet" href="/www.idge/css/normalize.css" />
	<link rel="stylesheet" href="/www.idge/css/prettify.css" />
	
		<link rel="stylesheet" href="/www.idge.ans/js/select2-3.5.0/select2.css" />
	
	
	
		
			
			
			
			
				
					
						
						
						
							<link rel="stylesheet" href="/www/css/article.css?v=20180802113401" />
						
					
					
					
			
				
		
		
		
			<link rel="stylesheet" href="/www.idge/css/insider-promo-styles.css?v=20180802113401" />
		
		<link rel="stylesheet" href="/www.idge/css/print.css" media="print" />
		
	
	
		
			
		<link rel="stylesheet" href="/www.idge.jvw/css/article.css?v=20180802113401" />
		
	
	
	<link rel="stylesheet" href="/www.idge/css/webfonts/ss-social.css" />
	<link rel="stylesheet" href="/www.idge/css/webfonts/ss-standard.css" />
	<!--[if lte IE 8]>  
		<link href="/www.idge/css/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]--> 
	
	
	
	
		<link href="//fonts.googleapis.com/css?family=PT+Sans:400,700|PT+Sans+Narrow:400,700" rel="stylesheet" type="text/css" />
	
		
	
	
	
	<!--  fav and touch icons -->
	<link rel="shortcut icon" type="image/x-icon" href="/www.idge.jvw/favicon.ico"/>
	<link rel="apple-touch-icon-precomposed" sizes="144x144" href="/www.idge.jvw/touchicon_144.gif" />
	<link rel="apple-touch-icon-precomposed" sizes="114x114" href="/www.idge.jvw/touchicon_114.gif" />
	<link rel="apple-touch-icon-precomposed" sizes="72x72" href="/www.idge.jvw/touchicon_72.gif" />
	<link rel="apple-touch-icon-precomposed" sizes="57x57" href="/www.idge.jvw/touchicon_57.gif" />
	<link rel="apple-touch-icon" href="/www.idge.jvw/images/JVW_logo_300x300.png" />
	
	
		<script src="/www.idge.ans/js/select2-3.5.0/select2.js"></script>
	
	
	
	
	
	
		<script>
		   $(document).ready(function() { 
			   $("select#country").select2({
			    	placeholder: "country",
			    	minimumResultsForSearch: Infinity,
			    	allowClear: true
			    });
			   $("select#state").select2({
			    	placeholder: "state",
			    	minimumResultsForSearch: Infinity,
			    	allowClear: true
			    });
			    $("#jobPosition").select2({
			    	placeholder: "position",
			    	minimumResultsForSearch: Infinity,
			    	allowClear: true
			    }); 
			   	$("#jobFunction").select2({
			   		placeholder: "function",
			   		minimumResultsForSearch: Infinity,
			    	allowClear: true
			   	}); 
			   	$("#companySize").select2({
			   		placeholder: "company size",
			   		minimumResultsForSearch: Infinity,
			    	allowClear: true
			   	});
			   	$("#industry").select2({
			   		placeholder: "industry",
			   		minimumResultsForSearch: Infinity,
			    	allowClear: true
			   	}); 
		   });
	   </script>
   	    
   	     











<script>

var brandCode = "jvw";
var brandName="JavaWorld";
var brandId = "9";
var regDebugLog=false;
var regApiUrl='https://api-stage.idgcommunications.net/api/v1/';
var apiKey="HLyMXLISSW7HAYGgbx2Vb1Gf1OLcGmMG5BcwZ4Vb";
var tokenPrefix='www';
var tokenSuffix='.com/insider/token?';
var brandDomain=".javaworld.com";
var insiderContentType="article";
var notEmptyArticle=false;
var notEmptyMediaResource=false;
var isInsiderPremium=false;
var isResourceInsiderPremium=false;
var assetId="697422d1-7acb-40f6-be13-0e67329bc9ec";
var placementId="2d44d74a-e883-4d18-ada8-b2f0e61a1d90";


	regApiUrl="https://lqxgcyk808.execute-api.us-east-1.amazonaws.com/prod/api/v1/";



	regDebugLog=false;



	tokenPrefix="http://www";



	tokenSuffix="/insider/token";





	notEmptyArticle=true;


	



 

</script>


<script src="/www/js/utils/alc_hashes.js"></script>
<script src="/www/js/insider/insider_reg_api.js?v=20180802113401"></script>
<script src="/www/js/insider/jquery.maskedinput-1.4.min.js"></script>

<script>
$(document).ready(function(){
	if(typeof(IDG.insiderReg.readCookie('nsdr')) !== 'undefined'){
		$('#welcome-message').show();			
		IDG.insiderReg.personalize();
	}else{
		$('.signin-register').show();	
	}
});

</script>


	
	
	




	
	
	
	
















	
	
	<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
	
	
	<script src="/www/js/ads/ads.js"></script>
	
	<script>var oneRegPlacementID = "";</script>
	
	
	
	
	
		
			
				
			
			
			
			
			
		
		
		
	
	
	
	





	
		
	
		
	
	





		
		  
		
		
		
		

	
	
	
	
	  	 
	    
	    
	 
	 
	
	
	
	
	
	
	
	
		
	
	
	
	
	
	
	
		
			
				
				
				
					
				
			
			
			
			
		
		
		
	
	
	
	

	
	
	
	
	
	<script>
	var insiderSignedIn = document.cookie.indexOf("nsdr") > -1; //check if Insider cookie exists
	var idg_uuid = $.cookie('idg_uuid') || '';
	
	var dlJobFunction = '';
	var dlJobPosition = '';
	var dlIndustry = '';
	
	if (insiderSignedIn) {
		var insiderToken = IDG.insiderReg.readCookie("nsdr");
		var tokens = IDG.insiderReg.readCookieProperty(insiderToken);
		if (!(tokens['jobPosition']===undefined)) {
			dlJobPosition = tokens['jobPosition'];
		}
		if (!(tokens['jobFunction']===undefined)) {
			dlJobFunction = tokens['jobFunction'];
		}
		if (!(tokens['industry']===undefined)) {
			dlIndustry = tokens['industry'];
		}
	}
	
	insiderSignedIn = insiderSignedIn.toString(); //per Infotrust this needs to be a string, not a boolean
	
	var sincePublished = '6 days';
	sincePublished = sincePublished.split(" ")[0];
	
	
	dataLayer=[{
		'articleId': '3294703',
		'articleDisplayId':'1',
		'articleTitle': 'Go Cloud aims to cement Golang in the cloud',
		'articleType': 'News',
		'audience':'enterprise',
		'author':'Paul Krill',
		'blogName':'',
		'brandpost': 'false',
		'categoryIdList':'3465,3646,3249',
		'categoryIdPrimary': '3465',
		'contentStrategy': '',
		'contentType':'news',
		'datePublished':'2018-07-27',
		'dateUpdated':'',
		'daysSincePublished':sincePublished,
		'daysSinceUpdated':'',
		'displayType':'article',
		'environment':'production',
		'ga_enabled':'true',
		'gaTrackingId':'UA-300704-19',
		'geolocEnabled':'true',
		'goldenTaxonomyIdPrimary': '287',
		'goldenTaxonomyIdList': '287,241,281',
		'industry': dlIndustry,
		'insiderSignedIn':insiderSignedIn,
		'isBlog':'false',
		'isInsiderContent':'false',
		'isICN': 'false',
		'jobFunction': dlJobFunction,
		'jobPosition': dlJobPosition,
		'oneRegPlacementID':oneRegPlacementID,
		'pageNumber':'1',
		'platform':'Web',
		'podcastSponsored': 'false',
		'primaryCategory': 'development tools',
		'primaryCategoryList': 'development tools,software development,scripting and jvm languages',
		'property': 'javaworld',
		'propertyCountry':'US',
		'purchaseIntent':'awareness',
		'sailthruCustomerId':'8a7950ccf4b505820f4688ea815011b6',
		'skimlinksId':'',
		'source':'infoworld',
		'sponsorName':'',
		'tags': '',
		'userId':idg_uuid,
		'videoAutoplay':'false',
		'articleHasVideo':'false'	
	}];
	</script>
	
	












	
<script type="text/javascript">
	var _sf_async_config={};

	_sf_async_config.uid = 29363;

	_sf_async_config.path = "/article/3294703/development-tools/go-cloud-aims-to-cement-golang-in-the-cloud.html";
	_sf_async_config.title = "Go Cloud aims to cement Golang in the cloud | JavaWorld";
	_sf_async_config.domain = "javaworld.com";
	if(window.location.href.indexOf("video")&&true) {
		_sf_async_config.playerdomain= _sf_async_config.domain.replace("www.","");
	}
	
	_sf_async_config.useCanonical = true;
	
		
			
			_sf_async_config.sections = "development-tools";
			_sf_async_config.authors="Paul Krill";
			
		
	
</script>



	
	
	
	
	
	
	
	










<script>
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var adBlockStatus = 'false';
	
	function AdBlockEnabled() {
		var ad = document.createElement('ins');
		ad.className = 'AdSense';
		ad.style.display = 'block';
		ad.style.position = 'absolute';
		ad.style.top = '-1px';
		ad.style.height = '1px';

		if (document.body != null) {
			document.body.appendChild(ad);
			var isAdBlockEnabled = !ad.clientHeight;
			document.body.removeChild(ad);
		}

		return isAdBlockEnabled; 
	}
	// AdBlockEnabled() was successful document.body not null
	if (AdBlockEnabled() != undefined) {
		adBlockStatus = AdBlockEnabled().toString();
	}
	// not successful - look for ads.js
	if (document.body == null) {
		if (window.canRunAds === undefined) {
			adBlockStatus = 'true';
		} else {
			adBlockStatus = 'false';
		}
	}
	
	dataLayer.push({
		'adBlockStatus': adBlockStatus
	});
</script>




	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-MMJKZ9"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-MMJKZ9');</script>
	<!-- End Google Tag Manager -->

	
	
	
	
	

	<script src="https://www.google.com/recaptcha/api.js" async defer></script>
	
	
	
		<script async src="//js-sec.indexww.com/ht/p/187051-164251026496775.js"></script>
	
	
	
	
	
	
</head>


	<body id="article3294703" class="article javaworld">
		
			
			
					
					
						
						
					





















	

		
			
			
				<!-- Begin welcome ad overlay - gpt-overlay position  -->
				
					<div id="superadunit" class="hidden">
						<div class="ad">
							<div class="ad-header">
								<div class="brand-logo"></div>
								<a href="javascript:unhide('superadunit');" id="superstitial-text">Close Ad</a>
							</div>
							<div id="gpt-overlay" class=" ad-container">
								<script type="text/javascript">
								consent.ads.queue.push(function(){
									
										IDG.GPT.addDisplayedAd("gpt-overlay", "true");
										IDG.GPT.displayGoogleTagSlot('gpt-overlay');
									
								});
								</script>
							</div>
						</div>
					</div>
				
				
				<!--  End welcome ad overlay - gpt-overlay position -->
				
			
			
			
			
			
		
	
 	
 
 
				
			
		
		













<!-- BEGIN PAGE HEADER -->
<header id="banner" >
	
	
	
	
	
	
    
    
    
    	
    	<script>
    	if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
			$('.main-header').insertBefore($('#banner .ad'));
    	}
		</script>
		
		
		<div class="topics-wrap">
		    <section class="topics">
		        <nav id="scrollable">
					
						
						
							
						
					











	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #670 blox4.raw_link_list  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
				
				
			
		












	
		
		
			
		
	
	
	<ul>
		
		<li class="header">Trending<span class="colon">:</span></li>
		
		
			
				<li><a href="/category/learn-java/" >Learn Java</a></li>
			
		
			
				<li><a href="/blog/java-101/" > Java 101</a></li>
			
		
			
				<li><a href="/category/java-app-dev/ " > Java App Dev</a></li>
			
		
			
				<li><a href="/category/developer-tools-ide/" >Java Toolbox</a></li>
			
		
			
				<li><a href="/blog/open-source-java-projects/" >Open Source Java </a></li>
			
		
			
				<li><a href="/category/careers/" >Programming Careers</a></li>
			
		
			
				<li><a href="/blog/java-qanda/" >Java Q&A</a></li>
			
		
			
				<li><a href="/resources" >Resources/White Papers</a></li>
			
		
			
				<li><a href="/jobs" >Job Search</a></li>
			
		
	</ul>

	


		        </nav>
		        
		        <div class="fading-gradient"></div>
		        
		        
		        <nav class="tools">
		        	<ul class="user">
	                     
	                     	<li class="search-icon"><a href="#search" id="search-btn"><i class="ss-icon">Search</i></a></li>
	                     
	                 </ul>
	                 <ul class="social">
						














	<li><a href="https://twitter.com/javaworldcom" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>



	<li><a href="http://www.linkedin.com/company/javaworld-com" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>



	<li><a href="https://www.facebook.com/pages/JavaWorld/107993545895326" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>				



	<li><a href="https://plus.google.com/117974570132126965756/posts" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>                	







	<li><a href="/index.rss" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>




	<li class="more-social"><i class="ss-icon ss-ellipsis"></i></li>

	                 </ul>
	             </nav>
	             
		    </section>
	    </div>
	    
	    
        	 <div id="sticky-anchor"></div>
        
	    <section id="sticky-head" class="main">
	        <div class="wrapper">
	            <div class="masthead">
	                
	                <button><i class="ss-icon ss-rows"></i></button>
	                
	                <a href="/"><span class="ir logo">javaworld</span></a>
	            	<!--
	            	<img class="print-only" src="/www.idge.jvw/images/javaworld-logo-print.png">
	            	-->
	            	
	            	<img class="print-only" src="//idge.staticworld.net/jvw/javaworld-logo-print.png">
	            	
	            </div>
	            <div id="reading-tools-wrapper">

	                
	                <nav class="tools">
	                    
	                    <ul class="user">
	                    	
	                    	
	                    	
	                    	
	                        
	                    </ul>
	                </nav>
	            </div>
	            
	            
	            	<div class="insider-signin">
	            	
	            		<span class="signin-register">
	            			<a href="/learn-about-insider/"><span class="insider"></span></a> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-signin')" class="js-open-modal signin" data-modal-id="insider-popup">Sign In</a> <span class="divider">|</span> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-form-short')" class="js-open-modal register" data-modal-id="insider-popup">Register</a>
	            		</span>
	            	
	            		<div id="welcome-message" class="insider-list">
		                    <div id="insider-selector">
		                        <div id="insider-welcome" class="label"></div>
		                        
		                        <div class="stories">
		                        	
		                        	<div class="personalization">Hi<span id="person-first-name"></span>! Here are the latest Insider stories.</div>
		                        	
		                        	











	
	
	
	
	
	
	
	
	
	





























































	<ul>
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3294220/python/guido-van-rossum-resigns-whats-next-for-python.html">Guido van Rossum resigns: What’s next for Python</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3291281/analytics/3-big-data-platforms-look-beyond-hadoop.html">3 big data platforms look beyond Hadoop</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3290468/agile-development/how-to-align-test-automation-with-agile-and-devops.html">How to align test automation with agile and devops</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3282827/cloud-computing/database-shift-start-with-open-source-but-finish-with-aws.html">Database shift: Start with open source but finish with AWS</a></li>
				
				
			
		
	</ul>




									
									<div class="sign-out-link">
										<a class="more-insider" href="/insider/">More Insider</a>
										<a class="sign-out" href="javascript://" onclick="IDG.insiderReg.logout()">Sign Out</a>
									</div>
								</div>
								
		                    </div>
		                </div>
		         
	            	</div>
	            	<script>
	            		$('.signin-register').hide();	
	            		$('#welcome-message').hide();
	            	</script>
	            	
	            
	            
	        </div>
	    </section>
	    <section class="tools-expand  ">
	        
	        
	        
	        
	        	
	        	
	        		
			        <form class="search" id="search-form" action="/search">
			            <label for="search-box">Search for</label>
						<input type="text" name="query" id="banner-search-term" value="" class="searchbox-input-class"/>
			            <input type="submit" id="banner-search-submit" value="Go" />
			            <input type="hidden" name="contentType" value="article,resource" />
			            <div class="search-suggest">Suggestions for you</div>
			        </form>
			    
			
	        <div class="user">
	            <form>
	                <label for="login-email">Insider email</label> <input id="login-email" type="text" />
	            </form>
	        </div>
	        
	    </section>
	    
	    
	    
		
		
    		<div id="sticky-anchor-nav"></div>
    	
    	
	    <nav id="sticky-nav" class="main">
	    	<ul class="topnav">
				
					
	        		
	        		
	        			
	        				<li><a href="/category/core-java/" class="hasChildren">Core Java<span class="ss-icon ss-navigatedown"></span></a>
	            		
	            		
	            	
	            		
	            		
		            		<ul class="subnav">
		                		<li><a href="/category/core-java/">All Core Java</a></li>
		            			
		            				<li><a href="/category/agile-development/">Agile Development</a></li>
		            			
		            				<li><a href="/category/java-concurrency/">Java Concurrency</a></li>
		            			
		            				<li><a href="/category/java-language/">Java Language</a></li>
		            			
		            				<li><a href="/category/java-platform/">Java Platform</a></li>
		            			
		            				<li><a href="/category/security/">Java Security</a></li>
		            			
		            				<li><a href="/category/careers/">Programming Careers</a></li>
		            			
		            				<li><a href="/category/testing-debugging/">Testing and Debugging</a></li>
		            			
		            		</ul>
		            	
	        		</li>
				
					
	        		
	        		
	        			
	        				<li><a href="/category/enterprise-java/" class="hasChildren">Enterprise Java<span class="ss-icon ss-navigatedown"></span></a>
	            		
	            		
	            	
	            		
	            		
		            		<ul class="subnav">
		                		<li><a href="/category/enterprise-java/">All Enterprise Java</a></li>
		            			
		            				<li><a href="/category/apis/">APIs</a></li>
		            			
		            				<li><a href="/category/big-data/">Big Data</a></li>
		            			
		            				<li><a href="/category/cloud-computing/">Cloud Computing</a></li>
		            			
		            				<li><a href="/category/analytics/">Data Analytics</a></li>
		            			
		            				<li><a href="/category/development-tools/">Development Tools</a></li>
		            			
		            				<li><a href="/category/application-development/">Java App Dev</a></li>
		            			
		            				<li><a href="/category/web-development/">Java Web Development</a></li>
		            			
		            				<li><a href="/category/open-source-tools/">Open Source</a></li>
		            			
		            				<li><a href="/category/scripting-jvm-languages/">Scripting and JVM Languages</a></li>
		            			
		            		</ul>
		            	
	        		</li>
				
					
	        		
	        		
	        			
	        				<li><a href="/category/learn-java/" class="hasChildren">Learn Java<span class="ss-icon ss-navigatedown"></span></a>
	            		
	            		
	            	
	            		
	            		
		            		<ul class="subnav">
		                		<li><a href="/category/learn-java/">All Learn Java</a></li>
		            			
		            				<li><a href="/category/design-patterns/">Design Patterns</a></li>
		            			
		            		</ul>
		            	
	        		</li>
				
					
	        		
	        		
	        			
	        				<li><a href="/category/mobile-java/" class="hasChildren">Mobile Java<span class="ss-icon ss-navigatedown"></span></a>
	            		
	            		
	            	
	            		
	            		
		            		<ul class="subnav">
		                		<li><a href="/category/mobile-java/">All Mobile Java</a></li>
		            			
		            				<li><a href="/category/android/">Java Android Developers</a></li>
		            			
		            				<li><a href="/category/ios/">Java iOS Developers</a></li>
		            			
		            		</ul>
		            	
	        		</li>
				
			</ul>
	
	    	<ul class="secondary">
           		
           		










<li><a href="/news/">News</a></li>
<li><a href="/feature/">Features</a></li>
<li><a href="/howto/">How-Tos</a></li>
<li><a href="/blogs/">Blogs</a></li>
<li><a href="/resources/">Resources/White Papers</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
           		
	    	</ul>
		</nav>
		
	
	
	
	
	
	
	
		<script>
    	if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
			$('div.insider-signin').prependTo('section.topics nav.tools');
    	}
		</script>
	
    
		<script>
		$(document).ready(function(){
			if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
				$("nav ul li a.hasChildren").attr("href", "#").addClass('notMobile');
				$('nav#sticky-nav ul.secondary').addClass('topnav');
			}
			if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
				$("nav#sticky-nav > ul").switchClass("topnav", "primary");
			}
		});
		</script>
	
	
		
    	<script>
    	if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
			$('#sticky-anchor, section.main, section.topics, section.tools-expand, #sticky-anchor-nav, nav.main').insertBefore($('#banner .ad'));
			$(document).ready(function(){
				$('#banner section.tools-expand').addClass('top-margin');
			});
    	}
		</script>
		
	
	
	
</header>



<script>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</script>



	<div id="insider-popup" class="modal-box ">
	
		<div class="insider-modal-wrapper">
	  
			<div class="modal-header-title">
				<div class="modal-banner-insider"><span class="insider"></span></div>
		    	<div class="modal-close close">×</div>
		  	</div>
		  	
		  	<div class="modal-body">
		  		
		  			
						<script>
$(document).ready(function(){
	$('a[data-link]').click(function() {
		
		  //get this link's dataLink value
		  var dataLink = $(this).attr('data-link');

		  //select the div with the same value
		  var toKeep = 'div[data-link="'+dataLink+'"]';
	
		  //select data-link divs that are not the above div
		  $('div[data-link]').not(toKeep).hide();
		  
		  if($(this).hasClass('link-transition')){
			  $(toKeep).fadeIn(800);
		  } else {
			  $(toKeep).show();
		  }
	
		  //prevent location change
		  return false;
	});
	

});
</script>

					
					
				
		  	</div>
		  	
		  	<div class="modal-footer">
		    	<div class="modal-close close-btn">Close</div>
		  	</div>
		</div>
	  	
	</div>

	<script>
		$(document).ready(function(){

			var appendthis =  ("<div class='modal-overlay modal-close'></div>");
			if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
				$('.modal-box').css({
					//top: ($(window).height() - $(".modal-box").outerHeight()) / 2,
					top: 10,
					left: 0
				});
			}
			
			
			if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
				$('.modal-box').height($(document).height());
				$('.modal-box').css('top','0');
			}
			
			var userAg = navigator.userAgent;

			$('a[data-modal-id]').click(function(e) {
				e.preventDefault();
				$('body').append(appendthis);
				$('.modal-overlay').fadeTo(500, 0.9);
				$('.modal-overlay').height($(document).height());
				var modalBox = $(this).attr('data-modal-id');
				
				if ($(".modal-box").hasClass('triggered') || (userAg.indexOf("Firefox")!=-1)) {
					$('#'+modalBox).fadeIn($(this).data()); // triggered by something other than onclick of link such as scroll to point in window
				} else {
					// IDGMPM-16177
					//if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
						$('#'+modalBox).toggle('slide', {direction: 'up'}, 800);
					//} else {
				   // 	$('#'+modalBox).toggle('slide', {direction: 'left'}, 600);
					//}
				}

				if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
					$("html, body").animate({
			            scrollTop: 0
			        }, 700);
			        
			        
			        $('a.btn.continue-on').click(function() {
			        	$('html, body').animate({
			        		scrollTop: 0
			        	}, 500);
			        });
			        
			        return false;
			        
				}
				if (navigator.userAgent.match(/(iPad)/)) {
					$("html, body").animate({
			            scrollTop: 0
			        }, 500);
				}
			});
		  
		  
			$(".modal-close, .modal-overlay").click(function() {
				$('.select2-drop').css('display','none');
				$(".modal-overlay").fadeOut(500, function() {
					$(".modal-overlay").remove();
				});
				if ($(".modal-box").hasClass('triggered') || (userAg.indexOf("Firefox")!=-1)) {
					$(".modal-box").fadeOut(500);
				} else {
					// IDGMPM-16177
					//if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
						$('.modal-box').toggle('slide', {direction: 'up'}, 800);
					//} else {
					//	$('.modal-box').toggle('slide', {direction: 'left'}, 600);
					//}
				}
			});
		
		});
	</script>






<!-- END PAGE HEADER -->



		
		











<div id="page-wrapper" class="page-wrapper">
	
	













<div id="skinAdTarget"></div>


			
		











	
	
	
	
	
	
	
	
	
	
	
	
	
	





	
	
 	







	
	<section role="main">

		<article itemscope itemtype="http://schema.org/NewsArticle"  >

		















	
	
		
		
			<div class="ticker-ad ad">
				
					
				





















	

		
			
			
			
			
			
				<div id="ticker" class=" ad-container">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				
					IDG.GPT.addDisplayedAd("ticker", "true");
					$('#ticker').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: ticker - [971 1115]");
				
				});
				</script>
			
		
	
 	
 
 
			</div>
		
	
	



<!-- Events Header -->

 
 
	
		
		
		
		
		
					    			
		
	
	
	
	
	

 
 
 
 
  
  
 
 












	
	
	
	
	
	
	
	
	
	
	
	
	
	


<!-- //end Events Header -->


	
	
	
	
	
	
		
	



	
		
	
	
	
		





















	
			















<header  class='cat'>

	
	
	
	
	
	
	
	
	
	
	
	<nav class="breadcrumbs horiz">
		<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
			<li><a href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
			
				
				
					<li><a href="/category/enterprise-java/" itemprop="url"><span itemprop="title">Enterprise Java</span></a></li>
				
				
					<li><a href="/category/development-tools/" itemprop="url"><span itemprop="title">Development Tools</span></a></li>
				
			
		</ul>
	</nav>
	
	
	
	
	
	
	
		
		
			<div class="category"><a href="/news" itemprop="genre">News</a></div>
		
	
	

	<h1 itemprop="headline">Go Cloud aims to cement Golang in the cloud</h1>
	
	
	
	
		<section class="deck viewability">
			<h3 itemprop="description">Go Cloud offers generic cloud APIs to build apps that can be ported across different clouds</h3>
		</section>
	
	
	
	
		<div class="cat-social">
			
				
			


















	

				

	
	
		
	



	
	


	


<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">


	<li class="sosh">
		<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3294703%2Fdevelopment-tools%2Fgo-cloud-aims-to-cement-golang-in-the-cloud.html&via=javaworldcom&text=Go+Cloud+aims+to+cement+Golang+in+the+cloud" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg" />
		</a>
	</li>
	<li class="sosh">
		<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3294703%2Fdevelopment-tools%2Fgo-cloud-aims-to-cement-golang-in-the-cloud.html" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg" />
		</a>
	</li>
	<li class="sosh">
		<a href="http://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3294703%2Fdevelopment-tools%2Fgo-cloud-aims-to-cement-golang-in-the-cloud.html&title=Go+Cloud+aims+to+cement+Golang+in+the+cloud" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/linkedin.svg" />
		</a>
	</li>
	<li class="sosh">
		<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3294703%2Fdevelopment-tools%2Fgo-cloud-aims-to-cement-golang-in-the-cloud.html" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/gplus.svg" />
		</a>
	</li>
	<li class="sosh hide">
		<a href="http://reddit.com/submit?url=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3294703%2Fdevelopment-tools%2Fgo-cloud-aims-to-cement-golang-in-the-cloud.html&title=Go+Cloud+aims+to+cement+Golang+in+the+cloud" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg" />
		</a>
	</li>
	<li class="sosh hide">
		<a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3294703%2Fdevelopment-tools%2Fgo-cloud-aims-to-cement-golang-in-the-cloud.html" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/stumbleupon.svg" />
		</a>
	</li>
	<li class="sosh hide">
		<a href="#email" id="email-icon">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg" />
		</a>
	</li>
	<li class="sosh hide print">
		<a href="javascript:window.print();">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg" />
		</a>
	</li>
	<li class="more">
		<div class="more-icon" onclick="document.getElementById('share-tool').className = 'expand';"></div>
	</li>




</ul>
</div>
<script type="text/javascript">
var isValidEmailAddress = isValidEmailAddress || function(emailAddress) {
    var pattern = new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);
    return pattern.test(emailAddress);
};
function encodeQueryData(params) {
	var ret = [];
	for (var paramKey in params) {
		ret.push(encodeURIComponent(paramKey) + "=" + encodeURIComponent(params[paramKey]));
	}
	return ret.join("&");
}	
function bindEmailModal() {
	$('#emailModal').on("click",".close-btn",function(event) {
		event.preventDefault();
        $('#emailModal').hide();
        $("#emailModal .eml-friend").show();
        $(".eml-friend-success").hide();
        $(".eml-friend-error").hide();
		$('#emailModal').fadeOut(200);
		$('#email-to').val('');
		$('#email-from').val('');
		$('#name').val('');
		$('#personalization').val('');
		$('#eml-from-address-message').html("");
		$('#eml-to-address-message').html("");
		$('#eml-friend-captcha-message').html("");
	});

	$('#emailModal').on("submit","form",function(event) {
		event.preventDefault();
		var $form = $(this);
		var action = $form.attr('action');
		var formData = $form.serialize();
		var emailFrom = $('#email-from').val();
		var emailTo = $('#email-to').val();
		var uresponse=$('#g-recaptcha-response').val();
		$('#eml-from-address-message').html("");
		$('#eml-to-address-message').html("");
		$('#eml-friend-captcha-message').html("");
		if (isValidEmailAddress(emailFrom) && isValidEmailAddress(emailTo) && uresponse !="") {
			// eloqua
			
			// email
			$.ajax(action, {
				type: 'POST',
				data: formData,
				success: function(data, textStatus, xhr) {
					$("#emailModal .eml-friend").hide();
					$(".eml-friend-success").fadeIn(800);	
				},
				error: function(xhr, textStatus, errorThrown) {
					$("#emailModal .eml-friend").hide();
					$(".eml-friend-error").fadeIn(800);						
				}
			});
		}
		else {	
			if(uresponse==""){
				$('#eml-friend-captcha-message').html("Please verify you're not a robot!");	
			}
			if(!isValidEmailAddress(emailTo)){
			  $('#eml-to-address-message').html("Please enter a valid email address.");		
			}
			if(!isValidEmailAddress(emailFrom)){
			  $('#eml-from-address-message').html("Please enter a valid email address.");		
			}
		}
	});
} //bindEmailModal() end

$(document).ready(function() {
	$(document).on("click","#email-icon",function(event) {
		event.preventDefault();
		bindEmailModal();
		$('#emailModal').fadeIn(800);
	});
});
</script>
<div class="modal eml-friend-wrapper" id="emailModal" style="display:none;">	
	<form class="eml-friend" action="/eloquaemail/article?eloqua=false&id=3294703">
		<input type="hidden" name="title" value="Go Cloud aims to cement Golang in the cloud" />
		<input type="hidden" name="url" value="https://www.javaworld.com/article/3294703/development-tools/go-cloud-aims-to-cement-golang-in-the-cloud.html" />
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Email a friend</h3>

		<div class="input-row">
			<div id="eml-to-address-message" class="error-msg"></div>
			<h4 class="input-label">To</h4>
			<input id="email-to" value="" placeholder="Email address (required)" type="email" name="recipients" tabindex="1">
			<p class="addl-text">Use commas to separate multiple email addresses</p>
		</div>
		<hr />
		<div class="input-row">
			<div id="eml-from-address-message" class="error-msg"></div>
			<h4 class="input-label">From</h4>
			<input id="name" value="" placeholder="Name (optional)" type="text" name="name" tabindex="2">
		</div>
		<div class="input-row">
			<input id="email-from" value="" placeholder="Email address (required)" type="email" name="sender" tabindex="3">
		</div>
		<div class="input-row">
			<textarea name="message" placeholder="Check out this article I found on JavaWorld." id="personalization" tabindex="4"></textarea>
		</div>
		<hr />
		<div class="input-row">
			<div id="eml-friend-captcha-message" class="error-msg"></div>
		
		
 			











<script src="https://www.google.com/recaptcha/api.js" async defer></script>

<div class="g-recaptcha" data-sitekey="6LczmkcUAAAAANEO7J277KwH6Kzp6BEQjPTWP4S4"></div>
 		</div>
		<hr />
		<div class="submit">
			<input type="submit" value="Send" class="input-submit" tabindex="5">
			<a href="/about/privacy.html" class="submit-privacy" target="_blank">Privacy Policy</a>
		</div>
	</form>

	<div class="eml-ty eml-friend-success" style="display:none;">
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Thank you</h3>
		<p class="msg-sent">Your message has been sent.</p>
	</div>
	<div class="eml-friend-error" style="display:none;">
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Sorry</h3>
		<p class="msg-sent">There was an error emailing this page.</p>
	</div>
</div>

		</div>
	
	
	

	
		
			
				
				<div class="cat byline vcard author with-image">		
					<div class="byline-wrapper">
						<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
							
						
							
							
							
							
						
















<a href="/author/Paul-Krill/" rel="author" title="Paul Krill"><img  class="bylineImage  imgId100356327 " src="https://images.techhive.com/images/article/2014/07/paulkrill_crop-100356327-byline.jpg" width="34" width="34" alt="Paul Krill" itemprop="image" /></a>

						
							
								
							
















<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Paul-Krill/"><span itemprop="name">Paul Krill</span></a></span>
						</p>
						<p class="dateline">
						
							Editor at Large, 
								
									
								












<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name"><a href="http://www.infoworld.com/" rel="nofollow" target="_blank">InfoWorld</a></span><meta itemprop="logo" content="https://www.javaworld.com/www.idge.jvw/images/JVW_logo_300x300.png"/></span> <span class="divider break">|</span>
							
										
							<span class="pub-date" class='break-date' itemprop="datePublished" content="2018-07-27T03:00-0700">Jul 27, 2018 3:00 AM
								 PT
							</span>
						</p>
					</div>
				</div>
			
		
	
	
		
	
	
		
		    <div class="ad viewability">
		  		
					
				





















	

		
			
			
			
			
			
				<div id="topleaderboard" class=" ad-container">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				
					IDG.GPT.addDisplayedAd("topleaderboard", "true");
					$('#topleaderboard').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: topleaderboard - [971 1115]");
				
				});
				</script>
			
		
	
 	
 
  
		    </div>		    
		
	
	
	
	
	
</header>



	
	
	
	
		
		
			
                
                	
                	
                
                
				
				
				
			
			
			
			
			<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
				<meta itemprop="representativeOfPage" content="1" />
				<meta itemprop="height" content="467" />
				<meta itemprop="width" content="700" />
	    		
	    		<img src="https://images.idgesg.net/images/article/2018/07/cloud_hand_touch_create_access_secure-clouds_reach_tech-job-100763725-large.jpg" alt="Go Cloud aims to cement Golang in the cloud" itemprop="contentUrl" itemprop="url" />
	    		
	    		<figcaption>
	    			
	    			
	    				<span class="credit" itemprop="copyrightHolder">
	    					
			    				
			    					<a href="https://unsplash.com/photos/7FOSJVtUtac" target="_blank" rel="nofollow">Jeremy Perkins</a>
			    				
			    				
		    				

			    			
			    				
			    				
			    				
								
								  	
								
								  	
								
								  	
								
								  	
								
								  	
								
								  	
								
								  	
								
								  	
								
								  	
								
								  	
								
								  	
								
								  	
								    	
								  	
								
			    				
			    				
									
									
									
										
											<a href="https://creativecommons.org/publicdomain/zero/1.0/" target="_blank" rel="nofollow">(CC0)</a>
										
										
									
								
								
							
					
						</span>
	    			
					
	    		</figcaption>
			</figure>
			

		
		
	











	
	
	
	
		
	



<section class="epo cat-narrow" id="drr-top-ad">
	
		
		
				
   	
   	
   	
   		
   			
   		











<!-- Related -->










	<div class="related-promo-wrapper">
		<div class="promo apart">
			<div class="hed">More like this</div>
	    	<ul class="">
		    	
		    		
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/3287056/application-development/yugabyte-review-planet-scale-cassandra-and-redis.html"><img  class="carousel.idgeImage  imgId100265504 " src="https://images.techhive.com/images/article/2014/05/planet-mars-close-up-with-sunrise-in-space-158456999-100265504-carousel.idge.jpg" alt="planet mars close up with sunrise in space 158456999" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/3287056/application-development/yugabyte-review-planet-scale-cassandra-and-redis.html">YugaByte review: Planet-scale Cassandra and Redis</a></div>
	</div>
</li>
		    	
		    		
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/3287153/application-development/github-vs-bitbucket-vs-gitlab-an-epic-battle-for-developer-mindshare.html"><img  class="small.3x2Image  imgId100763250 " src="https://images.idgesg.net/images/article/2018/07/branches_branching_trees_bare_black_and_white_by_gratisography_cc0_via_pexels_1200x800-100763250-small.3x2.jpg" alt="branches / branching / bare trees" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/3287153/application-development/github-vs-bitbucket-vs-gitlab-an-epic-battle-for-developer-mindshare.html">GitHub vs. Bitbucket vs. GitLab: An epic battle for developer mindshare</a></div>
	</div>
</li>
		    	
		    		
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/3294221/application-development/gke-tutorial-get-started-with-google-kubernetes-engine.html"><img  class="small.3x2Image  imgId100752095 " src="https://images.idgesg.net/images/article/2018/03/robot_monitoring_maintaining_fixing_cog_wheel_system_automation_gettyimages-820097186_3x2-100752095-small.3x2.jpg" alt="robot monitoringa  cog wheel system for maintenance [automation]" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/3294221/application-development/gke-tutorial-get-started-with-google-kubernetes-engine.html">GKE tutorial: Get started with Google Kubernetes Engine</a></div>
	</div>
</li>
		    	
		    	
					
					
						
						
						
							
							
							
							
							
							
							
							
							
							
						






























































					
				
		    </ul>
		</div>
	</div>

   	


				<div class="ad top-ad">
	
		
		
			
				
					
					
						
					
				
				
				
			





















	

		
			
			
			
			
			
				<div id="topimu" class="adunit ad-container">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				if($(window).width() >= 930) {
					IDG.GPT.addDisplayedAd("topimu", "true");
					$('#topimu').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: topimu - [971 1115]");
				}
				});
				</script>
			
		
	
 	
 
 
		
	
</div>
		
	
</section>











		
		



		<section class="bodee">

			
				
				
					












	
		



















	







	<div class="ad placement">
		
			
		





















	

		
			
			
				<!--  Begin gpt-skin/inread -->
				<div id="inread" class=" ad-container">					
				</div>
				<script type="text/javascript">
				consent.ads.queue.push(function(){
					IDG.GPT.addDisplayedAd("inread", "true");
					IDG.GPT.displayGoogleTagSlot('inread');
				});
				</script>
				<!--  End gpt-skin/inread -->	
			
			
			
			
		
	
 	
 
 
	</div>








	
	
		
		
		<script>
			var dataLayer = window.dataLayer = window.dataLayer || [];
			dataLayer.push({
				'event': 'loadTopCollectionModule'
				});
		</script>
		
	


















<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>
		


		

		












	
	



<script type="text/javascript">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</script>






	
	
		
	





	
		
			
			
			
				
			
			
		
	
	


	
	
		<div id="drr-container" class='cat ' itemprop="articleBody">
	
	
	
	

	<p>Google wants to make its <a href="https://www.infoworld.com/article/3201037/application-development/whats-new-in-googles-go-language.html">Go language (Golang)</a> a staple of cloud application development with its open source Go Cloud project, featuring a library and tools to build apps that can be ported across different clouds. Available in a very early beta version, Go Cloud is not yet suitable for production use.</p><p>Go offers cloud development benefits, including low latency and built-in concurrency. Go Cloud, meanwhile, provides APIs to write simpler, more-portable applications.</p><aside class="fakesidebar"><strong>[ Also on InfoWorld: <a href="https://www.infoworld.com/article/3198928/development-tools/whats-the-go-language-really-good-for.html">What’s the Google Go language really good for?</a> Find out! • Deep Dive PDF: <a href="https://www.infoworld.com/resources/73073/application-development/what-you-need-to-know-about-google-go.html">What you need to know about Google Go</a>. • Changelog: <a href="https://www.infoworld.com/article/3201037/whats-new-in-googles-go-language.html">What’s new in Google Go</a>. • <a href="https://www.infoworld.com/article/3190210/application-development/tap-the-power-of-googles-go-language.html">Tap the power of Google’s Go language</a>. • <a href="https://www.infoworld.com/article/3171158/application-development/the-best-go-language-ides-and-editors.htm">The best Go language IDEs and editors</a>. ]</strong></aside><aside class="fakesidebar"/><p>A set of generic APIs now cover:</p><ul>
<li>Unstructured binary (blob) storage.</li>
<li>Variables that change at runtime.</li>
<li>Connections to MySQL databases.</li>
<li>Server startup and diagnostics, including request logging, tracing, and health-checking.</li>
</ul><p>Go Cloud serves as a foundation for an ecosystem of portable cloud libraries to be built on these APIs. Currently, the Go Cloud GitHub repository has implementations for Google Cloud Platform and Amazon Web Services. Support for more cloud providers is planned soon.</p><aside class="nativo-promo nativo-promo-1 smartphone" id=""> </aside><p>Critical to the project is Wire, a code generator that creates human-readable code that imports cloud SDKs for the providers the developers use. This lets Go Cloud support cloud providers without increasing compile times or binary sizes while avoiding effects from <code>init()</code> functions.</p><p>Wire automates the connecting of components using dependency injection. Component dependencies are represented as function parameters to encourage explicit initialization rather than global variables. Wire operates without a runtime state or reflection, thus enabling code for handwritten initialization.</p><h2>Where to download Go Cloud</h2><p>You can <a href="https://github.com/google/go-cloud" rel="nofollow">download Go Cloud</a> from GitHub. Install it and Wire as follows:</p><aside id="fsb-2546" class="fakesidebar fakesidebar-auto fakesidebar-sponsored"><strong>[ <a href="https://pluralsight.pxf.io/c/321564/424552/7490?u=https%3A%2F%2Fwww.pluralsight.com%2Fpaths%2Fjava" rel="nofollow">Learn Java from beginning concepts to advanced design patterns in this comprehensive 12-part course!</a> ]</strong></aside><pre class="prettyprint">go get github.com/google/go-cloud
go get github.com/google/go-cloud/wire/cmd/wire</pre>

	
	
		
	
	
	
	
		
			<p class="orig">This story, "Go Cloud aims to cement Golang in the cloud" was originally published by 












<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name"><a href="http://www.infoworld.com/" rel="nofollow" target="_blank">InfoWorld</a></span><meta itemprop="logo" content="https://www.javaworld.com/www.idge.jvw/images/JVW_logo_300x300.png"/></span>.</p>
		
		
		
		










<div class="end-note">
	
		
	











	
	
	
	
	
	
	
	
	
	
	
	
	
	


</div>
	
	
</div>





<script>
$("a[data-product-id]").on('click',function(e){
	var e = e || window.event;
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var prodName = $(this).attr("data-product-name");
	prodName = prodName.replace("\\'","'"); // to counter the effects of over-escaping
	
	if ( $(this).parents('.slideshow').length > 0 ) {
		var productLinkPosition = "Slideshow";
	} else if ( $(this).parents('.emo-sb').length > 0 ) {
		var productLinkPosition = "Product Sidebar";
	} else if ( $(this).parents('.at-a-glance.top').length > 0 ) {
		var productLinkPosition = "AAG Top";
	} else if ( $(this).parents('.at-a-glance').length > 0 ) {
		var productLinkPosition = "AAG Bottom";
	} else if ( $(this).parents('.quick-hits.medium').length > 0 ) {
		var productLinkPosition = "Quick Hit Medium";
	} else if ( $(this).parents('.quick-hits').length > 0 ) {
		var productLinkPosition = "Quick Hit Full";
	} else if ( $(this).parents('.product-chart').length > 0 ) {
		var productLinkPosition = "Product Chart";
	} else if ( $(this).parents('.emo-list').length > 0 ) {
		var productLinkPosition = "Product List";
	} else {
		var productLinkPosition = "Body Text";
	}
	
	dataLayer.push({
		'event': 'affiliateLink', 
	  	'eventCategory': 'Affiliate Link', // Hardcoded, not dynamic
	  	'eventAction': 'Click', // Hardcoded, not dynamic
	  	'eventLabel': ''+e.target+'', // The URL the affiliate link leads to
	  	'productVendor': $(this).attr("data-bkvndr"), // The vendor of the product
	  	'productManufacturer': $(this).attr("data-bkmfr"), // The manufacturer of the product
	  	'productName': prodName, // The name of the product
	  	'productId': $(this).attr("data-product-id"), // The ID of the product
	  	'productLinkPosition': productLinkPosition // location of product link (Product Sidebar, Product Chart, etc.)
	});
});
</script>


	<script>
$("#drr-container a").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickParentsUntilDrr = $clickEl.parentsUntil("#drr-container");
	var clickText = $clickEl.text().trim();
	var linkLocation;
	var linkType;
	var regex = new RegExp("cio.com|csoonline.com|computerworld.com|itnews.com|itworld.com|infoworld.com|networkworld.com|javaworld.com|techconnect.com|techhive.com|macworld.com|pcworld.com|greenbot.com|gamestar.com", "i");
	
	if (clickParentsUntilDrr.hasClass("fakesidebar")) {
		linkLocation = "FSB";
	}
	else if (clickParentsUntilDrr.hasClass("end-note")) {
     	 linkLocation = "End Note";
   }
	else {
		linkLocation = "Body";
	}
	
	if (regex.test(clickUrl)) {
	      linkType = "Internal";
	    }
	else {
		linkType = "External";
	}
		
	
	dataLayer.push({
		'event': 'editBodyLink', 
	  	'eventCategory': 'Editorial Body Links',
	  	'eventAction': linkType,
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>







    <div class="apart-alt tags">
    <span class="related">Related: </span>
    <ul>
		
			<li><a href="/category/development-tools">Development Tools</a></li>
		
			<li><a href="/category/application-development">Java App Dev</a></li>
		
			<li><a href="/category/scripting-jvm-languages">Scripting and JVM Languages</a></li>
		 
		
			
			
				 
					 
			    				
				
			
				
		
    </ul>
   
	</div>









		
   		











	
	
	
		<div class="byline vcard author end-byline">	
			<div class="author-info">
					<p class="bio">Paul Krill is an editor at large at InfoWorld, whose coverage focuses on application development.</p>
			</div><!-- end .author-info -->
			
			<div class="brand-social">
				<div class="follow-text">Follow</div>
				<ul class="social-links">
					<li>
						<a href="/author/Paul-Krill/">
							<i class="ss-icon ss-user"></i>
						</a>
					</li>
					
						<li>
							<a href="mailto:paul_krill@infoworld.com">
								<i class="ss-icon ss-mail"></i>
							</a>
						</li>
					
					
						<li>
							<a href="https://twitter.com/pjkrill" class="twitter-follow" target="_blank">
								<i class="ss-icon ss-social ss-twitter"></i>
							</a>
						</li>
					
					
					
					
						<li>
							<a href="https://plus.google.com/108289165450818957590" class="googleplus-follow" target="_blank">
								<i class="ss-icon ss-social ss-googleplus"></i>
							</a>
						</li>
					
					
						<li>
							<a href="/author/Paul-Krill/index.rss" class="rss">
								<i class="ss-icon ss-social ss-rss"></i>
							</a>
						</li>
					
				</ul>
			</div>
		</div>
	



   		
   		
		







	
	


















 




	
	
	
	
	
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	





<script src="/www/js/video/embedder.js"></script>

	
	
	
	




					










				
			
		
		</section><!-- /.bodee -->

		














	
		
			
				
				
					
						
							
						











<div class="six-column" id="recommended">
	<div class="head">Recommended</div>
	<ul>
		
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
		




























































	
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
						
							
						
						
						
						
						
					



















<li class=" first">
	
		
			
			
			
			
			
		

























	




	
		



 

	
	
	
		
				
				<figure class="well-img">
					
						
						
							<a  href="/article/3268983/learn-java/java-challengers-1-method-overloading-in-the-jvm.html"><img  class="lazy small.3x2Image  imgId100755843 " data-original="https://images.idgesg.net/images/article/2018/04/jw-calculate-100755843-small.3x2.jpg" alt="jw calculate" /></a>
						
					
					
					
				</figure>
				
		
		
	

	
	
		
		
		
			
		
		
	
	
	<div class="post-cont">
		
			
								
			
			
		
		<div class="title">













	
		
    	
    		<a  href="/article/3268983/learn-java/java-challengers-1-method-overloading-in-the-jvm.html">Java Challengers: Method overloading in the JVM</a>
    	
	
</div>
    </div>
    
	    
    
</li>

				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
						
							
						
						
						
						
						
					



















<li class=" ">
	
		
			
			
			
			
			
		

























	




	
		



 

	
	
	
		
				
				<figure class="well-img">
					
						
						
							<a  href="/article/3224505/application-development/machine-learning-for-java-developers.html"><img  class="lazy small.3x2Image  imgId100735845 " data-original="https://images.idgesg.net/images/article/2017/09/jw-machine-learning09142017-100735845-small.3x2.jpg" alt="jw machine learning09142017" /></a>
						
					
					
					
				</figure>
				
		
		
	

	
	
		
		
		
			
		
		
	
	
	<div class="post-cont">
		
			
								
			
			
		
		<div class="title">













	
		
    	
    		<a  href="/article/3224505/application-development/machine-learning-for-java-developers.html">Machine learning for Java developers</a>
    	
	
</div>
    </div>
    
	    
    
</li>

				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
						
							
						
						
						
						
						
					



















<li class=" ">
	
		
			
			
			
			
			
		

























	




	
		



 

	
	
	
		
				
				<figure class="well-img">
					
						
						
							<a  href="/article/3215112/learn-java/java-101-datastructures-and-algorithms-in-java-part-1.html"><img  class="lazy small.3x2Image  imgId100731424 " data-original="https://images.idgesg.net/images/article/2017/08/jw101-datastructuresp1-100731424-small.3x2.jpg" alt="Datastructures and algorithms in Java" /></a>
						
					
					
					
				</figure>
				
		
		
	

	
	
		
		
		
			
		
		
	
	
	<div class="post-cont">
		
			
								
			
			
		
		<div class="title">













	
		
    	
    		<a  href="/article/3215112/learn-java/java-101-datastructures-and-algorithms-in-java-part-1.html">Java 101: Datastructures and algorithms in Java </a>
    	
	
</div>
    </div>
    
	    
    
</li>

				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
						
							
						
						
						
						
						
					



















<li class=" ">
	
		
			
			
			
			
			
		

























	




	
		



 

	
	
	
		
				
				<figure class="well-img">
					
						
						
							<a  href="/article/3272244/core-java/what-is-the-jvm-introducing-the-java-virtual-machine.html"><img  class="lazy small.3x2Image  imgId100758585 " data-original="https://images.idgesg.net/images/article/2018/05/jvm_binary_code_3x2_1200x800-100758585-small.3x2.jpg" alt="JVM - Java Virtual Machine" /></a>
						
					
					
					
				</figure>
				
		
		
	

	
	
		
		
		
			
		
		
	
	
	<div class="post-cont">
		
			
								
			
			
		
		<div class="title">













	
		
    	
    		<a  href="/article/3272244/core-java/what-is-the-jvm-introducing-the-java-virtual-machine.html">What is the JVM? Introducing the Java virtual machine</a>
    	
	
</div>
    </div>
    
	    
    
</li>

				
				
			
		
	




		
		
		
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
		




























































	
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					



















<li class="sponsored first">
	
		
			
			
			
			
			
		

























	




	
		



 

	
	
	
		
		
			
			<figure class="well-img">
				  <div class="sized-img-teaser">
					
					  
					  
					    
					    <a  href="/resources/174959/business-management/-choosing-the-right-in-memory-computing-solution">
					    	<img  class="lazy smallImage  imgId100763471 " data-original="https://images.idgesg.net/images/idge/imported/imageapi/2018/07/09/20/logo-2017-100763471-small.png" />
					    </a>
					  
					
				  </div>
				</figure>
			
		
	

	
	
		
			<div class="item-eyebrow">
			
	   			White Paper
	   			
	   		
	   		</div>
		
		
		
		
	
	
	<div class="post-cont">
		
			
			
		
		<div class="title">













	
		
			
				
				
				
				
			
			
				
				
					<a  href="/resources/174959/business-management/-choosing-the-right-in-memory-computing-solution"> Choosing the Right In-Memory Computing Solution</a>
				
			
		
    	
	
</div>
    </div>
    
	    
    
</li>

				
				
			
		
	




		
	</ul>
</div><!-- /.six-column -->
					

				
			
			
		
		
		
		

		
			
			
		
			
				
					
						
						
					





















	
 	
		
		<div class="lazyload_ad">
		<code type="text/javascript">
		<!--
		document.write('<div id="ciu" class=" ad-container">');
		consent.ads.queue.push(function(){
		IDG.GPT.addDisplayedAd("ciu", "true");
		IDG.GPT.addLazyloadedAd("ciu", "true");
		});
		document.write('</div>');
		consent.ads.queue.push(function(){
		$('#ciu').responsiveAd({screenSize:'971 1115', scriptTags: []});
		if (Object.keys(IDG.GPT.companions).length > 0 || IDG.GPT.disableInitialLoad) {
			IDG.GPT.refreshAd('ciu');
		}
		});
		//-->
		</code>
		</div>
 	
 
  
							
	
	


	
		
	<link rel="stylesheet" href="/www.idge/css/sponsored-links.css?v=20180802113401" />
	<link rel="stylesheet" href="/www.idge.jvw/css/sponsored-links.css?v=20180802113401" />


<section id="resources-sponsored-links">
	
	
 	<section class="sponsored-links">
 	  <div class="head">Sponsored Links</div>
	 	
			
			
			
			
			
			
			
			
			
			
			
			
		






























































 	</section>
</section>
	
	


		</article>

	</section><!-- /role=main -->

</div><!-- /#page-wrapper -->
		
		












	<link rel="stylesheet" href="/www.idge/css/foot.css?v=20180802113401" />
	<link rel="stylesheet" href="/www.idge.jvw/css/foot.css?v=20180802113401" />


<footer>
    <section class="brand" itemscope itemtype="http://schema.org/Organization">
   	
   		<link itemprop="url" href="http://www.javaworld.com"> 
        <a href="/"><span class="logo">JavaWorld</span></a>
		<span class="tagline"> JavaWorld is the original independent resource for Java developers, architects, and managers.</span>
        
        <span class="follow">
			<label>Follow us</label>
            	<ul>
            		














	<li><a href="https://twitter.com/javaworldcom" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>



	<li><a href="http://www.linkedin.com/company/javaworld-com" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>



	<li><a href="https://www.facebook.com/pages/JavaWorld/107993545895326" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>				



	<li><a href="https://plus.google.com/117974570132126965756/posts" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>                	







	<li><a href="/index.rss" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>



            	</ul>
        </span>
        
    </section>
    	
    <section class="topics">
    	
			
		        
		        <nav id="ft1">
		            <ul>
						
							
							
		    			
















	
		
			
				<li><a href="/category/core-java/">Core Java</a>
					
				</li>
			
				<li class="selected"><a href="/category/enterprise-java/" class="active">Enterprise Java</a>
					
				</li>
			
				<li><a href="/category/learn-java/">Learn Java</a>
					
				</li>
			
				<li><a href="/category/mobile-java/">Mobile Java</a>
					
				</li>
			
		
	
	
	

		            </ul>
		        </nav>
		        
	        
        
        
        <nav id="ft2">
            <ul>
           		
           		










<li><a href="/howto">How-Tos</a></li>
<li><a href="/feature">Features</a></li>
<li><a href="/news">News</a></li>
<li><a href="/blogs">Blogs</a></li>
<li><a href="/resources">Resources</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
           		
            </ul>
        </nav>
        
        
			
		
    </section>
    
    
    <section class="about">
		<div class="wrapper"> 
        	<nav class="tertiary" id="ft3">
            	<ul>
            		
















<li><a href="/about/about.html"  >About Us</a>

<li><a href="/about/contactus.html"  >Contact</a>

<li><a href="/about/privacy.html"  >Privacy Policy</a>

<li><a href="/about/cookie-policy.html"  >Cookie Policy</a>

<li><a href="/about/member-preferences.html"  >Member Preferences</a>

<li><a href="https://www.idgenterprise.com/reach/javaworld/" target="_blank" rel="nofollow" >Advertising</a>

<li><a href="https://www.idg.com/work-here/" target="_blank" rel="nofollow" >IDG Careers</a>

<li><a href="/about/adchoices.html"  >Ad Choices</a>

<li><a href="/about/affiliates.html"  >E-commerce Links</a>




            	</ul>
        	</nav>
		</div>
	</section>
	
    <section class="copyright">
        <div class="wrapper">
			
        	
        
        	
        	<p><a href="/about/copyright.html">Copyright</a> &copy; 2018 IDG Communications, Inc.</p>
			<div class="network">
				<div id="network-selector">
                <div class="label">Explore the IDG Network <i class="ss-icon tick">descend</i></div>
                <ul>
                	
                		
                		
                	














	
		<li><a href="https://www.cio.com" target="_blank" rel="nofollow">CIO</a></li>
	
		<li><a href="https://www.cio-asia.com" target="_blank" rel="nofollow">CIO Asia</a></li>
	
		<li><a href="https://www.computerworld.com" target="_blank" rel="nofollow">Computerworld</a></li>
	
		<li><a href="https://www.csoonline.com" target="_blank" rel="nofollow">CSO</a></li>
	
		<li><a href="https://www.gamestar.com" target="_blank" rel="nofollow">GameStar</a></li>
	
		<li><a href="https://www.greenbot.com" target="_blank" rel="nofollow">Greenbot</a></li>
	
		<li><a href="https://www.idc.com" target="_blank" rel="nofollow">IDC</a></li>
	
		<li><a href="https://www.idg.com" target="_blank" rel="nofollow">IDG</a></li>
	
		<li><a href="https://www.idgconnect.com" target="_blank" rel="nofollow">IDG Connect</a></li>
	
		<li><a href="https://www.idg.tv" target="_blank" rel="nofollow">IDG.TV</a></li>
	
		<li><a href="https://www.infoworld.com" target="_blank" rel="nofollow">InfoWorld</a></li>
	
		<li><a href="https://www.itnews.com" target="_blank" rel="nofollow">IT News</a></li>
	
		<li><a href="https://www.itwhitepapers.com" target="_blank" rel="nofollow">ITwhitepapers</a></li>
	
		<li><a href="https://www.itworld.com" target="_blank" rel="nofollow">ITworld</a></li>
	
		<li><a href="https://www.javaworld.com" target="_blank" rel="nofollow">JavaWorld</a></li>
	
		<li><a href="https://www.macworld.com" target="_blank" rel="nofollow">Macworld</a></li>
	
		<li><a href="https://www.networkworld.com" target="_blank" rel="nofollow">Network World</a></li>
	
		<li><a href="https://www.pcworld.com" target="_blank" rel="nofollow">PCWorld</a></li>
	
		<li><a href="https://www.techconnect.com" target="_blank" rel="nofollow">TechConnect</a></li>
	
		<li><a href="https://www.techhive.com" target="_blank" rel="nofollow">TechHive</a></li>
	
		<li><a href="https://www.thefullnerd.com/" target="_blank" rel="nofollow">The Full Nerd</a></li>
	

                </ul>
				</div><!-- /#network-selector -->
			</div><!-- /.network -->
		</div><!-- /.wrapper -->
    </section>
</footer>

<script src="/www/js/analytics/mouse_down.js"></script> 
<script src="/www/js/jquery/jquery-ui.js"></script>
<script src="/www/js/jquery/jquery.dfp.min.js"></script>
<script src="/www.idge/js/mule/shortstack_nav.js"></script>




	
		
			
		





















	

		
			
			
			
			
			
				<div id="mobilewelcomead" class=" ad-container">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				
					IDG.GPT.addDisplayedAd("mobilewelcomead", "true");
					$('#mobilewelcomead').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: mobilewelcomead - [971 1115]");
				
				});
				</script>
			
		
	
 	
 
 
	


<script src="/www/js/analytics/tracking.js"></script>
<script src="/www/js/autocomplete.js"></script>


	<script src="/www.idge/js/social_sidecar.js"></script>
	<script src="/www.idge/js/jquery/plugins/jquery.colorbox-min.js"></script>
	<script src="/www.idge/js/article.js?v=20180802113401"></script>
	
	<script src="/www/js/prettify.js"></script>
	<script src="/www.idge/js/jquery/responsive-tables.js"></script>
	<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
	<script>
	$(document).ready(function() {
		$("table.tablesorter").tablesorter({
			widgets: ['zebra']
		});
		
		$("table.tablesorter tbody tr").hover(function() {
			$(this).toggleClass("selected");
		});
		
		$("table.tablesorter thead tr th").each(function(){			
			if ($(this).find('.ss-icon').length < 1) {
				$(this).append('<i class="ss-icon"></i>');
			}
		});
		
	});
	</script>


<script src="/www/js/jquery/jquery.lazyload.min.js"></script>
<script src="/www.idge/js/global.js?v=20180802113401"></script>
<script src="/www/js/webfonts/ss-social.js"></script>
<script src="/www/js/webfonts/ss-standard.js"></script>
<script src="/www/js/analytics/brandAnalytics.js"></script>


























<!-- Begin BlueKai Tag -->
<iframe name="__bkframe" height="0" width="0" frameborder="0" src="javascript:void(0)"></iframe>
<script type="text/javascript" src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
<!-- CryptoJS -->
<script src="/www/js/utils/md5.js"></script>
<script type="text/javascript" src="/www/js/analytics/idg_bk_coreapi.js"></script>
	
<script type="text/javascript">
bk_allow_multiple_calls=true;
var blueKaiId=14349;
var blueKaiPort=10;
var brandCode = "jvw";
var regUrl="https://regdev.idge.int/api/"
var daysToRefresh=30;
var bk_debug_log=false;



	 regUrl="https://reg.idgenterprise.com/api/";



	daysToRefresh=30;


	




	

if ( typeof(s) != 'undefined' ) {
	bk_addPageCtx("pageType", (typeof(s.pageType)!='undefined')?s.pageType:'');
}


//CMS-Specific
bk_addPageCtx("cmscatids", "[3465,3646,3249]");



	bk_addPageCtx("goldenIds", "[287,241,281]");



	




bk_addPageCtx("cmpy", "[]");


bk_addPageCtx('tid', '2');

	
	







	bk_addPageCtx("purchaseintent","awareness");



// Add the list name and email address hash params to bluekai tracking
// If the user came from a newsletter clickthru, also set the isnl pagectx
params = getUrlParams('phint');
if(Object.keys(params).length > 0)
	{
	bk_addPageCtx("idg_eid", params['idg_eid']);
	bk_addPageCtx("newt", params['newt']);
	bk_addPageCtx("isnl", "1");	
	}

	try{
		IDG.bkCoreApi.start();
	}
	catch(e){
		//alert("Triggering catch")
		bk_doJSTag(blueKaiId ,blueKaiPort);
		if (window.console && window.console.log){
			window.console.log("Error Occured While Processing Profile Siubmission")
		}
	}
	
	










$('article, #slideshowCarousel').on('click', '.product-list-price, .btn-amazon, .productLink', function(e) {
	var $linkEl = $(e.target);
	var po = $linkEl.data('po');
	if ($.inArray(po, ['amazon', 'vendor', 'other']) >= 0) {
		if (po == 'amazon') {
			var prCat = $linkEl.data('bkc');
			if (typeof prCat != 'undefined') {
				bk_addPageCtx('event', 'AmazonClick'+prCat);
			}
			
			bk_addPageCtx('event', 'AmazonClickDevelopmentTools');
			
			bk_addPageCtx('event', 'AmazonClickJavaAppDev');
			
			bk_addPageCtx('event', 'AmazonClickScriptingandJVMLanguages');
			
		}
		var prMfr = $linkEl.data('bkmfr');
		if (typeof prMfr != 'undefined') {
			bk_addPageCtx('event', 'eCommerceMFR'+prMfr);
		}
		var prVndr = $linkEl.data('bkvndr');
		if (typeof prVndr != 'undefined') {
			bk_addPageCtx('event', 'eCommerceClickVendor'+prVndr);
		}
		bk_doJSTag(34202, 1);
	}
});
</script>



<!-- End BlueKai Tag -->





		
		
			
				
			





















	

		
			
			
			
			
			
				<div id="catfish" class=" ad-container">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				
					IDG.GPT.addDisplayedAd("catfish", "true");
					$('#catfish').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: catfish - [971 1115]");
				
				});
				</script>
			
		
	
 	
 
 
			
				
			





















	

		
			
			
				<!--  Begin gpt-skin/inread -->
				<div id="gpt-skin" class=" ad-container">					
				</div>
				<script type="text/javascript">
				consent.ads.queue.push(function(){
					IDG.GPT.addDisplayedAd("gpt-skin", "true");
					IDG.GPT.displayGoogleTagSlot('gpt-skin');
				});
				</script>
				<!--  End gpt-skin/inread -->	
			
			
			
			
		
	
 	
 
 
		
	



<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>


<script type="text/javascript">
// -- Load Lazy Advertisement placement as deferred
$("div.lazyload_ad").lazyLoadAd({
        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
        onLoad       : false,       // Callback function on call ad loading
        onComplete   : false,       // Callback function when load is loaded
        timeout      : 1500,        // Timeout ad load
        debug        : false,       // For debug use : draw colors border depends on load status
        xray         : false        // For debug use : display a complete page view with ad placements
}) ;
</script>
















	
		
	
	
		
	
	

<!-- Begin comScore Tag -->
<script>
var _comscore = _comscore || [];
_comscore.push(
{ c1: "2", c2: "6035308", c3: "", c5: "Development Tools", c6: "Article: News", c15: "3294703" });
(function()
{
	var s = document.createElement("script"), el = document.getElementsByTagName("script")[0];
	s.async = true; s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
	el.parentNode.insertBefore(s, el);
})();
</script>
<noscript>
<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035308&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->


	<!-- LiveRamp Sources -->
	<script type="text/javascript"src="//storage.googleapis.com/cdn.pippio.com/sdk/pippio.min.js" async></script>
	<script src="/www/js/utils/liveRamp.js"></script>
	<!-- End of LiveRamp -->














<script type="text/javascript">
$thm.logPlEvent({"b":"jvw","e":"view","t":"article","id":"3294703"});
</script>



		<div id="loginModal"></div>
		<div id="logoffModal"></div>

		
		
		
		<script type="text/javascript">a=top;f=self;if(a!=f){a.location=f.location;}</script>			

					
	</body>
</html>