












	
	
		
	
		
	
	
	
	


<!DOCTYPE html>
<!--[if lt IE 7]>  <html lang="en" class="lt-ie9 lt-ie8 lt-ie7" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]> <html lang="en" class="lt-ie10 lt-ie9 lt-ie8" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]> <html lang="en" class="lt-ie10 lt-ie9" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="lt-ie10" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]-->
	
	











<head>

	
	
	<!-- metas -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />		
	<title>ECMAScript roadmap: New JavaScript features for 2019 | JavaWorld</title>
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	
	
	<script>
	function getQueryVariable(variable) {
		var query = window.location.search.substring(1);
		var vars = query.split("&");
		for (var i=0;i<vars.length;i++) {
			var pair = vars[i].split("=");
			if(pair[0] == variable){return pair[1];}
		}
		return(false);
	}
	</script>
	
	<!-- ad-related js -->
	<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
	
	<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
	
	












<script>
!function(t,o,e){e=t.createElement(o),t=t.getElementsByTagName(o)[0],e.async=1,e.src="https://spiffymachine.com/v2/0/fitZYlVYjgmdd8GwapvOOGGtavCpllDPjbCa0vrD0xplLjdMGk-WUe9rrDX701LK5lbXw",t.parentNode.insertBefore(e,t)}(document,"script"),function(t,o){t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)}}(document,window,"script","admiral");!function(t,e,a,n){function o(t){try{return t=localStorage.getItem("v4ac1eiZr0"),t&&t.split(",")[4]>0}catch(e){}return!1}function r(){var n=o();if(n){var r=t[e].pubads();typeof r.setTargeting===a&&r.setTargeting("admiral-engaged","true")}}n=t[e]=t[e]||{},n.cmd=n.cmd||[],typeof n.pubads===a?r():typeof n.cmd.unshift===a?n.cmd.unshift(r):n.cmd.push(r)}(window,"googletag","function");;;;!function(t,e,a,n){function o(){if(!window.frames[n]){var e=t.body;if(e){var a=t.createElement("iframe");a.style="display:none",a.name=n,e.appendChild(a)}else setTimeout(o,5)}}function r(){for(var t=[],a=0;a<arguments.length;a++)t.push(arguments[a]);i.q=i.q||[],"ping"===t[0]?t[2]({gdprAppliesGlobally:e.__cmpGdprAppliesGlobally||!1,cmpLoaded:!1},!0):t.length&&i.q.push(t)}function c(t){try{return JSON.parse(t)}catch(e){}}function s(t){if(t){var e,a="__cmpCall",n="string"==typeof t.data&&t.data.indexOf(a)>=0;e=n?(c(t.data)||{})[a]:(t.data||{})[a],e&&i(e.command,e.parameter,function(a,o){var r={__cmpReturn:{returnValue:a,success:o,callId:e.callId}};t.source.postMessage(n?JSON.stringify(r):r,"*")})}}var i=e[a];o(),"function"!=typeof i&&(i=e[a]=r,e.addEventListener?e.addEventListener("message",s,!1):e.attachEvent&&e.attachEvent("onmessage",s))}(document,window,"__cmp","__cmpLocator");;
</script>

<script>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</script>



	
	
	
	<script src="/www/js/init_device.js"></script>
	
	
	
		














<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20190117112204"></script>

<script type="text/javascript">
	if (adLayer==null || adLayer=='undefined') {
		var adLayer=[];
	}
	
		
			adLayer["itemType"]="article";
		
		
	
</script>
	
<script type="text/javascript">
	// Set up ad related variables
	try {
		IDG.GPT.unitName = "/8456/IDG.US_E_JavaWorld.com";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}

	try {
		IDG.GPT.unitName = IDG.GPT.unitName + "/" + "application-development_section";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	// global variables
	var global_ShowSuper = true;
	var global_ShowHero = false;
	
	//XFP global targeting, more targeting thm_pre
	var url = window.location.href;
	if(url.indexOf("?")>1){
		url=url.split('?')[0];
	}
	

	try {
		IDG.GPT.addTarget("URL", encodeURIComponent(url));
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	try {IDG.GPT.addTarget("zone", 'article/application-development');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("channel", 'enterprise-java');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("articleId", '3335483');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("type", 'news');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("typeId", '2');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("templateType", 'article-default');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	
	try {IDG.GPT.addTarget("categoryIds", [3646,3471,3249,3761]);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("categorySlugs", ['application-development','web-development','scripting-jvm-languages','javascript']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {IDG.GPT.addTarget("goldenIds", [241,247,281,275]);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {
		if (null != IDG.GPT.getQsVal("env")) {		
			IDG.GPT.addTarget("env", IDG.GPT.getQsVal("env").replace(/\W/g, "") );
		}
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	
	
		try {
			IDG.GPT.addTarget("author", 'Paul Krill');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
		

	try {
		IDG.GPT.addTarget("page_type", '');
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	

	
	
	
	
		try {
			IDG.GPT.addTarget("insiderContent", 'true');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
	
	
</script>



<script type="text/javascript">
	
	
	
	
		
		
		
		
		
		
		
		
	
</script>
  
<script src="/www.idge/js/thm_pre.js?v=20190117112204"></script>















	
		
	
	
	



	
		<script type="text/javascript">
			//console.log("PROXIMIC RESPONSE: PAGE-LEVEL");
			(function () {
			    try {
                    var proximic_data = {"data":["300003","112200","121100","131100","131120","240000","240002","240003","240004","240001","240005","240006","240007","240008","240009","240011","240012","240013","240014","240017","240015","240016","e2co9k","20f4sh","folvaf","r03wnl","z7xuj9","pytywb","bkwp85","w601py","2ew8ed","yhfsd1","agtqg7","7grvv1","agt9m3","vptcfh","240saz","itgwkk","86m0tt","skl8g2","li8svo","500247"]};
                    IDG.GPT.addTarget("proximic", proximic_data.data);
                }
                catch (e){
			        console.log("Error: " + e);
                }
			})();
		</script>
	
	



	
	
		<script>
		// IDGMPM-16419 - moved out of adsel queue for IDGMPM-16933
		googletag.cmd.push(function() {
		  if (googletag.pubads().getTargeting('permutive').length == 0) {
		    var kvs = localStorage.getItem('_pdfps');
		    googletag.pubads().setTargeting('permutive', kvs ? JSON.parse(kvs) : []);
		    console.log('ad targeting permutive kvs: ', kvs);
		  }
		});
		</script>
	

<script type="text/javascript" src="/www/js/ads/gpt_starter.js?1234"></script>
	<script>
		loadGPT();
	</script>
<script type="text/javascript" src="/www/js/ads/gpt_launcher.js"></script>

	
	
	
	
	
		
				
		
		
		
	

	<link rel="canonical" href="https://www.infoworld.com/article/3334576/javascript/ecmascript-roadmap-new-javascript-features-for-2019.html" />
	
	
		
	

	<meta itemprop="url" content="https://www.javaworld.com/article/3335483/application-development/ecmascript-roadmap-new-javascript-features-for-2019.html" />
	<meta name="description" content="Two proposals are completed, and more are under consideration for the technology behind JavaScript" />
	
		
			<meta name="DC.date.issued" content="2019-01-22T10:13-05:00" />
			<meta name="date" content="2019-01-22" />
			
		
		
		
		
	
	
	
	
		
		
		
			
			
				
			
			
			
		
	
	
		
		
			<meta property="og:title" content="ECMAScript roadmap: New JavaScript features for 2019">
		
	
	<meta property="og:description" content="Two proposals are completed, and more are under consideration for the technology behind JavaScript">	
	
	
		
			<meta property="og:image" content="https://images.idgesg.net/images/article/2019/01/tunnel_highway_driving_car-100785125-large.3x2.jpg" />
			<meta property="og:image:width" content="700" />
			<meta property="og:image:height" content="467" />
			<meta itemprop="image" content="https://images.idgesg.net/images/article/2019/01/tunnel_highway_driving_car-100785125-large.3x2.jpg">
			<meta itemprop="thumbnailURl" content="https://images.idgesg.net/images/article/2019/01/tunnel_highway_driving_car-100785125-large.3x2.jpg" />
			<link rel="image_src" href="https://images.idgesg.net/images/article/2019/01/tunnel_highway_driving_car-100785125-large.3x2.jpg" />
			<meta name="twitter:image" content="https://images.idgesg.net/images/article/2019/01/tunnel_highway_driving_car-100785125-large.3x2.jpg" />
		
		
	
	
		
			<meta property="og:type" content="article" />
			
			
			
			
			
			
			
			
			
			<meta name="author" content="Paul Krill">
			
			
			
			
			
		
		 
		
	<meta property="og:site_name" content="JavaWorld" />
	<meta property="fb:app_id" content="196366870381968" />
	
		
			<meta property="og:url" content="https://www.javaworld.com/article/3335483/application-development/ecmascript-roadmap-new-javascript-features-for-2019.html">
		
		
	
	
	<!-- Use Twitter Summary Card with Large Image for articles and videos -->
	
		
				<meta name="twitter:card" content="summary_large_image">
		
		
	

	<meta name="twitter:site" content="@javaworldcom">
	<meta name="twitter:description" content="Two proposals are completed, and more are under consideration for the technology behind JavaScript">

	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	<meta name="rating" content="General">
	
	<meta name="robots" content="NOODP,NOYDIR" />
	
	
	
	
		<meta name="msvalidate.01" content="04917178B598F0648B9BAD693FEC29A3" />
	
		
	<!-- pagination -->
	
	
	
	
	
	
	
	
	
	
		<link id="mobile-size" rel="stylesheet" href="/www.idge/css/inline-header-mobile.css?v=20190117112204" />
		
		<script>
			if (window.matchMedia("(min-width: 768px)").matches) {
				document.getElementById('mobile-size').insertAdjacentHTML('afterend', '<link id="desktop-size" rel="stylesheet" href="/www.idge/css/inline-header.css?v=20190117112204" />');
			}
		</script>
		
			
				<link rel="stylesheet" href="/www.idge.jvw/css/inline-header.css?v=20190117112204" />
			
		
	
	
	<!-- css -->
	<link rel="stylesheet" href="/www.idge/css/normalize.css" />
	<link rel="stylesheet" href="/www.idge/css/prettify.css" />
	
		<link rel="stylesheet" href="/www.idge.ans/js/select2-3.5.0/select2.css" />
	
	
	
		
			
			
			
			
				
					
						
						
						
							<link rel="stylesheet" href="/www/css/article.css?v=20190117112204" />
						
					
					
					
			
				
		
		
		
			<link rel="stylesheet" href="/www.idge/css/insider-promo-styles.css?v=20190117112204" />
		
		<link rel="stylesheet" href="/www.idge/css/print.css" media="print" />
		
	
	
		
			
		<link rel="stylesheet" href="/www.idge.jvw/css/article.css?v=20190117112204" />
		
	
	
	<link rel="stylesheet" href="/www.idge/css/webfonts/ss-social.css" />
	<link rel="stylesheet" href="/www.idge/css/webfonts/ss-standard.css" />
	<!--[if lte IE 8]>  
		<link href="/www.idge/css/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]--> 
	
	
	
	
		<link href="//fonts.googleapis.com/css?family=PT+Sans:400,700|PT+Sans+Narrow:400,700" rel="stylesheet" type="text/css" />
	
		
	
	
	
	<!--  fav and touch icons -->
	<link rel="shortcut icon" type="image/x-icon" href="/www.idge.jvw/favicon.ico"/>
	<link rel="apple-touch-icon-precomposed" sizes="144x144" href="/www.idge.jvw/touchicon_144.gif" />
	<link rel="apple-touch-icon-precomposed" sizes="114x114" href="/www.idge.jvw/touchicon_114.gif" />
	<link rel="apple-touch-icon-precomposed" sizes="72x72" href="/www.idge.jvw/touchicon_72.gif" />
	<link rel="apple-touch-icon-precomposed" sizes="57x57" href="/www.idge.jvw/touchicon_57.gif" />
	<link rel="apple-touch-icon" href="/www.idge.jvw/images/JVW_logo_300x300.png" />
	
	
		<script src="/www.idge.ans/js/select2-3.5.0/select2.js"></script>
	
	
	
	
	
	
		<script>
		   $(document).ready(function() { 
			   $("select#country").select2({
			    	placeholder: "country",
			    	minimumResultsForSearch: Infinity,
			    	allowClear: true
			    });
			   $("select#state").select2({
			    	placeholder: "state",
			    	minimumResultsForSearch: Infinity,
			    	allowClear: true
			    });
			    $("#jobPosition").select2({
			    	placeholder: "position",
			    	minimumResultsForSearch: Infinity,
			    	allowClear: true
			    }); 
			   	$("#jobFunction").select2({
			   		placeholder: "function",
			   		minimumResultsForSearch: Infinity,
			    	allowClear: true
			   	}); 
			   	$("#companySize").select2({
			   		placeholder: "company size",
			   		minimumResultsForSearch: Infinity,
			    	allowClear: true
			   	});
			   	$("#industry").select2({
			   		placeholder: "industry",
			   		minimumResultsForSearch: Infinity,
			    	allowClear: true
			   	}); 
		   });
	   </script>
   	    
   	     











<script>

var brandCode = "jvw";
var brandName="JavaWorld";
var brandId = "9";
var regDebugLog=false;
var regApiUrl='https://api-stage.idgcommunications.net/api/v1/';
var apiKey="HLyMXLISSW7HAYGgbx2Vb1Gf1OLcGmMG5BcwZ4Vb";
var tokenPrefix='www';
var tokenSuffix='.com/insider/token?';
var brandDomain=".javaworld.com";
var insiderContentType="article";
var notEmptyArticle=false;
var notEmptyMediaResource=false;
var isInsiderPremium=false;
var isResourceInsiderPremium=false;
var assetId="697422d1-7acb-40f6-be13-0e67329bc9ec";
var placementId="2d44d74a-e883-4d18-ada8-b2f0e61a1d90";


	regApiUrl="https://lqxgcyk808.execute-api.us-east-1.amazonaws.com/prod/api/v1/";



	regDebugLog=false;



	tokenPrefix="http://www";



	tokenSuffix="/insider/token";





	notEmptyArticle=true;


	
		isInsiderPremium=true;
	



 

</script>


<script src="/www/js/utils/alc_hashes.js"></script>
<script src="/www/js/insider/insider_reg_api.js?v=20190117112204"></script>
<script src="/www/js/insider/jquery.maskedinput-1.4.min.js"></script>

<script>
$(document).ready(function(){
	if(typeof(IDG.insiderReg.readCookie('nsdr')) !== 'undefined'){
		$('#welcome-message').show();			
		IDG.insiderReg.personalize();
	}else{
		$('.signin-register').show();	
	}
});

</script>


	
	
	




	
	
	
	
















	

	
	<script src="/www/js/ads/ads.js"></script>
	
	<script>var oneRegPlacementID = "";</script>
	
	
	
	
	
		
			
				
			
			
			
			
			
		
		
		
	
	
	
	





	
		
	
		
	
	





		
		  
		
		
		
		

	
	
	
	
	  	 
	    
	    
	 
	 
	
	
	
	
	
		
	
	
	
	
		
	

	<script>
	var supMontMods = false;
	</script>
	
	
	
	
		
		
			
				
				
			











	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #2806 blox4.simple  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
				
				
			
		
















	


		
	
	
		
	
	
	
	
	
	
		
			
				
				
				
					
				
			
			
			
			
		
		
		
	
	
	
	

	
	
	
	
	
		<script>
		window.ntvConfig = window.ntvConfig || {} ;
		window.ntvConfig.keyValues = window.ntvConfig.keyValues || {};
		var segs = localStorage.getItem('_pnativo');
		if (segs) {
		  window.ntvConfig.keyValues.permutive = JSON.parse(segs).join(",");
		}
		</script>
	
	
	
	
		<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
	
	
	
	<script type="text/javascript">
		var prodNames = '';
		var prodManufacturers = '';
		var prodCategories = '';
		var prodVendors = '';
	</script>
	
	
	
	<script>
	var insiderSignedIn = document.cookie.indexOf("nsdr") > -1; //check if Insider cookie exists
	var idg_uuid = $.cookie('idg_uuid') || '';
	
	var dlJobFunction = '';
	var dlJobPosition = '';
	var dlIndustry = '';
	
	if (insiderSignedIn) {
		var insiderToken = IDG.insiderReg.readCookie("nsdr");
		var tokens = IDG.insiderReg.readCookieProperty(insiderToken);
		if (!(tokens['jobPosition']===undefined)) {
			dlJobPosition = tokens['jobPosition'];
		}
		if (!(tokens['jobFunction']===undefined)) {
			dlJobFunction = tokens['jobFunction'];
		}
		if (!(tokens['industry']===undefined)) {
			dlIndustry = tokens['industry'];
		}
	}
	
	insiderSignedIn = insiderSignedIn.toString(); //per Infotrust this needs to be a string, not a boolean
	
	var sincePublished = '0 days';
	sincePublished = sincePublished.split(" ")[0];
	
	
	dataLayer=[{
		'articleId': '3335483',
		'articleDisplayId':'1',
		'articleTitle': 'ECMAScript roadmap: New JavaScript features for 2019',
		'articleType': 'News',
		'audience':'enterprise',
		'author':'Paul Krill',
		'blogName':'',
		'brandpost': 'false',
		'categoryIdList':'3646,3471,3249,3761',
		'categoryIdPrimary': '3646',
		'contentStrategy': '',
		'contentType':'news',
		'datePublished':'2019-01-22',
		'dateUpdated':'',
		'daysSincePublished':sincePublished,
		'daysSinceUpdated':'',
		'displayType':'article',
		'environment':'production',
		'ga_enabled':'true',
		'gaTrackingId':'UA-300704-19',
		'geolocEnabled':'true',
		'goldenTaxonomyIdPrimary': '241',
		'goldenTaxonomyIdList': '241,247,281,275',
		'industry': dlIndustry,
		'insiderSignedIn':insiderSignedIn,
		'isBlog':'false',
		'isInsiderContent':'true',
		'isICN': 'false',
		'jobFunction': dlJobFunction,
		'jobPosition': dlJobPosition,
		'oneRegPlacementID':oneRegPlacementID,
		'pageNumber':'1',
		'platform':'Web',
		'podcastSponsored': 'false',
		'primaryCategory': 'software development',
		'primaryCategoryList': 'software development,web development,scripting and jvm languages,javascript',
		'property': 'javaworld',
		'propertyCountry':'US',
		'purchaseIntent':'notapplicable',
		'skimlinksId':'',
		'source':'infoworld',
		'sponsorName':'',
		'suppressMonetization': supMontMods.toString(),
		'tags': '',
		'userId':idg_uuid,
		'videoAutoplay':'false',
		'articleHasVideo':'false',
		'de_normalized_company_name':$.cookie('de_normalized_company_name'),
		'ip_normalized_company_name':$.cookie('ip_normalized_company_name'),
		'prodNames':prodNames.slice('|', -1),
		'prodManufacturers':prodManufacturers.slice('|', -1),
		'prodCategories':prodCategories.slice('|', -1),
		'prodVendors':prodVendors.slice('|', -1)	
	}];
	</script>
	
	












	
<script type="text/javascript">
	var _sf_async_config={};

	_sf_async_config.uid = 29363;

	_sf_async_config.path = "/article/3335483/application-development/ecmascript-roadmap-new-javascript-features-for-2019.html";
	_sf_async_config.title = "ECMAScript roadmap: New JavaScript features for 2019 | JavaWorld";
	_sf_async_config.domain = "javaworld.com";
	if(window.location.href.indexOf("video")&&true) {
		_sf_async_config.playerdomain= _sf_async_config.domain.replace("www.","");
	}
	
	_sf_async_config.useCanonical = true;
	
		
			
			_sf_async_config.sections = "application-development";
			_sf_async_config.authors="Paul Krill";
			
		
	
</script>



	
	
	
	
	
	
	
	










<script>
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var adBlockStatus = 'false';
	
	function AdBlockEnabled() {
		var ad = document.createElement('ins');
		ad.className = 'AdSense';
		ad.style.display = 'block';
		ad.style.position = 'absolute';
		ad.style.top = '-1px';
		ad.style.height = '1px';

		if (document.body != null) {
			document.body.appendChild(ad);
			var isAdBlockEnabled = !ad.clientHeight;
			document.body.removeChild(ad);
		}

		return isAdBlockEnabled; 
	}
	// AdBlockEnabled() was successful document.body not null
	if (AdBlockEnabled() != undefined) {
		adBlockStatus = AdBlockEnabled().toString();
	}
	// not successful - look for ads.js
	if (document.body == null) {
		if (window.canRunAds === undefined) {
			adBlockStatus = 'true';
		} else {
			adBlockStatus = 'false';
		}
	}
	
	dataLayer.push({
		'adBlockStatus': adBlockStatus
	});
</script>




	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-MMJKZ9"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-MMJKZ9');</script>
	<!-- End Google Tag Manager -->

	
	
	
	

	<script src="https://www.google.com/recaptcha/api.js" async defer></script>
	
	
	
		<script async src="//js-sec.indexww.com/ht/p/187051-164251026496775.js"></script>
	
	
	
	
		<script>
			var numberFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "number") {
			    return dataLayer[0][property];
			  }
			  return null;
			};
			
			var stringFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "string") {
			    return dataLayer[0][property];
			  }
			  return "";
			};
		</script>
	

	

	
		










<script>
// IDGMPM-16419 - updated in IDGMPM-16933
	!function(n,e,o,r,i){if(!e){e=e||{},window.permutive=e,e.q=[],e.config=i||{},e.config.projectId=o,e.config.apiKey=r,e.config.environment=e.config.environment||"production";for(var t=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],c=0;c<t.length;c++){var f=t[c];e[f]=function(n){return function(){var o=Array.prototype.slice.call(arguments,0);e.q.push({functionName:n,arguments:o})}}(f)}}}(document,window.permutive,"f5b3be27-f789-4ef1-8867-37c67da5b361","84c7e805-5ce9-41f4-b988-3529488bab1c",{});
	  permutive.addon('web', {
	    page: {
	      type: stringFromDataLayer('displayType'),
	      language: 'en',
	      tags: stringFromDataLayer('tags').split(","),
	      audience: stringFromDataLayer('audience'),
	      description: 'Two proposals are completed, and more are under consideration for the technology behind JavaScript',
	      
	      article: {
	        authors: stringFromDataLayer('author').split(","),
	        description: 'Two proposals are completed, and more are under consideration for the technology behind JavaScript',
	        id: stringFromDataLayer('articleId'),
	        isInsiderContent: (stringFromDataLayer('isInsiderContent') == "true"),
	        modifiedAt: "2019-01-22T10:13:00Z",
	        publishedAt: "2019-01-22T10:13:00Z",
	        source: stringFromDataLayer('source'),
	        title: stringFromDataLayer('articleTitle'),
	        type: stringFromDataLayer('articleType'),
	        purchaseIntent: stringFromDataLayer('purchaseIntent')
	      },
	      
	      ads: {
	        adblocker: (adBlockStatus == "true"), //detected further up the page
	        enabled: true
	      },
	      gTax: {
	        primaryIds: [241],
	        secondaryIds: [241,247,281,275]
	      },
	      tax: {
	        primaryCategories: [stringFromDataLayer('primaryCategory')],
	        secondaryCategories: stringFromDataLayer('primaryCategoryList').split(",")
	      }
	    }
	  });

	  dlJobPosition = dlJobPosition || null;
	  dlIndustry = dlIndustry || null;

	  if (dlJobPosition !== '' || dlIndustry !== '' || stringFromDataLayer('userId') !== '') {
		  window.permutive.track('User', {
			  companySize: null,
			  country: null,
			  id: (stringFromDataLayer('userId') !== "" ? stringFromDataLayer('userId') : null),
			  jobIndustry: (dlIndustry !== "" ? dlIndustry : null),
			  jobPosition: (dlJobPosition !== "" ? dlJobPosition : null),
			  loggedIn: (stringFromDataLayer('insiderSignedIn') == 'true')
			})
	  }
	
	  //product js vars defined in document-head	  
	  if (prodNames !== '' || prodManufacturers !== '' || prodCategories !== '' || prodVendors !== '') {
		  window.permutive.track('Product', {
			  names: stringFromDataLayer('prodNames').split("|"),
			  categories: stringFromDataLayer('prodCategories').split("|"),
			  manufacturers: stringFromDataLayer('prodManufacturers').split("|"),
			  vendors: stringFromDataLayer('prodVendors').split("|")
		});

	  }
		 

</script>

<script>
	$.ajax({
		url: "https://cdn.permutive.com/f5b3be27-f789-4ef1-8867-37c67da5b361-web.js",
	  	dataType: "script",
	  	cache: true, // default is false
	  	async: true // default is true
	});
</script>
	
	
	
	
	
	
	
</head>


	<body id="article3335483" class="article javaworld">
		
			
			
		
		













<!-- BEGIN PAGE HEADER -->
<header id="banner" >
	
	
	
	
	
	
    
    
    
    	
    	<script>
    	if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
			$('.main-header').insertBefore($('#banner .ad'));
    	}
		</script>
		
		
		<div class="topics-wrap">
		    <section class="topics">
		        <nav id="scrollable">
					
						
						
							
						
					











	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #670 blox4.raw_link_list  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
				
				
			
		












	
		
		
			
		
	
	
	<ul>
		
		<li class="header">Trending<span class="colon">:</span></li>
		
		
			
				<li><a href="/category/learn-java/" >Learn Java</a></li>
			
		
			
				<li><a href="/blog/java-101/" > Java 101</a></li>
			
		
			
				<li><a href="/category/java-app-dev/ " > Java App Dev</a></li>
			
		
			
				<li><a href="/category/developer-tools-ide/" >Java Toolbox</a></li>
			
		
			
				<li><a href="/blog/open-source-java-projects/" >Open Source Java </a></li>
			
		
			
				<li><a href="/category/careers/" >Programming Careers</a></li>
			
		
			
				<li><a href="/blog/java-qanda/" >Java Q&A</a></li>
			
		
	</ul>

	


		        </nav>
		        
		        <div class="fading-gradient"></div>
		        
		        
        		
		        <nav class="tools">
		        	<ul class="user">
	                     
	                     	<li class="search-icon"><a href="#search" id="search-btn"><i class="ss-icon">Search</i></a></li>
	                     
	                 </ul>
	                 <ul class="social">
						














	                 </ul>
	             </nav>
	             
	             
		    </section>
	    </div>
	    
	    
        	 <div id="sticky-anchor"></div>
        
	    <section id="sticky-head" class="main">
	        <div class="wrapper">
	            <div class="masthead">
	                
	                <button><i class="ss-icon ss-rows"></i></button>
	                
	                <a href="/"><span class="ir logo">javaworld</span></a>
	            	<!--
	            	<img class="print-only" src="/www.idge.jvw/images/javaworld-logo-print.png">
	            	-->
	            	
	            	<img class="print-only" src="//idge.staticworld.net/jvw/javaworld-logo-print.png">
	            	
	            </div>
	            <div id="reading-tools-wrapper">

	                
	                <nav class="tools">
	                    
	                    <ul class="user">
	                    	
	                    	
	                    	
	                    	
	                        
	                    </ul>
	                </nav>
	            </div>
	            
	            
	            	<div class="insider-signin">
	            	
	            		<span class="signin-register">
	            			<a href="/learn-about-insider/"><span class="insider"></span></a> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-signin')" class="js-open-modal signin" data-modal-id="insider-popup">Sign In</a> <span class="divider">|</span> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-form-short')" class="js-open-modal register" data-modal-id="insider-popup">Register</a>
	            		</span>
	            	
	            		<div id="welcome-message" class="insider-list">
		                    <div id="insider-selector">
		                        <div id="insider-welcome" class="label"></div>
		                        
		                        <div class="stories">
		                        	
		                        	<div class="personalization">Hi<span id="person-first-name"></span>! Here are the latest Insider stories.</div>
		                        	
		                        	











	
	
	
	
	
	
	
	
	
	





























































	<ul>
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3335482/application-development/18-nodejs-and-javascript-libraries-for-fast-and-simple-microservices.html">18 Node.js and JavaScript libraries for fast and simple microservices</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3333642/java-platform/what-to-do-when-free-java-8-updates-end.html">What to do when free Java 8 updates end</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3330742/java-language/13-java-frameworks-for-rock-solid-microservices.html">13 Java frameworks for rock-solid microservices</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3330736/application-development/tigergraph-review-a-graph-database-designed-for-deep-analytics.html">TigerGraph review: A graph database designed for deep analytics</a></li>
				
				
			
		
	</ul>




									
									<div class="sign-out-link">
										<a class="more-insider" href="/insider/">More Insider</a>
										<a class="sign-out" href="javascript://" onclick="IDG.insiderReg.logout()">Sign Out</a>
									</div>
								</div>
								
		                    </div>
		                </div>
		         
	            	</div>
	            	<script>
	            		$('.signin-register').hide();	
	            		$('#welcome-message').hide();
	            	</script>
	            	
	            
	            
	        </div>
	    </section>
	    <section class="tools-expand  ">
	        
	        
	        
	        
	        	
	        	
	        		
			        <form class="search" id="search-form" action="/search">
			            <label for="search-box">Search for</label>
						<input type="text" name="query" id="banner-search-term" value="" class="searchbox-input-class"/>
			            <input type="submit" id="banner-search-submit" value="Go" />
			            <input type="hidden" name="contentType" value="article,resource" />
			            <div class="search-suggest">Suggestions for you</div>
			        </form>
			    
			
	        <div class="user">
	            <form>
	                <label for="login-email">Insider email</label> <input id="login-email" type="text" />
	            </form>
	        </div>
	        
	    </section>
	    
	    
	    
		
		
    		<div id="sticky-anchor-nav"></div>
    	
    	
	    <nav id="sticky-nav" class="main">
	    	<ul class="topnav">
				
					
	        		
	        		
	        			
	        				<li><a href="/category/core-java/" class="hasChildren">Core Java<span class="ss-icon ss-navigatedown"></span></a>
	            		
	            		
	            	
	            		
	            		
		            		<ul class="subnav">
		                		<li><a href="/category/core-java/">All Core Java</a></li>
		            			
		            				<li><a href="/category/agile-development/">Agile Development</a></li>
		            			
		            				<li><a href="/category/java-concurrency/">Java Concurrency</a></li>
		            			
		            				<li><a href="/category/java-language/">Java Language</a></li>
		            			
		            				<li><a href="/category/java-platform/">Java Platform</a></li>
		            			
		            				<li><a href="/category/security/">Java Security</a></li>
		            			
		            				<li><a href="/category/careers/">Programming Careers</a></li>
		            			
		            				<li><a href="/category/testing-debugging/">Testing and Debugging</a></li>
		            			
		            		</ul>
		            	
	        		</li>
				
					
	        		
	        		
	        			
	        				<li><a href="/category/enterprise-java/" class="hasChildren">Enterprise Java<span class="ss-icon ss-navigatedown"></span></a>
	            		
	            		
	            	
	            		
	            		
		            		<ul class="subnav">
		                		<li><a href="/category/enterprise-java/">All Enterprise Java</a></li>
		            			
		            				<li><a href="/category/apis/">APIs</a></li>
		            			
		            				<li><a href="/category/big-data/">Big Data</a></li>
		            			
		            				<li><a href="/category/cloud-computing/">Cloud Computing</a></li>
		            			
		            				<li><a href="/category/analytics/">Data Analytics</a></li>
		            			
		            				<li><a href="/category/development-tools/">Development Tools</a></li>
		            			
		            				<li><a href="/category/application-development/">Java App Dev</a></li>
		            			
		            				<li><a href="/category/web-development/">Java Web Development</a></li>
		            			
		            				<li><a href="/category/open-source-tools/">Open Source</a></li>
		            			
		            				<li><a href="/category/scripting-jvm-languages/">Scripting and JVM Languages</a></li>
		            			
		            		</ul>
		            	
	        		</li>
				
					
	        		
	        		
	        			
	        				<li><a href="/category/learn-java/" class="hasChildren">Learn Java<span class="ss-icon ss-navigatedown"></span></a>
	            		
	            		
	            	
	            		
	            		
		            		<ul class="subnav">
		                		<li><a href="/category/learn-java/">All Learn Java</a></li>
		            			
		            				<li><a href="/category/design-patterns/">Design Patterns</a></li>
		            			
		            		</ul>
		            	
	        		</li>
				
					
	        		
	        		
	        			
	        				<li><a href="/category/mobile-java/" class="hasChildren">Mobile Java<span class="ss-icon ss-navigatedown"></span></a>
	            		
	            		
	            	
	            		
	            		
		            		<ul class="subnav">
		                		<li><a href="/category/mobile-java/">All Mobile Java</a></li>
		            			
		            				<li><a href="/category/android/">Java Android Developers</a></li>
		            			
		            				<li><a href="/category/ios/">Java iOS Developers</a></li>
		            			
		            		</ul>
		            	
	        		</li>
				
			</ul>
	
	    	<ul class="secondary">
           		
           		










<li><a href="/news/">News</a></li>
<li><a href="/feature/">Features</a></li>
<li><a href="/howto/">How-Tos</a></li>
<li><a href="/blogs/">Blogs</a></li>
<li><a href="/resources/">Resources/White Papers</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
           		
	    	</ul>
		</nav>
		
	
	
	
	
	
	
	
		<script>
    	if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
			$('div.insider-signin').prependTo('section.topics nav.tools');
    	}
		</script>
	
    
		<script>
		$(document).ready(function(){
			if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
				$("nav ul li a.hasChildren").attr("href", "#").addClass('notMobile');
				$('nav#sticky-nav ul.secondary').addClass('topnav');
			}
			if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
				$("nav#sticky-nav > ul").switchClass("topnav", "primary");
			}
		});
		</script>
	
	
		
    	<script>
    	if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
			$('#sticky-anchor, section.main, section.topics, section.tools-expand, #sticky-anchor-nav, nav.main').insertBefore($('#banner .ad'));
			$(document).ready(function(){
				$('#banner section.tools-expand').addClass('top-margin');
			});
    	}
		</script>
		
	
	
	
</header>



<script>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</script>



	<div id="insider-popup" class="modal-box ">
	
		<div class="insider-modal-wrapper">
	  
			<div class="modal-header-title">
				<div class="modal-banner-insider"><span class="insider"></span></div>
		    	<div class="modal-close close">×</div>
		  	</div>
		  	
		  	<div class="modal-body">
		  		
		  			
						<script>
$(document).ready(function(){
	$('a[data-link]').click(function() {
		
		  //get this link's dataLink value
		  var dataLink = $(this).attr('data-link');

		  //select the div with the same value
		  var toKeep = 'div[data-link="'+dataLink+'"]';
	
		  //select data-link divs that are not the above div
		  $('div[data-link]').not(toKeep).hide();
		  
		  if($(this).hasClass('link-transition')){
			  $(toKeep).fadeIn(800);
		  } else {
			  $(toKeep).show();
		  }
	
		  //prevent location change
		  return false;
	});
	

});
</script>

					
					
				
		  	</div>
		  	
		  	<div class="modal-footer">
		    	<div class="modal-close close-btn">Close</div>
		  	</div>
		</div>
	  	
	</div>

	<script>
		$(document).ready(function(){

			var appendthis =  ("<div class='modal-overlay modal-close'></div>");
			if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
				$('.modal-box').css({
					//top: ($(window).height() - $(".modal-box").outerHeight()) / 2,
					top: 10,
					left: 0
				});
			}
			
			
			if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
				$('.modal-box').height($(document).height());
				$('.modal-box').css('top','0');
			}
			
			var userAg = navigator.userAgent;

			$('a[data-modal-id]').click(function(e) {
				e.preventDefault();
				$('body').append(appendthis);
				$('.modal-overlay').fadeTo(500, 0.9);
				$('.modal-overlay').height($(document).height());
				var modalBox = $(this).attr('data-modal-id');
				
				if ($(".modal-box").hasClass('triggered') || (userAg.indexOf("Firefox")!=-1)) {
					$('#'+modalBox).fadeIn($(this).data()); // triggered by something other than onclick of link such as scroll to point in window
				} else {
					// IDGMPM-16177
					//if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
						$('#'+modalBox).toggle('slide', {direction: 'up'}, 800);
					//} else {
				   // 	$('#'+modalBox).toggle('slide', {direction: 'left'}, 600);
					//}
				}

				if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
					$("html, body").animate({
			            scrollTop: 0
			        }, 700);
			        
			        
			        $('a.btn.continue-on').click(function() {
			        	$('html, body').animate({
			        		scrollTop: 0
			        	}, 500);
			        });
			        
			        return false;
			        
				}
				if (navigator.userAgent.match(/(iPad)/)) {
					$("html, body").animate({
			            scrollTop: 0
			        }, 500);
				}
			});
		  
		  
			$(".modal-close, .modal-overlay").click(function() {
				$('.select2-drop').css('display','none');
				$(".modal-overlay").fadeOut(500, function() {
					$(".modal-overlay").remove();
				});
				if ($(".modal-box").hasClass('triggered') || (userAg.indexOf("Firefox")!=-1)) {
					$(".modal-box").fadeOut(500);
				} else {
					// IDGMPM-16177
					//if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
						$('.modal-box').toggle('slide', {direction: 'up'}, 800);
					//} else {
					//	$('.modal-box').toggle('slide', {direction: 'left'}, 600);
					//}
				}
			});
		
		});
	</script>






<!-- END PAGE HEADER -->



		
		











<div id="page-wrapper" class="page-wrapper">
	
	













<div id="skinAdTarget"></div>


			
		











	
	
	
	
	
	
	
	
	
	
	
	
	
	





	
	
 	







	
	<section role="main">

		<article itemscope itemtype="http://schema.org/NewsArticle"  >

		















	
	



<!-- Events Header -->

 
 
	
		
		
		
		
		
					    			
		
	
	
	
	
	

 
 
 
 
  
  
 
 












	
	
	
	
	
	
	
	
	
	
	
	
	
	


<!-- //end Events Header -->


	
	
	
	
	
	
		
	



	
		
	
	
	
		




















	
			















<header  class='cat'>

	
	
	
	
	
	
	
	
	
	
	
	<nav class="breadcrumbs horiz">
		<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
			<li><a href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
			
				
				
					<li><a href="/category/enterprise-java/" itemprop="url"><span itemprop="title">Enterprise Java</span></a></li>
				
				
					<li><a href="/category/application-development/" itemprop="url"><span itemprop="title">Java App Dev</span></a></li>
				
			
		</ul>
	</nav>
	
	
	
	
	
	
	
		
		
			<div class="category"><span class="insider"></span><a href="/news" itemprop="genre">News</a></div>
		
	
	

	<h1 itemprop="headline">ECMAScript roadmap: New JavaScript features for 2019</h1>
	
	
	
	
		<section class="deck viewability">
			<h3 itemprop="description">Two proposals are completed, and more are under consideration for the technology behind JavaScript</h3>
		</section>
	
	
	
	
			<div class="cat-social">
				
					
				


















	

				

	
	
		
	



	
	


	


<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">


	<li class="sosh">
		<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3335483%2Fapplication-development%2Fecmascript-roadmap-new-javascript-features-for-2019.html&via=javaworldcom&text=ECMAScript+roadmap%3A+New+JavaScript+features+for+2019" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg" />
		</a>
	</li>
	<li class="sosh">
		<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3335483%2Fapplication-development%2Fecmascript-roadmap-new-javascript-features-for-2019.html" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg" />
		</a>
	</li>
	<li class="sosh">
		<a href="http://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3335483%2Fapplication-development%2Fecmascript-roadmap-new-javascript-features-for-2019.html&title=ECMAScript+roadmap%3A+New+JavaScript+features+for+2019" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/linkedin.svg" />
		</a>
	</li>
	<li class="sosh hide">
		<a href="http://reddit.com/submit?url=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3335483%2Fapplication-development%2Fecmascript-roadmap-new-javascript-features-for-2019.html&title=ECMAScript+roadmap%3A+New+JavaScript+features+for+2019" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg" />
		</a>
	</li>
	<li class="sosh hide">
		<a href="#email" id="email-icon">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg" />
		</a>
	</li>
	<li class="sosh hide print">
		<a href="javascript:window.print();">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg" />
		</a>
	</li>
	<li class="more">
		<div class="more-icon" onclick="document.getElementById('share-tool').className = 'expand';"></div>
	</li>




</ul>
</div>
<script type="text/javascript">
var isValidEmailAddress = isValidEmailAddress || function(emailAddress) {
    var pattern = new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);
    return pattern.test(emailAddress);
};
function encodeQueryData(params) {
	var ret = [];
	for (var paramKey in params) {
		ret.push(encodeURIComponent(paramKey) + "=" + encodeURIComponent(params[paramKey]));
	}
	return ret.join("&");
}	
function bindEmailModal() {
	$('#emailModal').on("click",".close-btn",function(event) {
		event.preventDefault();
        $('#emailModal').hide();
        $("#emailModal .eml-friend").show();
        $(".eml-friend-success").hide();
        $(".eml-friend-error").hide();
		$('#emailModal').fadeOut(200);
		$('#email-to').val('');
		$('#email-from').val('');
		$('#name').val('');
		$('#personalization').val('');
		$('#eml-from-address-message').html("");
		$('#eml-to-address-message').html("");
		$('#eml-friend-captcha-message').html("");
	});

	$('#emailModal').on("submit","form",function(event) {
		event.preventDefault();
		var $form = $(this);
		var action = $form.attr('action');
		var formData = $form.serialize();
		var emailFrom = $('#email-from').val();
		var emailTo = $('#email-to').val();
		var uresponse=$('#g-recaptcha-response').val();
		$('#eml-from-address-message').html("");
		$('#eml-to-address-message').html("");
		$('#eml-friend-captcha-message').html("");
		if (isValidEmailAddress(emailFrom) && isValidEmailAddress(emailTo) && uresponse !="") {
			// eloqua
			
			// email
			$.ajax(action, {
				type: 'POST',
				data: formData,
				success: function(data, textStatus, xhr) {
					$("#emailModal .eml-friend").hide();
					$(".eml-friend-success").fadeIn(800);	
				},
				error: function(xhr, textStatus, errorThrown) {
					$("#emailModal .eml-friend").hide();
					$(".eml-friend-error").fadeIn(800);						
				}
			});
		}
		else {	
			if(uresponse==""){
				$('#eml-friend-captcha-message').html("Please verify you're not a robot!");	
			}
			if(!isValidEmailAddress(emailTo)){
			  $('#eml-to-address-message').html("Please enter a valid email address.");		
			}
			if(!isValidEmailAddress(emailFrom)){
			  $('#eml-from-address-message').html("Please enter a valid email address.");		
			}
		}
	});
} //bindEmailModal() end

$(document).ready(function() {
	$(document).on("click","#email-icon",function(event) {
		event.preventDefault();
		bindEmailModal();
		$('#emailModal').fadeIn(800);
	});
});
</script>
<div class="modal eml-friend-wrapper" id="emailModal" style="display:none;">	
	<form class="eml-friend" action="/eloquaemail/article?eloqua=false&id=3335483">
		<input type="hidden" name="title" value="ECMAScript roadmap: New JavaScript features for 2019" />
		<input type="hidden" name="url" value="https://www.javaworld.com/article/3335483/application-development/ecmascript-roadmap-new-javascript-features-for-2019.html" />
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Email a friend</h3>

		<div class="input-row">
			<div id="eml-to-address-message" class="error-msg"></div>
			<h4 class="input-label">To</h4>
			<input id="email-to" value="" placeholder="Email address (required)" type="email" name="recipients" tabindex="1">
			<p class="addl-text">Use commas to separate multiple email addresses</p>
		</div>
		<hr />
		<div class="input-row">
			<div id="eml-from-address-message" class="error-msg"></div>
			<h4 class="input-label">From</h4>
			<input id="name" value="" placeholder="Name (optional)" type="text" name="name" tabindex="2">
		</div>
		<div class="input-row">
			<input id="email-from" value="" placeholder="Email address (required)" type="email" name="sender" tabindex="3">
		</div>
		<div class="input-row">
			<textarea name="message" placeholder="Check out this article I found on JavaWorld." id="personalization" tabindex="4"></textarea>
		</div>
		<hr />
		<div class="input-row">
			<div id="eml-friend-captcha-message" class="error-msg"></div>
		
		
 			











<script src="https://www.google.com/recaptcha/api.js" async defer></script>

<div class="g-recaptcha" data-sitekey="6LczmkcUAAAAANEO7J277KwH6Kzp6BEQjPTWP4S4"></div>
 		</div>
		<hr />
		<div class="submit">
			<input type="submit" value="Send" class="input-submit" tabindex="5">
			<a href="/about/privacy.html" class="submit-privacy" target="_blank">Privacy Policy</a>
		</div>
	</form>

	<div class="eml-ty eml-friend-success" style="display:none;">
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Thank you</h3>
		<p class="msg-sent">Your message has been sent.</p>
	</div>
	<div class="eml-friend-error" style="display:none;">
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Sorry</h3>
		<p class="msg-sent">There was an error emailing this page.</p>
	</div>
</div>

			</div>
	
	
	

	
		
			
				
				<div class="cat byline vcard author with-image">		
					<div class="byline-wrapper">
						<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
							
						
							
							
							
							
						
















<a href="/author/Paul-Krill/" rel="author" title="Paul Krill"><img  class="bylineImage  imgId100356327 " src="https://images.techhive.com/images/article/2014/07/paulkrill_crop-100356327-byline.jpg" width="34" width="34" alt="Paul Krill" itemprop="image" /></a>

						
							
								
							
















<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Paul-Krill/"><span itemprop="name">Paul Krill</span></a></span>
						</p>
						<p class="dateline">
						
							Editor at Large, 
								
									
								












<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name"><a href="http://www.infoworld.com/" rel="nofollow" target="_blank">InfoWorld</a></span><meta itemprop="logo" content="https://www.javaworld.com/www.idge.jvw/images/JVW_logo_300x300.png"/></span> <span class="divider break">|</span>
							
										
							<span class="pub-date" class='break-date' itemprop="datePublished" content="2019-01-22T10:13-0800">Jan 22, 2019 10:13 AM
								 PT
							</span>
						</p>
					</div>
				</div>
			
		
	
	
		
	
	
		
		    <div class="ad viewability">
		  		
					
				





















	

		
			
			
			
			
			
				<div id="topleaderboard" class=" ad-container">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				
					IDG.GPT.addDisplayedAd("topleaderboard", "true");
					$('#topleaderboard').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: topleaderboard - [971 1115]");
				
				});
				</script>
			
		
	
 	
 
  
		    </div>		    
		
	
	
	
	
	
</header>




	










	
	
	
		
	



<section class="epo cat-narrow" id="drr-top-ad">
	
		
		
				
   	
   		
        	
		












    
    















<div class="insider-promo-wrapper not-nsdr" data-placement-id="">
	<div class="sector apart">
	  <div class="insider-both">
	  	
			<div class="become-an-insider">
				<div class="notlogin-insider-title"><h3><span class="insider"></span>Become An <span class="color-title">Insider</span></h3></div>
				<div class="notlogin-insider-deck">Sign up now and get FREE access to  
				hundreds of Insider articles, guides, reviews, interviews, blogs, and other premium content.
				 <a href="/learn-about-insider">Learn more</a>.</div>
			</div>												
		
	
		<div class="other-insider">
		
			
				
				
				
					<div class="insider-module-title">
						<div class="hed">Related Articles</div>
					</div>
				
			
			<ul>
		    
		    	
					
				













<li class="clearfix">
	
		<div class="sized-img"><a  href="/article/3335482/application-development/18-nodejs-and-javascript-libraries-for-fast-and-simple-microservices.html"><img  class="small.3x2Image  imgId100768066 " src="https://images.idgesg.net/images/article/2018/08/circular_jigsaw_puzzle_pieces_component_parts_of_a_whole_microservices_by_thomasvogel_gettyimages-495061257_plus_abstract_network_connections_nodes_background_by_matjaz_slanic_gettyimages-629677830_1200x800-100768066-small.3x2.jpg" alt="puzzle pieces / network / connections / component parts of a whole / microservices" itemprop="image" /></a></div>
	
<div class="hed"><a  href="/article/3335482/application-development/18-nodejs-and-javascript-libraries-for-fast-and-simple-microservices.html#tk.jvw_nsdr_ndxprmomod">18 Node.js and JavaScript libraries for fast and simple...</a></div>
</li>

		    
		    	
					
				













<li class="clearfix">
	
		<div class="sized-img"><a  href="/article/3333642/java-platform/what-to-do-when-free-java-8-updates-end.html"><img  class="small.3x2Image  imgId100765082 " src="https://images.idgesg.net/images/article/2018/07/java_flavors_jvm_flavours_by_nathan_dumlao_cc0_via_unsplash_binary_by_lagartofilm_gettyimages_1200x800-100765082-small.3x2.jpg" alt="Java / JVM / flavors / flavours" itemprop="image" /></a></div>
	
<div class="hed"><a  href="/article/3333642/java-platform/what-to-do-when-free-java-8-updates-end.html#tk.jvw_nsdr_ndxprmomod">What to do when free Java 8 updates end</a></div>
</li>

		    
		    	
					
				













<li class="clearfix">
	
		<div class="sized-img"><a  href="/article/3330742/java-language/13-java-frameworks-for-rock-solid-microservices.html"><img  class="small.3x2Image  imgId100758866 " src="https://images.idgesg.net/images/article/2018/05/coffee_cup_bean_java_by_foundry_cc0_via_pixabay_1200x800-100758866-small.3x2.jpg" alt="coffee cup - coffee beans - Java" itemprop="image" /></a></div>
	
<div class="hed"><a  href="/article/3330742/java-language/13-java-frameworks-for-rock-solid-microservices.html#tk.jvw_nsdr_ndxprmomod">13 Java frameworks for rock-solid microservices</a></div>
</li>

		    
			</ul>
		
			<div class="more-insider"><a href="/insider"><span class="insider"></span>See all Insider</a></div>
		</div><!-- //.other-insider -->
		
	  </div><!-- //.insider-both -->
	</div><!--  //.promo.apart -->
</div>


   	
   	
   	


				<div class="ad top-ad">
	
		
		
			
				
					
					
						
					
				
				
				
			





















	

		
			
			
			
			
			
				<div id="topimu" class="adunit ad-container">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				if($(window).width() >= 930) {
					IDG.GPT.addDisplayedAd("topimu", "true");
					$('#topimu').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: topimu - [971 1115]");
				}
				});
				</script>
			
		
	
 	
 
 
		
	
</div>
		
	
</section>











		
		



		<section class="bodee">

			
				
				
					












	
		



















<style>
	#drr-container figure.large.video {
		border-bottom: 0 none;
	}
	figure#page-lede.thm-gallery.rr-gallery-vid #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 300px !important;
		height: 169px !important;
		transition: all 0.5s ease;
	}
	figure#page-lede.thm-gallery #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 100%;
		height: 100%;
		transition: all 0.5s ease;
	}
</style>
<style>
.jwplayer.jw-state-paused .jw-display {
	display: table !important;
	padding: 0;
}
.jwplayer .jw-display-icon-container {
    float: none;
    padding: 0;
    margin: 0;
}
.jw-flag-small-player .jw-display {
	padding-top: 0px;
}
.jwplayer .jw-display-icon-container .jw-icon-rewind {
	visibility: hidden;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play path,
.jw-state-idle .jw-svg-icon-play path,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay path,
.jw-state-complete .jw-svg-icon-replay path {    
    display: none;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    background-size: contain;
    background-repeat: no-repeat;
    background-color: transparent;
    background-image: url(//idge.staticworld.net/idgtv/btn-play-default.svg);
    background-position: center center;
    bottom: 0;
    border-radius: 0;
    box-shadow: none;
    left: 0;
    margin: auto;
    right: 0;
    top: 0;
}
.jwplayer .jw-display-icon-container .jw-icon,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    height: 81px;
    width: 78px;
}
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container .jw-icon,
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.thm-gallery.rr-gallery-vid .jw-state-idle .jw-svg-icon-play,
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.thm-gallery.rr-gallery-vid .jw-state-complete .jw-svg-icon-replay  {
	height: 65px;
    width: 62px;
}
</style>


	
		
	




	<div id="drr-container" class="is-insider" itemprop="articleBody">
	<p>ECMAScript 2019, the planned next version of the specification serving as the basis of JavaScript, is moving forward. The first two proposals have reached the “finished” stage thus far.</p><aside class="fakesidebar"><strong>[ Go deeper at InfoWorld: <a href="https://www.infoworld.com/article/3039817/application-development/beyond-jquery-an-expert-guide-to-choosing-the-right-javascript-framework.html">Beyond jQuery: An expert guide to JavaScript frameworks</a> • <a href="https://www.infoworld.com/article/3202764/node-js/the-complete-guide-to-nodejs-frameworks.html">The complete guide to Node.js frameworks</a> • The <a href="https://www.infoworld.com/article/3229747/javascript/the-10-essential-tools-for-javascript-developers.html">10 essential JavaScript developer tools</a> • The <a href="https://www.infoworld.com/article/3192844/application-development/review-the-6-best-javascript-ides.html">6 best JavaScript IDEs</a> and <a href="https://www.infoworld.com/article/3195951/application-development/review-the-10-best-javascript-editors.html">10 best JavaScript editors</a>. | Keep up with hot topics in programming with InfoWorld’s <a href="https://www.infoworld.com/newsletters/signup.html">App Dev Report newsletter</a>. ]</strong></aside><aside class="fakesidebar"/><p>These proposals include:</p>
	













<div class="empty-div"></div>

<div class="tease-promo">
	<p class="tease-title">To continue reading this article register now</p>
	<div class="access-btn"><a class="btn register" href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-form-short')" data-modal-id="insider-popup">Get Free Access</a></div>
	<p class="tease-links">
		<a href="/learn-about-insider/">Learn More</a> &nbsp; Existing Users <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-signin')" data-modal-id="insider-popup">Sign In</a>
	</p>
</div>


	
	<script>
	$(document).ready(function($){
		$(function(){
			$(".signin-register > a.signin, .signin-register > a.register").click(function(){
			    $(".signin-register > a.signin, .signin-register > a.register").removeClass("selected");
			    $(this).addClass("selected");
			    return false;
			});
		});
		
	   if(typeof(IDG.insiderReg.readCookie('nsdr')) == 'undefined' && $thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
		
		$triggered_times = 0;
		
	    $(window).on('scroll', function() {
			if($('.signin-register > a').hasClass('selected')) {
				$triggered_times = 1;
			}
            var y_scroll_pos = window.pageYOffset;
            var emptyDiv = $('.empty-div').offset().top;
            var scroll_pos_test = emptyDiv - 600;

            if(y_scroll_pos > scroll_pos_test && $triggered_times == 0 ) {
                $triggered_times = 1;   // to make sure the above action triggers only once

                IDG.insiderReg.registerLinkEvent('insider-reg-form-short');
                $('body').append("<div class='modal-overlay modal-close'></div>");
                $('.modal-overlay').fadeTo(500, 0.9);
				$('.modal-overlay').height($(document).height());
                $('#insider-popup.modal-box').fadeIn(500);
                
                if (navigator.userAgent.match(/(iPad)/)) {
					$("html, body").animate({
			            scrollTop: 0
			        }, 500);
				}
            }
	    });
	   }  
	    
	});
	</script>
	
	</div>





	
	
	
	
	
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	





<script src="/www/js/video/embedder-jwp.js?v=20190117112204"></script>


	
	
	
	




					










				
			
		
		</section><!-- /.bodee -->

		















	
		
			
				
				
					
						
							
						











<div class="six-column" id="recommended">
	<div class="head">Recommended</div>
	<ul>
		
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
		




























































	
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
						
							
						
						
						
						
						
					



















<li class=" first">
	
		
			
			
			
			
			
		

























	




	
		



 

	
	
	
		
				
				<figure class="well-img">
					
						
						
							<a  href="/article/3114167/development-tools/choosing-your-java-ide.html"><img  class="lazy small.3x2Image  imgId100760556 " data-original="https://images.idgesg.net/images/article/2018/06/java_beans_grounds_coffee_binary_by_nathan_dumlao_cc0_via_unsplash_1200x800-100760556-small.3x2.jpg" alt="java -- beans, grounds, coffee -- binary background" /></a>
						
					
					
					
				</figure>
				
		
		
	

	
	
		
		
		
			
		
		
	
	
	<div class="post-cont">
		
			
								
			
			
		
		<div class="title">













	
		
    	
    		<a  href="/article/3114167/development-tools/choosing-your-java-ide.html">Choosing your Java IDE</a>
    	
	
</div>
    </div>
    
	    
    
</li>

				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
						
							
						
						
						
						
						
					



















<li class=" ">
	
		
			
			
			
			
			
		

























	




	
		



 

	
	
	
		
				
				<figure class="well-img">
					
						
						
							<a  href="/article/3272244/core-java/what-is-the-jvm-introducing-the-java-virtual-machine.html"><img  class="lazy small.3x2Image  imgId100758585 " data-original="https://images.idgesg.net/images/article/2018/05/jvm_binary_code_3x2_1200x800-100758585-small.3x2.jpg" alt="JVM - Java Virtual Machine" /></a>
						
					
					
					
				</figure>
				
		
		
	

	
	
		
		
		
			
		
		
	
	
	<div class="post-cont">
		
			
								
			
			
		
		<div class="title">













	
		
    	
    		<a  href="/article/3272244/core-java/what-is-the-jvm-introducing-the-java-virtual-machine.html">What is the JVM? Introducing the Java virtual machine</a>
    	
	
</div>
    </div>
    
	    
    
</li>

				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
						
							
						
						
						
						
						
					



















<li class=" ">
	
		
			
			
			
			
			
		

























	




	
		



 

	
	
	
		
				
				<figure class="well-img">
					
						
						
							<a  href="/article/3319078/learn-java/functional-programming-for-java-developers-part-2.html"><img  class="lazy small.3x2Image  imgId100779885 " data-original="https://images.idgesg.net/images/article/2018/11/apples_oranges_slices_mixture_puzzle_balance_opposites_fruit__savatore-gersace_flickr-100779885-small.3x2.jpg" alt="apples oranges slices mixture puzzle balance opposites fruit  savatore gersace flickr" /></a>
						
					
					
					
				</figure>
				
		
		
	

	
	
		
		
		
			
		
		
	
	
	<div class="post-cont">
		
			
								
			
			
		
		<div class="title">













	
		
    	
    		<a  href="/article/3319078/learn-java/functional-programming-for-java-developers-part-2.html">Functional programming for Java developers </a>
    	
	
</div>
    </div>
    
	    
    
</li>

				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
						
							
						
						
						
						
						
					



















<li class=" ">
	
		
			
			
			
			
			
		

























	




	
		



 

	
	
	
		
				
				<figure class="well-img">
					
						
						
							<a  href="/article/3305792/learn-java/java-challengers-4-comparing-java-objects-with-equals-and-hashcode.html"><img  class="lazy small.3x2Image  imgId100773298 " data-original="https://images.idgesg.net/images/article/2018/09/equal_engraved__sign_by_scott_cc_by-sa_2-0_via_flickr_1200x800-100773298-small.3x2.jpg" alt="An image of the word 'equal'" /></a>
						
					
					
					
				</figure>
				
		
		
	

	
	
		
		
		
			
		
		
	
	
	<div class="post-cont">
		
			
								
			
			
		
		<div class="title">













	
		
    	
    		<a  href="/article/3305792/learn-java/java-challengers-4-comparing-java-objects-with-equals-and-hashcode.html">Java Challengers #4: equals() and hashcode() </a>
    	
	
</div>
    </div>
    
	    
    
</li>

				
				
			
		
	




		
		
		
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
		






























































		
	</ul>
</div><!-- /.six-column -->
					

				
			
			
		

		
			
				
					
						
						
					





















	
 	
		
		<div class="lazyload_ad">
		<code type="text/javascript">
		<!--
		document.write('<div id="ciu" class=" ad-container">');
		consent.ads.queue.push(function(){
		IDG.GPT.addDisplayedAd("ciu", "true");
		IDG.GPT.addLazyloadedAd("ciu", "true");
		});
		document.write('</div>');
		consent.ads.queue.push(function(){
		$('#ciu').responsiveAd({screenSize:'971 1115', scriptTags: []});
		if (Object.keys(IDG.GPT.companions).length > 0 || IDG.GPT.disableInitialLoad) {
			IDG.GPT.refreshAd('ciu');
		}
		});
		//-->
		</code>
		</div>
 	
 
  
							
	
	


	
		
	<link rel="stylesheet" href="/www.idge/css/sponsored-links.css?v=20190117112204" />
	<link rel="stylesheet" href="/www.idge.jvw/css/sponsored-links.css?v=20190117112204" />


<section id="resources-sponsored-links">
	
	
 	<section class="sponsored-links">
 	  <div class="head">Sponsored Links</div>
	 	
			
			
			
			
			
			
			
			
			
			
			
			
		




























































	<ul class="first">
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
					

















	
		
	
	





	




<li>
	<a rel="nofollow" target="_blank" href="http://pubads.g.doubleclick.net/gampad/clk?id=4504608452&iu=/8456/IDG.US_E_CIO.com" >
		What are you doing to accelerate IT agility? Learn about the IT model that serves as a catalyst for digital transformation. 
	</a>
</li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
					

















	
		
	
	






</ul><ul>

<li>
	<a rel="nofollow" target="_blank" href="http://pubads.g.doubleclick.net/gampad/clk?id=4504608452&iu=/8456/IDG.US_E_CIO.com" >
		Unlock the potential of your data. How well are you harnessing information to improve business outcomes? A new CIO Playbook will help.
	</a>
</li>
				
				
			
		
	</ul>




 	</section>
</section>
	
	


		</article>

	</section><!-- /role=main -->

</div><!-- /#page-wrapper -->
		
		












	<link rel="stylesheet" href="/www.idge/css/foot.css?v=20190117112204" />
	<link rel="stylesheet" href="/www.idge.jvw/css/foot.css?v=20190117112204" />


<footer>
    <section class="brand" itemscope itemtype="http://schema.org/Organization">
   	
   		<link itemprop="url" href="http://www.javaworld.com"> 
        <a href="/"><span class="logo">JavaWorld</span></a>
		<span class="tagline"> JavaWorld is the original independent resource for Java developers, architects, and managers.</span>
        
        
        
    </section>
    	
    <section class="topics">
    	
			
		        
		        <nav id="ft1">
		            <ul>
						
							
							
		    			
















	
		
			
				<li><a href="/category/core-java/">Core Java</a>
					
				</li>
			
				<li class="selected"><a href="/category/enterprise-java/" class="active">Enterprise Java</a>
					
				</li>
			
				<li><a href="/category/learn-java/">Learn Java</a>
					
				</li>
			
				<li><a href="/category/mobile-java/">Mobile Java</a>
					
				</li>
			
		
	
	
	

		            </ul>
		        </nav>
		        
	        
        
        
        <nav id="ft2">
            <ul>
           		
           		










<li><a href="/howto">How-Tos</a></li>
<li><a href="/feature">Features</a></li>
<li><a href="/news">News</a></li>
<li><a href="/blogs">Blogs</a></li>
<li><a href="/resources">Resources</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
           		
            </ul>
        </nav>
        
        
			
		
    </section>
    
    
    <section class="about">
		<div class="wrapper"> 
        	<nav class="tertiary" id="ft3">
            	<ul>
            		
















<li><a href="/about/about.html"  >About Us</a>

<li><a href="/about/contactus.html"  >Contact</a>

<li><a href="/about/privacy.html"  >Privacy Policy</a>

<li><a href="/about/cookie-policy.html"  >Cookie Policy</a>

<li><a href="/about/member-preferences.html"  >Member Preferences</a>

<li><a href="https://www.idgenterprise.com/reach/javaworld/" target="_blank" rel="nofollow" >Advertising</a>

<li><a href="https://www.idg.com/work-here/" target="_blank" rel="nofollow" >IDG Careers</a>

<li><a href="/about/adchoices.html"  >Ad Choices</a>

<li><a href="/about/affiliates.html"  >E-commerce Links</a>




            	</ul>
        	</nav>
		</div>
	</section>
	
    <section class="copyright">
        <div class="wrapper">
			
        	
        
        	
        	<p><a href="/about/copyright.html">Copyright</a> &copy; 2019 IDG Communications, Inc.</p>
			<div class="network">
				<div id="network-selector">
                <div class="label">Explore the IDG Network <i class="ss-icon tick">descend</i></div>
                <ul>
                	
                		
                		
                	














	
		<li><a href="https://www.cio.com" target="_blank" rel="nofollow">CIO</a></li>
	
		<li><a href="https://www.cio-asia.com" target="_blank" rel="nofollow">CIO Asia</a></li>
	
		<li><a href="https://www.computerworld.com" target="_blank" rel="nofollow">Computerworld</a></li>
	
		<li><a href="https://www.csoonline.com" target="_blank" rel="nofollow">CSO</a></li>
	
		<li><a href="https://www.gamestar.com" target="_blank" rel="nofollow">GameStar</a></li>
	
		<li><a href="https://www.greenbot.com" target="_blank" rel="nofollow">Greenbot</a></li>
	
		<li><a href="https://www.idc.com" target="_blank" rel="nofollow">IDC</a></li>
	
		<li><a href="https://www.idg.com" target="_blank" rel="nofollow">IDG</a></li>
	
		<li><a href="https://www.idgconnect.com" target="_blank" rel="nofollow">IDG Connect</a></li>
	
		<li><a href="https://www.idg.tv" target="_blank" rel="nofollow">IDG.TV</a></li>
	
		<li><a href="https://www.infoworld.com" target="_blank" rel="nofollow">InfoWorld</a></li>
	
		<li><a href="https://www.itnews.com" target="_blank" rel="nofollow">IT News</a></li>
	
		<li><a href="https://www.itwhitepapers.com" target="_blank" rel="nofollow">ITwhitepapers</a></li>
	
		<li><a href="https://www.itworld.com" target="_blank" rel="nofollow">ITworld</a></li>
	
		<li><a href="https://www.javaworld.com" target="_blank" rel="nofollow">JavaWorld</a></li>
	
		<li><a href="https://www.macworld.com" target="_blank" rel="nofollow">Macworld</a></li>
	
		<li><a href="https://www.networkworld.com" target="_blank" rel="nofollow">Network World</a></li>
	
		<li><a href="https://www.pcworld.com" target="_blank" rel="nofollow">PCWorld</a></li>
	
		<li><a href="https://www.techconnect.com" target="_blank" rel="nofollow">TechConnect</a></li>
	
		<li><a href="https://www.techhive.com" target="_blank" rel="nofollow">TechHive</a></li>
	
		<li><a href="https://www.thefullnerd.com/" target="_blank" rel="nofollow">The Full Nerd</a></li>
	

                </ul>
				</div><!-- /#network-selector -->
			</div><!-- /.network -->
		</div><!-- /.wrapper -->
    </section>
</footer>

<script src="/www/js/analytics/mouse_down.js"></script> 
<script src="/www/js/jquery/jquery-ui.js"></script>
<script src="/www/js/jquery/jquery.dfp.min.js"></script>
<script src="/www.idge/js/mule/shortstack_nav.js"></script>




	
		
			
		





















	

		
			
			
			
			
			
				<div id="mobilewelcomead" class=" ad-container">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				
					IDG.GPT.addDisplayedAd("mobilewelcomead", "true");
					$('#mobilewelcomead').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: mobilewelcomead - [971 1115]");
				
				});
				</script>
			
		
	
 	
 
 
	


<script src="/www/js/analytics/tracking.js"></script>
<script src="/www/js/autocomplete.js"></script>


	<script src="/www.idge/js/social_sidecar.js"></script>
	<script src="/www.idge/js/jquery/plugins/jquery.colorbox-min.js"></script>
	<script src="/www.idge/js/article.js?v=20190117112204"></script>
	
	<script src="/www/js/prettify.js"></script>
	<script src="/www.idge/js/jquery/responsive-tables.js"></script>
	<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
	<script>
	$(document).ready(function() {
		$("table.tablesorter").tablesorter({
			widgets: ['zebra']
		});
		
		$("table.tablesorter tbody tr").hover(function() {
			$(this).toggleClass("selected");
		});
		
		$("table.tablesorter thead tr th").each(function(){			
			if ($(this).find('.ss-icon').length < 1) {
				$(this).append('<i class="ss-icon"></i>');
			}
		});
		
	});
	</script>


<script src="/www/js/jquery/jquery.lazyload.min.js"></script>
<script src="/www.idge/js/global.js?v=20190117112204"></script>
<script src="/www/js/webfonts/ss-social.js"></script>
<script src="/www/js/webfonts/ss-standard.js"></script>
<script src="/www/js/analytics/brandAnalytics.js"></script>


























<!-- Begin BlueKai Tag -->
<iframe name="__bkframe" height="0" width="0" frameborder="0" src="javascript:void(0)"></iframe>
<script type="text/javascript" src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
<!-- CryptoJS -->
<script src="/www/js/utils/md5.js"></script>
<script type="text/javascript" src="/www/js/analytics/idg_bk_coreapi.js"></script>
	
<script type="text/javascript">
bk_allow_multiple_calls=true;
var blueKaiId=14349;
var blueKaiPort=10;
var brandCode = "jvw";
var regUrl="https://regdev.idge.int/api/"
var daysToRefresh=30;
var bk_debug_log=false;



	 regUrl="https://reg.idgenterprise.com/api/";



	daysToRefresh=30;


	




	

if ( typeof(s) != 'undefined' ) {
	bk_addPageCtx("pageType", (typeof(s.pageType)!='undefined')?s.pageType:'');
}


//CMS-Specific
bk_addPageCtx("cmscatids", "[3646,3471,3249,3761]");



	bk_addPageCtx("goldenIds", "[241,247,281,275]");



	
		bk_addPageCtx('insider', '[true]');
	




bk_addPageCtx("cmpy", "[]");


bk_addPageCtx('tid', '2');

	
	







	bk_addPageCtx("purchaseintent","notapplicable");



// Add the list name and email address hash params to bluekai tracking
// If the user came from a newsletter clickthru, also set the isnl pagectx
params = getUrlParams('phint');
if(Object.keys(params).length > 0)
	{
	bk_addPageCtx("idg_eid", params['idg_eid']);
	bk_addPageCtx("newt", params['newt']);
	bk_addPageCtx("isnl", "1");	
	}

	try{
		consent.adsel.queue.push(function(){
			console.log('*****GDPR: running queue for bluekai ad selection');
			IDG.bkCoreApi.start();
		});
	}
	catch(e){
		//alert("Triggering catch")
		consent.adsel.queue.push(function(){
			bk_doJSTag(blueKaiId ,blueKaiPort);
		});
		if (window.console && window.console.log){
			window.console.log("Error Occured While Processing Profile Siubmission")
		}
	}
	
	










$('article, #slideshowCarousel').on('click', '.product-list-price, .btn-amazon, .productLink', function(e) {
	var $linkEl = $(e.target);
	var po = $linkEl.data('po');
	if ($.inArray(po, ['amazon', 'vendor', 'other']) >= 0) {
		if (po == 'amazon') {
			var prCat = $linkEl.data('bkc');
			if (typeof prCat != 'undefined') {
				bk_addPageCtx('event', 'AmazonClick'+prCat);
			}
			
			bk_addPageCtx('event', 'AmazonClickJavaAppDev');
			
			bk_addPageCtx('event', 'AmazonClickJavaWebDevelopment');
			
			bk_addPageCtx('event', 'AmazonClickScriptingandJVMLanguages');
			
			bk_addPageCtx('event', 'AmazonClickHTML/CSS/JavaScript');
			
		}
		var prMfr = $linkEl.data('bkmfr');
		if (typeof prMfr != 'undefined') {
			bk_addPageCtx('event', 'eCommerceMFR'+prMfr);
		}
		var prVndr = $linkEl.data('bkvndr');
		if (typeof prVndr != 'undefined') {
			bk_addPageCtx('event', 'eCommerceClickVendor'+prVndr);
		}
		consent.adsel.queue.push(function(){
			bk_doJSTag(34202, 1);
		});
	}
});
</script>



<!-- End BlueKai Tag -->







<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>


<script type="text/javascript">
// -- Load Lazy Advertisement placement as deferred
$("div.lazyload_ad").lazyLoadAd({
        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
        onLoad       : false,       // Callback function on call ad loading
        onComplete   : false,       // Callback function when load is loaded
        timeout      : 1500,        // Timeout ad load
        debug        : false,       // For debug use : draw colors border depends on load status
        xray         : false        // For debug use : display a complete page view with ad placements
}) ;
</script>



<script type='text/javascript'>

			IDG.insiderReg.stepReg();
		

		$('#resources-sponsored-links').addClass('show');
	
</script>












	
		
	
	
		
	
	

<!-- Begin comScore Tag -->
<script>
var _comscore = _comscore || [];
_comscore.push(
{ c1: "2", c2: "6035308", c3: "", c5: "Java App Dev", c6: "Article: News", c15: "3335483" });
(function()
{
	var s = document.createElement("script"), el = document.getElementsByTagName("script")[0];
	s.async = true; s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
	el.parentNode.insertBefore(s, el);
})();
</script>
<noscript>
<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035308&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->


	<!-- LiveRamp Sources -->
	<script type="text/javascript"src="//storage.googleapis.com/cdn.pippio.com/sdk/pippio.min.js" async></script>
	<script src="/www/js/utils/liveRamp.js"></script>
	<!-- End of LiveRamp -->













<script type="text/javascript">
consent.digitalelement.queue.push(function(){
	$thm.logPlEvent({"b":"jvw","e":"view","t":"article","id":"3335483"});
	
});
</script>

		<div id="loginModal"></div>
		<div id="logoffModal"></div>

		
		
		
		<script type="text/javascript">
			a=top;f=self;
			var acceptedDomains = ["lookbookhq.com"];
			var cleanedHost = a.location.hostname.split(".").slice(-2).join(".");
			if(a!=f && acceptedDomains.indexOf(cleanedHost) < 0) {
				a.location=f.location;
			}
		</script>			

	</body>
</html>