












	
	
		
	
		
	
	
	
	


<!DOCTYPE html>
<!--[if lt IE 7]>  <html lang="en" class="lt-ie9 lt-ie8 lt-ie7" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]> <html lang="en" class="lt-ie10 lt-ie9 lt-ie8" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]> <html lang="en" class="lt-ie10 lt-ie9" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="lt-ie10" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]-->
	
	











<head>
	<link rel="alternate" hreflang="en" href="https://www.javaworld.com/article/3537391/coding-together-apart-software-development-after-covid-19.html" />
	
	
	
	<!-- metas -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />		
	<title>Coding together apart: Software development after COVID-19 | JavaWorld</title>
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	
	
	<script>
	function getQueryVariable(variable) {
		var query = window.location.search.substring(1);
		var vars = query.split("&");
		for (var i=0;i<vars.length;i++) {
			var pair = vars[i].split("=");
			if(pair[0] == variable){return pair[1];}
		}
		return(false);
	}
	</script>
	
	<script>
	// Include CSS file for insider modal - used in insider_reg_api.js
	function addCSS(filename){
		 var headerTag = document.querySelector("header#banner");
		 var styleTag = document.createElement('link');
		 styleTag.href = filename;
		 styleTag.className = "oc-modal";
		 styleTag.type = 'text/css';
		 styleTag.rel = 'stylesheet';
		 headerTag.parentNode.insertBefore(styleTag, headerTag);
	}
	function addScript(filename){
		let headTag = document.querySelector("header#banner");
		let scriptTag = document.createElement('script');
		scriptTag.src = filename;
		scriptTag.className = 'oc-modal';
		scriptTag.type = 'text/javascript';
		headTag.parentNode.insertBefore(scriptTag, headTag);
	}
	</script>
		
	<!-- ad-related js -->
	<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
	
	<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
	
	
	
	<script type="text/javascript" src="/www/js/apollo-locales.js?v=20200407113609"></script>
	
	
	











<script src="//d2zv5rkii46miq.cloudfront.net/0/latest/cmp_shim.js"></script>

<script>
var consent = consent || {};
consent.isEU = consent.isEU || null;
consent.personalization = consent.personalization || null;
consent.ads = consent.ads || {};
consent.ads.queue = consent.ads.queue || [];

consent.infostorage = consent.infostorage || {};
consent.infostorage.queue = consent.infostorage.queue || [];

consent.adsel = consent.adsel || {};
consent.adsel.queue = consent.adsel.queue || [];

consent.contentsel = consent.contentsel || {};
consent.contentsel.queue = consent.contentsel.queue || [];

consent.socmedia = consent.socmedia || {};
consent.socmedia.queue = consent.socmedia.queue || [];

consent.blueconic = consent.blueconic || {};
consent.blueconic.queue = consent.blueconic.queue || [];

consent.digitalelement = consent.digitalelement || {};
consent.digitalelement.queue = consent.digitalelement.queue || [];

consent.purposes = consent.purposes || {};
consent.purposes.standard = consent.purposes.standard || [];
consent.purposes.custom = consent.purposes.custom || [];
consent.vendors = consent.vendors || {};
consent.vendors.standard = consent.vendors.standard || [];
consent.vendors.custom = consent.vendors.custom || [];

var dataLayer = window.dataLayer = window.dataLayer || [];
</script>






<style type="text/css">
#sp_privacy_manager_container {
	z-index: 10000000 !important;
}
</style>

<script> 											
window._sp_ = window._sp_ || {};
window._sp_.config = window._sp_.config || {};

//Replace YOUR_ACCOUNT_ID with the account ID provided
//by Sourcepoint
window._sp_.config.account_id = 146;

// replace 'mms.sp-prod.net' with your CNAME'd messaging subdomain		
window._sp_.config.mms_domain = 'cmp.javaworld.com' ; 
//window._sp_.config.mms_domain = 'mms.sp-prod.net' ; 

// messaging-specific configuration
window._sp_.mms = window._sp_.mms || {};
window._sp_.mms.cmd = window._sp_.mms.cmd || [];

//CMP Flags
window._sp_.config.cmp = _sp_.config.cmp || {};
window._sp_.config.cmp.enabled = true;
window._sp_.config.cmp.waitForConsentData = true;

//Code to call the server and display a message
window._sp_.mms.cmd.push( function () {
    window._sp_.mms.startMsg();
});
</script>

<script src="/www/js/messaging.js?v=dec2019update"></script>


<script type="text/javascript">(function () { var e = false; var c = window; var t = document; function r() { if (!c.frames["__uspapiLocator"]) { if (t.body) { var a = t.body; var e = t.createElement("iframe"); e.style.cssText = "display:none"; e.name = "__uspapiLocator"; a.appendChild(e) } else { setTimeout(r, 5) } } } r(); function p() { var a = arguments; __uspapi.a = __uspapi.a || []; if (!a.length) { return __uspapi.a } else if (a[0] === "ping") { a[2]({ gdprAppliesGlobally: e, cmpLoaded: false }, true) } else { __uspapi.a.push([].slice.apply(a)) } } function l(t) { var r = typeof t.data === "string"; try { var a = r ? JSON.parse(t.data) : t.data; if (a.__cmpCall) { var n = a.__cmpCall; c.__uspapi(n.command, n.parameter, function (a, e) { var c = { __cmpReturn: { returnValue: a, success: e, callId: n.callId } }; t.source.postMessage(r ? JSON.stringify(c) : c, "*") }) } } catch (a) { } } if (typeof __uspapi !== "function") { c.__uspapi = p; __uspapi.msgHandler = l; c.addEventListener("message", l, false) } })();</script>
<script>
        window._sp_ccpa = {
            config: {
                mmsDomain: "https://cmp.javaworld.com",
                ccpaOrigin: "https://ccpa-service.sp-prod.net",
                accountId: "146",
                getDnsMsgMms: true,
                alwaysDisplayDns: false,
            }
        }
</script>
<script src="https://ccpa.sp-prod.net/ccpa.js"></script>

<script>
__cmp('getConsentData',null,function(e){
	
	consent.isEU = e.gdprApplies;
	if (!consent.isEU) {
		
		
		consent.personalization=false;
		
		__uspapi('getUSPData', 1, (uspData, success) => {
			if(success) {
				try {
					console.log('uspapi success: ', uspData);
					var uspDataString = uspData.uspString;
					var uspDataArray = [];
					uspDataArray = uspDataString.split("");
					if (typeof uspDataArray[2] !== "undefined" && uspDataArray[2] !== "Y") {
						console.log('User has not opted in to CCPA - run everything');
						consent.personalization=true;
						$(window).trigger("runConsent", [consent.socmedia.queue]);
						$(window).trigger("runConsent", [consent.blueconic.queue]);
					}
		
					$(window).trigger("runConsent", [consent.adsel.queue]);
				}
				catch(e) {
					console.log('error with uspData retrieval: ', e);
				}
				
			} else {
				console.log('uspapi fail: ', uspData);
			}
			
		});	
		
		$(window).trigger("runConsent", [consent.contentsel.queue]);
		$(window).trigger("runConsent", [consent.digitalelement.queue]);
		$(window).trigger("runConsent", [consent.ads.queue]);
		$(window).trigger("runConsent", [consent.infostorage.queue]);
		
	
		dataLayer.push({
			'event': 'consentKnown' 
		});
		bindReshowCmp();
	}
	else if (e.consentData !== null && e.consentData !== "") { // else if.. visitor is from EU and consent is known...
		getConsentInfo();
		bindReshowCmp();
	}
	else { //else consent is not known
	    bindReshowCmp();
	}
});

function getConsentInfo() {
	
	__cmp('getVendorConsents',[],function (e) {
		
		consent.purposes.standard = Object.keys(e.purposeConsents);
		consent.vendors.standard = Object.keys(e.vendorConsents);
		
		consent.personalization = consent.purposes.standard.includes("2");
		
		
		
		
		
		
		
		if (consent.purposes.standard.includes("1")) { // if information storage consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.infostorage.queue]);
		}
		if (consent.purposes.standard.includes("3")) { // if ad selection consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.adsel.queue]);
		}
		if (consent.purposes.standard.includes("4")) { // if content selection consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.contentsel.queue]);
		}
		//special case for blueconic
		if (consent.purposes.standard.includes("1") && consent.purposes.standard.includes("2") && consent.purposes.standard.includes("3") && consent.purposes.standard.includes("4") && consent.purposes.standard.includes("5")) {
			
			$(window).trigger("runConsent", [consent.blueconic.queue]);
		}
		
		//special case for Digital Element
		if (consent.purposes.standard.includes("2") && consent.purposes.standard.includes("3") && consent.purposes.standard.includes("4") && consent.purposes.standard.includes("5")) {
			
			$(window).trigger("runConsent", [consent.digitalelement.queue]);
		}
	});

	__cmp('getCustomVendorConsents',[],function (e) { 
		
		consent.purposes.custom = [];
		e.consentedPurposes.forEach(function(item, index) {
			consent.purposes.custom.push(item.name);
		});
		
		consent.vendors.custom = [];
		e.consentedVendors.forEach(function(item, index) {
			consent.vendors.custom.push(item.name);
		});
		
		
		
		if (consent.purposes.custom.includes("Social Media Consents")) { // if social media consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.socmedia.queue]);
		}
		
		
		if (consent.vendors.custom.includes("Google Ad Manager")) {
			
			$(window).trigger("runConsent", [consent.ads.queue]);
		}
		
	});
	
	dataLayer.push({
		'event': 'consentKnown' 
	});
}

var idgCMPSourcepointCallback = function(){
	if (consent.isEU) {		
		getConsentInfo();
	}
}

$(window).on("runConsent", function(event, queueToRun) {
		watchConsentQueue(queueToRun)
});

function runQueue(queue){
	for (var x=0;x<queue.length;x++) {
		var nextFn = queue.shift();
		nextFn();
		
	}	
}

function watchConsentQueue(queue){
	setInterval(function() { runQueue(queue); },500);
}
function bindReshowCmp() {
	var url = document.location.pathname;
	if (url.indexOf("/about/member-preferences") > -1) {
		$(document).ready(function() {
			$(".cmpSettings").show();
			$(".reshowLink").on("click", function(e) {
				e.preventDefault();
				window._sp_.privacyManager.loadPrivacyManagerModal(3921, '5cd195e5f9f3332a80a0e25f');
			});
		});
	}
}
</script>




	
	
	
	
		










<script>
// this javascript is for retrieving locale-specific ad units for DFP - see mapping in apollo-locales.js
// getting locale and editions for the site the reader is viewing
let brandAbbrev = "jvw";
let brandConfigBrandId = "8";
//let myLocale = getLocale(); // getting locale on page load from URL, IP, geolocation - this will always be something. If 0, it's the global/default/core view.
let countryCode = "";
let getSlugFromId = getApolloLocaleIdMap();
let getIdFromSlug = getApolloLocaleSlugMap();

// if selectedLocale cookie exists, get locale
if (typeof getSelectedLocale() !== 'undefined'  && getSelectedLocale() === getLocale()) { // get locale from cookie if available otherwise, use another locale source (from geolocation, url slug, etc.)
 	countryCode = getSlugFromId[getSelectedLocale()];
} else {
	countryCode = getSlugFromId[getLocale()];
}
//console.log("+++ 1) in locales.editions.jsp - COUNTRY CODE IS DEFINED AS: "+countryCode+"+++");
// if countryCode is empty string at this point, it means localeId = 0 which is global (default/core)...
if (countryCode == "") {
	countryCode = "us"; // country code for default global is currently US
}
//console.log("====INSIDE locales-editions.jsp - getSelectedLocale() = " + getSelectedLocale() + " and getLocale() = " + getLocale() + " and countryCode = " + countryCode);
//US social media accounts are the default if locale cannot be determined
var twitterUrl = "https://twitter.com/javaworldcom";
var linkedInUrl = "http://www.linkedin.com/company/javaworld-com";
var facebookUrl = "https://www.facebook.com/pages/JavaWorld/107993545895326";
var youTubeUrl = "";
var twitterHandle = "javaworldcom";

if (countryCode === 'asean') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'middle-east') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'uk') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'in') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
	youTubeUrl = "";
}
if (countryCode === 'africa') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
	youTubeUrl = "";
}
if (countryCode === 'au') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'nz') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'nl') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}

//US business unit is the default if locale cannot be determined
var busUnit = "";
//cookie policy page
var localeEdition = "";
var busUnitAddress = "";
if (countryCode === 'asean') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'middle-east') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'uk') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'in') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'africa') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'au') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'nz') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'nl') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
</script>

	
	
	
	<script src="/www/js/init_device.js"></script>
	
	

	

	
		
			
			



















	<script async="async" src="//cdn.adsafeprotected.com/iasPET.1.js"></script>




	<script async src="//js-sec.indexww.com/ht/p/183980-91708798337038.js"></script>

	
<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20200407113609"></script>



<script type="text/javascript">
	if (adLayer==null || adLayer=='undefined') {
		var adLayer=[];
	}
	
		
			adLayer["itemType"]="article";
		
		
	
</script>
	
<script type="text/javascript">
	// Set up ad related variables
	try {
		IDG.GPT.unitName = "/8456/IDG.US_E_JavaWorld.com";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}

	try {
		IDG.GPT.unitName = IDG.GPT.unitName + "/" + "application-development_section";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	// global variables
	var global_ShowSuper = true;
	var global_ShowHero = false;
	
	//XFP global targeting, more targeting thm_pre
	var url = window.location.href;
	if(url.indexOf("?")>1){
		url=url.split('?')[0];
	}
	

	try {
		IDG.GPT.addTarget("URL", encodeURIComponent(url));
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	try {IDG.GPT.addTarget("zone", 'article/application-development');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("channel", 'enterprise-java,core-java');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("articleId", '3537391');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("type", 'analysis');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("typeId", '9');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("manufacturer", 'microsoft');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("templateType", 'article-default');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	
	try {IDG.GPT.addTarget("categoryIds", ['3646','3871','3469','3258']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("categorySlugs", ['application-development','technology-business','java','careers']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {IDG.GPT.addTarget("goldenIds", ['241','683','264','585']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {
		if (null != IDG.GPT.getQsVal("env")) {		
			IDG.GPT.addTarget("env", IDG.GPT.getQsVal("env").replace(/\W/g, "") );
		}
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	
	
		try {
			IDG.GPT.addTarget("author", 'James Kobielus');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
		

	try {
		IDG.GPT.addTarget("page_type", '');
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	

	
	
		try {
			IDG.GPT.addTarget("tagNames", 'COVID-19');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
		try {
			IDG.GPT.addTarget("insiderContent", 'true');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
	
	
</script>



<script type="text/javascript">
	
	
	
	
		
		
		
		
		
		
		
		
	
	
	
	
</script>
  
<script src="/www.idge/js/thm_pre.js?v=20200407113609"></script>


	
	
		<script>
		// IDGMPM-16419 - moved out of adsel queue for IDGMPM-16933
		googletag.cmd.push(function() {
		  if (googletag.pubads().getTargeting('permutive').length == 0) {
			
			//IDGMPM-18418 - capture paermutive key-values
			window.headertag = window.headertag || {};
			window.headertag.cmd = window.headertag.cmd || [];
			window.headertag.cmd.push(function() {
				try {
					var segs = JSON.parse(localStorage._pdfps || '[]').slice(0,250);
					window.headertag.setUserKeyValueData({ segments: {"permutive": segs} });                
				} catch (e) {}
			});
			
		    var kvs = localStorage.getItem('_pdfps');
		    googletag.pubads().setTargeting('permutive', kvs ? JSON.parse(kvs) : []);
		    console.log('ad targeting permutive kvs: ', kvs);
		  }
		});
		</script>
	

<script type="text/javascript" src="/www/js/ads/gpt_starter.js?1234"></script>
	<script>
		loadGPT();
	</script>

	
		<script type="text/javascript" src="/www/js/ads/ias_gpt_launcher.js?v=20200407113609"></script>
	

	



		
		
	
	
	
		
				
		
		
		
	

	<link rel="canonical" href="https://www.infoworld.com/article/3537168/coding-together-apart-software-development-after-covid-19.html" />
	
	
		
	

	<meta itemprop="url" content="https://www.javaworld.com/article/3537391/coding-together-apart-software-development-after-covid-19.html" />
	<meta name="description" content="Distance collaboration may become standard practice, aided by group collaboration tools " />
	
		
			<meta name="DC.date.issued" content="2020-04-09T03:00-05:00" />
			<meta name="date" content="2020-04-09" />
			
		
		
		
		
	
	
	
	
		
		
		
			
			
				
			
			
			
		
	
	
		
		
			<meta property="og:title" content="Coding together apart: Software development after COVID-19">
		
	
	<meta property="og:description" content="Distance collaboration may become standard practice, aided by group collaboration tools ">	
	
	
		
			<meta property="og:image" content="https://images.idgesg.net/images/article/2019/07/cio_cw_remote_worker_digital_nomad_by_jgalione_gettyimages-626172600_2400x1600-100802371-large.3x2.jpg" />
			<meta property="og:image:width" content="1200" />
			<meta property="og:image:height" content="800" />
			<meta itemprop="image" content="https://images.idgesg.net/images/article/2019/07/cio_cw_remote_worker_digital_nomad_by_jgalione_gettyimages-626172600_2400x1600-100802371-large.3x2.jpg">
			<meta itemprop="thumbnailURl" content="https://images.idgesg.net/images/article/2019/07/cio_cw_remote_worker_digital_nomad_by_jgalione_gettyimages-626172600_2400x1600-100802371-large.3x2.jpg" />
			<link rel="image_src" href="https://images.idgesg.net/images/article/2019/07/cio_cw_remote_worker_digital_nomad_by_jgalione_gettyimages-626172600_2400x1600-100802371-large.3x2.jpg" />
			<meta name="twitter:image" content="https://images.idgesg.net/images/article/2019/07/cio_cw_remote_worker_digital_nomad_by_jgalione_gettyimages-626172600_2400x1600-100802371-large.3x2.jpg" />
		
		
	
	
		
			<meta property="og:type" content="article" />
			
			
			
			
			
			
			
			
			
			<meta name="author" content="James Kobielus">
			
			
			
			
			
		
		 
		
	<meta property="og:site_name" content="JavaWorld" />
	<meta property="fb:app_id" content="196366870381968" />
	
		
			<meta property="og:url" content="https://www.javaworld.com/article/3537391/coding-together-apart-software-development-after-covid-19.html">
		
		
	
	
	<!-- Use Twitter Summary Card with Large Image for articles and videos -->
	
		
				<meta name="twitter:card" content="summary_large_image">
		
		
	

	<meta name="twitter:site" content="@javaworldcom">
	<meta name="twitter:description" content="Distance collaboration may become standard practice, aided by group collaboration tools ">

	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	<meta name="rating" content="General">
	
	<meta name="robots" content="NOODP,NOYDIR" />
	
	
	
	
		<meta name="msvalidate.01" content="04917178B598F0648B9BAD693FEC29A3" />
	
		
	<!-- pagination -->
	
	
	
	
	
	
	
	
	
	
	
		
			<link id="mobile-size" rel="stylesheet" href="/www.idge/css/inline-header-mobile.css?v=20200407113609" />
					
		
		
		<script>
			if (window.matchMedia("(min-width: 768px)").matches) {
				document.getElementById('mobile-size').insertAdjacentHTML('afterend', '<link id="desktop-size" rel="stylesheet" href="/www.idge/css/inline-header.css?v=20200407113609" />');
			}
		</script>
		
		
			
			
				
					<link rel="stylesheet" href="/www.idge.jvw/css/inline-header.css?v=20200407113609" />
				
			
		
	
	
	<!-- css -->
	
		<link rel="stylesheet" href="/www.idge/css/normalize.css" />
	
	
		<link rel="stylesheet" href="/www.idge/css/prettify.css" />
	
	
		
			
			
			
			
				
					
						
						
							<link rel="stylesheet" href="/www/css/article.css?v=20200407113609" />
						
					
					
					
					
			
				
		
		
		
			<link rel="stylesheet" href="/www.idge/css/insider-promo-styles.css?v=20200407113609" />
		
		<link rel="stylesheet" href="/www.idge/css/print.css" media="print" />
		
	
	
		
			
			
				
				
					<link rel="stylesheet" href="/www.idge.jvw/css/article.css?v=20200407113609" />
				
			
		
	
	
	<link rel="stylesheet" href="/www.idge/css/webfonts/ss-social.css" />
	<link rel="stylesheet" href="/www.idge/css/webfonts/ss-standard.css" />
	<!--[if lte IE 8]>  
		<link href="/www.idge/css/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]--> 
	
	

	
		<link href="//fonts.googleapis.com/css?family=PT+Sans:400,700|PT+Sans+Narrow:400,700" rel="stylesheet" type="text/css" />
	
		
	
	
	
	
	
	
	<!--  fav and touch icons -->
	<link rel="shortcut icon" type="image/x-icon" href="/www.idge.jvw/favicon.ico"/>
	<link rel="apple-touch-icon-precomposed" sizes="144x144" href="/www.idge.jvw/touchicon_144.gif" />
	<link rel="apple-touch-icon-precomposed" sizes="114x114" href="/www.idge.jvw/touchicon_114.gif" />
	<link rel="apple-touch-icon-precomposed" sizes="72x72" href="/www.idge.jvw/touchicon_72.gif" />
	<link rel="apple-touch-icon-precomposed" sizes="57x57" href="/www.idge.jvw/touchicon_57.gif" />
	<link rel="apple-touch-icon" href="/www.idge.jvw/images/JVW_logo_300x300.png" />
	
	
	
	
	
		<script>
			$(document).ready(function(){
				if(typeof(IDG.insiderReg.readCookie('nsdr')) !== 'undefined'){
					$('#welcome-message').show();			
					IDG.insiderReg.personalize();
				}else{
					$('.signin-register').show();	
				}
			});
		</script>
   	    
   	    











<script>
var isProd = 'true';

var ocEnabledSite = "false";

var brandCode = "jvw";
var brandName="JavaWorld";
var brandId = "9";
var regDebugLog=false;

// Marketing Channels Preference
var brandIdDemandgen=false;
var brandIdEvents=false;
var brandIdResearch=false;
var brandIdThirdparty=false;
var isEu=false;

// API URL and API key
var regApiUrl='https://api-stage.idgcommunications.net/api/v1/'; // replaced below with property in .properties file
var apiKey="HLyMXLISSW7HAYGgbx2Vb1Gf1OLcGmMG5BcwZ4Vb";

var tokenPrefix='www';
var tokenSuffix='.com/insider/token?';
var brandDomain=".javaworld.com";
var insiderContentType="article";
var notEmptyArticle=false;
var notEmptyMediaResource=false;
var isInsiderPremium=false;
var isResourceInsiderPremium=false;

var ownerIds=["0c99a1d7-c4e7-42a5-910f-a22134d1f98d"];
var campaignId="2a3b7224-f920-41a1-bea6-615aa59ea0f8";
var assetId="697422d1-7acb-40f6-be13-0e67329bc9ec";
var placementId="2d44d74a-e883-4d18-ada8-b2f0e61a1d90";
var clientCompany="IDG Communications US";
var businessUnit="IDG Communications US";

</script>
<script>
function getOneRegIDs(countryCode) {
	let obj = {};
	if (countryCode === 'uk') {
		obj={
			brandId: "",
			ownerIds: ["f3efa90a-2330-4d42-bbc7-f7f96eb0f3db"],
			campaignId: "a465ea50-b639-4f98-ad1c-bc0b8c80e3c9",
			assetId: "5ab2586f-3bb6-4ad3-84e2-bdd230980e88",
			placementId: "77a1e657-f12c-4f7c-b685-6a9da2eb25d6",
			businessUnit: "IDG UK"
		}
	}
	if (countryCode === 'africa') {
		obj={
			brandId: "",
			ownerIds: ["02b2821f-2118-442a-9f16-df416847133f"],
			campaignId: "89c3e1d5-f5c6-4934-b683-751414ffe5b7",
			assetId: "8848c7a9-7ed0-4119-ba20-e9f06869928c",
			placementId: "7d80c555-1916-4c7b-bd56-dd10767d83b8",
			businessUnit: "IDG Connect"
		}
	}
	if (countryCode === "asean") {
		obj={
			brandId: "",
			ownerIds: ["02b2821f-2118-442a-9f16-df416847133f"],
			campaignId: "77f2f4c1-c3f3-4796-be52-d44c982bc824",
			assetId: "59fdb971-7da7-48a0-bd6d-e52db502b83f",
			placementId: "b1f22813-ff0d-42d8-90d9-c1fbd47b3424",
			businessUnit: "IDG Connect"
		}
	}
	if (countryCode === 'mideast' || countryCode === 'middle-east') {
		obj={
			brandId: "",
			ownerIds: ["02b2821f-2118-442a-9f16-df416847133f"],
			campaignId: "2e8ce243-c3b2-417b-a893-ba4fb496776b",
			assetId: "511c10e5-69b7-4a0d-861f-99b048e129f8",
			placementId: "59a18947-cead-4faf-8d94-2fd9bba346a4",
			businessUnit: "IDG Connect"
		}
	}
	if (countryCode === 'in') {
		obj={
			brandId: "",
			ownerIds: ["b6973a30-3c15-4667-9165-e206b8876adc"],
			campaignId: "cf43ee09-cb17-4704-aec9-3c3faefee27f",
			assetId: "f411310d-fa2f-4518-93c9-e08962d736b2",
			placementId: "6813ef80-eb35-4d48-94f0-4b64c406ca52",
			businessUnit: "IDG India"
		}
	}
	if (countryCode === 'au') {
		obj={
			brandId: "",
			ownerIds: ["dfcefb71-7919-4a1b-9b77-6a1c05314109"],
			campaignId: "371454ac-79e0-4bef-9a02-6ba52dc58e51",
			assetId: "fe648fe7-937f-4f7d-8822-2125efbbde26",
			placementId: "d6d61fb9-333b-4721-ae7a-3b069224c628",
			businessUnit: "IDG Australia"
		}
	}
	if (countryCode === 'nz') {
		obj={
			brandId: "",
			ownerIds: ["dfcefb71-7919-4a1b-9b77-6a1c05314109"],
			campaignId: "371454ac-79e0-4bef-9a02-6ba52dc58e51",
			assetId: "fe648fe7-937f-4f7d-8822-2125efbbde26",
			placementId: "d6d61fb9-333b-4721-ae7a-3b069224c628",
			businessUnit: "IDG New Zealand"
		}
	}

	return obj;
}
</script>

<script>
if (countryCode !== "" && countryCode !== "us") {
	clientCompany="IDG Communications";
	
	let oneRegIDs = getOneRegIDs(countryCode);
	
	brandId = oneRegIDs.brandId;
	ownerIds = oneRegIDs.ownerIds;
	campaignId = oneRegIDs.campaignId;
	assetId = oneRegIDs.assetId;
	placementId = oneRegIDs.placementId;
	businessUnit = oneRegIDs.businessUnit;
}
if (countryCode == 'nl') {
	brandId = "";
	ownerIds=["995bcc26-0146-4b23-a843-e4a9dab15ab2"];
	campaignId="9c573c52-3bb0-406c-8925-8ae3610d4b46";
	assetId="d8343ec7-7fd4-4232-b227-62d98ea9525b";
	placementId="3dbe27d8-52a6-4b42-b07a-cdd7dc6f5b97";
	clientCompany="IDG Communications";
	businessUnit="IDG Benelux";
}
if (countryCode == 'nl') {
	brandId = "";
	ownerIds=["995bcc26-0146-4b23-a843-e4a9dab15ab2"];
	campaignId="9c573c52-3bb0-406c-8925-8ae3610d4b46";
	assetId="d8343ec7-7fd4-4232-b227-62d98ea9525b";
	placementId="3dbe27d8-52a6-4b42-b07a-cdd7dc6f5b97";
	clientCompany="IDG Communications";
	businessUnit="IDG Netherlands";
}


	regApiUrl="https://lqxgcyk808.execute-api.us-east-1.amazonaws.com/prod_h2/api/v1/";



	regDebugLog=false;



	tokenPrefix="http://www";



	tokenSuffix="/insider/token";





	notEmptyArticle=true;


	
		isInsiderPremium=true;
	



 

</script>














	



	
	
	
















	

	
	<script src="/www/js/ads/ad.js"></script>
	
	<script>var oneRegPlacementID = "";</script>
	
	<script>
		const articlePaidAccess = [];
	</script>
	
	
	
		
			
				
			
			
			
			
			
			
			
			

				
			
		
		
		
	
	
	
	
	
	
	





	
		
	
		
	
	





		
		  
		
		
		
		

	
	
	
	
	

	
	  	 
	    
	    
	 
	 
	
	
	
	
	
		
	
	
	
	
	
	
		
		
		
	

	<script>
	var supMontMods = false;
	</script>
	
	
	
	
		
		
		
		
			
				
				
			











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #2806 blox4.simple  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
					
						
					
				
				
			
		















	
		
		
	


	


		
	
	
	
	
	
	
	
	
	
	
	
		
			
				
				
				
					
				
			
			
			
			
		
		
		
	
	
	
	
	
	
	
	

	
	
	
	
	
		<script>
		window.ntvConfig = window.ntvConfig || {} ;
		window.ntvConfig.keyValues = window.ntvConfig.keyValues || {};
		var segs = localStorage.getItem('_pnativo');
		if (segs) {
		  window.ntvConfig.keyValues.permutive = JSON.parse(segs).join(",");
		}
		</script>
	
	
	
	
		<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
	

	
	
	
	<script type="text/javascript">
		var prodNames = '';
		var prodManufacturers = '';
		var prodCategories = '';
		var prodVendors = '';
	</script>
	
	
	
		
		<script src="/www/js/insider/insider_reg_api.js?v=20200407113609"></script>
	
	
	
	<script>
	var insiderSignedIn = document.cookie.indexOf("nsdr") > -1; //check if Insider cookie exists
	var idg_uuid = $.cookie('idg_uuid') || '';
	
	var dlJobFunction = '';
	var dlJobPosition = '';
	var dlIndustry = '';
	
	if (insiderSignedIn) {
		var insiderToken = IDG.insiderReg.readCookie("nsdr");
		var tokens = IDG.insiderReg.readCookieProperty(insiderToken);
		if (!(tokens['jobPosition']===undefined)) {
			//dlJobPosition = tokens['jobPosition'];
			//OC-1647 change to indicate this data was remove
			dlJobPosition = "removed";
		}
		if (!(tokens['jobFunction']===undefined)) {
			dlJobFunction = tokens['jobFunction'];
		}
		if (!(tokens['industry']===undefined)) {
			dlIndustry = tokens['industry'];
		}
	}
	
	insiderSignedIn = insiderSignedIn.toString(); //per Infotrust this needs to be a string, not a boolean
	
	var sincePublished = '0 days';
	sincePublished = sincePublished.split(" ")[0];
	
	//get edition from countryCode
	var edition = '';
	if (typeof countryCode !== 'undefined' && countryCode !== "") {//should be defined in locales-editions.jsp if brand has editions
		edition = countryCode.toLowerCase();
	}
	
	dataLayer.push({
		'articleId': '3537391',
		'articleDisplayId':'1',
		'articleHasVideo':'false',
		'articleLocale': 'global',
		'articleTitle': 'Coding together apart: Software development after COVID-19',
		'articleType': 'Analysis',
		'audience':'enterprise',
		'author':'James Kobielus',
		'blogName':'',
		'brandpost': 'false',
		'categoryIdAll': '3646, 3871, 3469, 3258',
		'categoryIdList':'3646,3871,3469,3258',
		'categoryIdPrimary': '3646',
		'contentStrategy': '',
		'contentType':'analysis',
		'datePublished':'2020-04-09',
		'dateUpdated':'2020-04-09',
		'daysSincePublished':"0",
		'daysSinceUpdated':'0',
		'de_normalized_company_name':$.cookie('de_normalized_company_name'),
		'displayType':'article',
		'edition':edition,
		'environment':'production',
		'ga_enabled':'true',
		'gaTrackingId':'UA-300704-19',
		'geolocEnabled':'true',
		'goldenTaxonomyIdAll': '241, 683, 264, 585',
		'goldenTaxonomyIdPrimary': '241',
		'goldenTaxonomyIdList': '683,264,585',
		'industry': dlIndustry,
		'insiderSignedIn':insiderSignedIn,
		'ip_normalized_company_name':$.cookie('ip_normalized_company_name'),
		'isBlog':'false',
		'isInsiderContent':'true',
		'isICN': 'false',
		'jobFunction': dlJobFunction,
		'jobPosition': dlJobPosition,
		'oneRegPlacementID':oneRegPlacementID,
		'pageNumber':'1',
		'platform':'Web',
		'podcastSponsored': 'false',
		'primaryCategory': 'software development',
		'ancestorGoldenCategories': '',
		'primaryCategoryAll': 'software development, technology industry, java, careers',
		'primaryCategoryList': 'technology industry,java,careers',
		'primaryAncestorCategoryList': 'software development',
		'prodCategories':prodCategories.slice('|', -1),
		'prodManufacturers':prodManufacturers.slice('|', -1),
		'prodNames':prodNames.slice('|', -1),
		'prodVendors':prodVendors.slice('|', -1),
		'property': 'javaworld',
		'propertyCountry':'US',
		'purchaseIntent':'awareness',
		'skimlinksId':'',
		'source':'infoworld',
		'sponsorName':'',
		'suppressMonetization': supMontMods.toString(),
		'tags': 'covid-19',
		'userId':idg_uuid,
		'videoAutoplay':'false',
		'youtubeId':''
	});
	</script>

	
	
	










<script>
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var adBlockStatus = 'false';
	
	//look for variable set in ad.js
	if (window.canRunAds === undefined) {
		adBlockStatus = 'true';
	} else {
		adBlockStatus = 'false';
	}
	
	dataLayer.push({
		'adBlockStatus': adBlockStatus
	});
</script>





	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-WR6LD2P"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-WR6LD2P');</script>
	<!-- End Google Tag Manager -->

	
	
	
		<script>
			var numberFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "number") {
			    return dataLayer[0][property];
			  }
			  return null;
			};
			
			var stringFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "string") {
			    return dataLayer[0][property];
			  }
			  return "";
			};
		</script>
	

	

	
		










<script>
// IDGMPM-16419 - updated in IDGMPM-16933
	!function(n,e,o,r,i){if(!e){e=e||{},window.permutive=e,e.q=[],e.config=i||{},e.config.projectId=o,e.config.apiKey=r,e.config.environment=e.config.environment||"production";for(var t=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],c=0;c<t.length;c++){var f=t[c];e[f]=function(n){return function(){var o=Array.prototype.slice.call(arguments,0);e.q.push({functionName:n,arguments:o})}}(f)}}}(document,window.permutive,"f5b3be27-f789-4ef1-8867-37c67da5b361","84c7e805-5ce9-41f4-b988-3529488bab1c",{});
	  permutive.addon('web', {
	    page: {
	      type: stringFromDataLayer('displayType'),
	      language: 'en',
	      tags: stringFromDataLayer('tags').split(","),
	      audience: stringFromDataLayer('audience'),
	      description: 'Distance collaboration may become standard practice, aided by group collaboration tools ',
	      
	      article: {
	        authors: stringFromDataLayer('author').split(","),
	        description: 'Distance collaboration may become standard practice, aided by group collaboration tools ',
	        id: stringFromDataLayer('articleId'),
	        isInsiderContent: (stringFromDataLayer('isInsiderContent') == "true"),
	        modifiedAt: "2020-04-09T10:29:02Z",
	        publishedAt: "2020-04-09T10:29:02Z",
	        source: stringFromDataLayer('source'),
	        title: stringFromDataLayer('articleTitle'),
	        type: stringFromDataLayer('articleType'),
	        purchaseIntent: stringFromDataLayer('purchaseIntent')
	      },
	      
 		  	      
	      gTax: {
	        primaryIds: [241,],
	        secondaryIds: [683,264,585,241]
	      },	      
	      tax: {
	    	  primaryCategories: stringFromDataLayer('ancestorGoldenCategories').length > 0 ? stringFromDataLayer('ancestorGoldenCategories').split(",").concat(stringFromDataLayer('primaryCategory')) : [stringFromDataLayer('primaryCategory')] ,
	          secondaryCategories: stringFromDataLayer('primaryAncestorCategoryList').length > 0 ? stringFromDataLayer('primaryCategoryList').split(",").concat(stringFromDataLayer('primaryAncestorCategoryList').split(",")) : stringFromDataLayer('primaryCategoryList').split(",")
	      },
	      
	      ads: {
	        adblocker: (adBlockStatus == "true"), //detected further up the page
	        enabled: true
	      }	     
	    }
	  });

	  dlJobPosition = dlJobPosition || null;
	  dlIndustry = dlIndustry || null;

	  if (dlJobPosition !== '' || dlIndustry !== '' || stringFromDataLayer('userId') !== '') {
		  if (stringFromDataLayer('userId') !== '') {
				var userData = {};

				var hermesAttrs = {
					"companySize" : "543ea0bd-604a-4011-99e7-806fc8979b5e",
					"country" : "ea76d652-29bd-4a6c-ae50-a5d08ea28c5e",
				};
				var userKeys = Object.keys(hermesAttrs);

				$.ajax({
					type: "get",
				    crossDomain: true,
					url: "https://lqxgcyk808.execute-api.us-east-1.amazonaws.com/prod_h2/api/v1/profiles/" + idg_uuid,
					dataType: "json",
					data: {}, 
					headers : {
						"Content-Type": "application/x-www-form-urlencoded",
						"x-api-key":"HLyMXLISSW7HAYGgbx2Vb1Gf1OLcGmMG5BcwZ4Vb"
					}
				}).done(function(responseData){ 
					userKeys.forEach(function(key) {
						if (typeof(responseData.attrs[hermesAttrs[key]].option_label) !== "undefined") { 
							userData[key] = responseData.attrs[hermesAttrs[key]].option_label;
						}
						else { 
							userData[key] = responseData.attrs[hermesAttrs[key]].value;
						}
					});

					window.permutive.track('User', {
					  companySize: userData['companySize'],
					  country: userData['country'],
					  id: (stringFromDataLayer('userId') !== "" ? stringFromDataLayer('userId') : null),
					  jobIndustry: (dlIndustry !== "" ? dlIndustry : null),
					  jobPosition: (dlJobPosition !== "" ? dlJobPosition : null),
					  loggedIn: (stringFromDataLayer('insiderSignedIn') == 'true')
					})
					
					
				}).fail(function(data){
					//console.log("Error retrieving data: " + data.responseJSON.error);
				});  

			}
			else {
				window.permutive.track('User', {
				  companySize: null,
				  country: null,
				  id: (stringFromDataLayer('userId') !== "" ? stringFromDataLayer('userId') : null),
				  jobIndustry: (dlIndustry !== "" ? dlIndustry : null),
				  jobPosition: (dlJobPosition !== "" ? dlJobPosition : null),
				  loggedIn: (stringFromDataLayer('insiderSignedIn') == 'true')
				});
			}
	  }
	
	  //product js vars defined in document-head	  
	  if (prodNames !== '' || prodManufacturers !== '' || prodCategories !== '' || prodVendors !== '') {
		  window.permutive.track('Product', {
			  names: stringFromDataLayer('prodNames').split("|"),
			  categories: stringFromDataLayer('prodCategories').split("|"),
			  manufacturers: stringFromDataLayer('prodManufacturers').split("|"),
			  vendors: stringFromDataLayer('prodVendors').split("|")
		});

	  }
		 

</script>

<script>
	$.ajax({
		url: "https://cdn.permutive.com/f5b3be27-f789-4ef1-8867-37c67da5b361-web.js",
	  	dataType: "script",
	  	cache: true, // default is false
	  	async: true // default is true
	});
</script>
	
	
	
	
	

	

	
	
	
</head>



	<body id="article3537391" class="article javaworld">
		
			
			
		
		











	
	
		
		
		
		<!-- BEGIN PAGE HEADER -->
		<header id="banner" >
			
			
			
			
			
			
			
		    
		    
		    
		    	
		    	<script>
		    	if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
					$('.main-header').insertBefore($('#banner .ad'));
		    	}
				</script>
				
				
				<div class="topics-wrap">
				    <section class="topics">
				        <nav id="scrollable">
					        
								
									
									
										
									
								











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #670 blox4.raw_link_list  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
					
						
					
				
				
			
		













	
		
		
			
		
	
	
	
	<ul>
		
		<li class="header">Trending<span class="colon">:</span></li>
		
		
			
				<li><a class="edition-link-url" href="/category/java-app-dev/ " > Java News & Reviews</a></li>
			
		
			
				<li><a class="edition-link-url" href="/blog/what-is-java/" >What Is: Java</a></li>
			
		
			
				<li><a class="edition-link-url" href="/blog/java-101/" >Java 101: Learn Java</a></li>
			
		
			
				<li><a class="edition-link-url" href="/blog/java-challengers/" >Java Challengers</a></li>
			
		
			
				<li><a class="edition-link-url" href="/blog/java-tips/" >Java Tips</a></li>
			
		
			
				<li><a class="edition-link-url" href="/blog/open-source-java-projects/" >Open Source Java Tutorials</a></li>
			
		
			
				<li><a class="edition-link-url" href="/category/android/" >Java Android</a></li>
			
		
	</ul>

	


							
						</nav>
				        
				        <div class="fading-gradient"></div>
				        
				        
				           
					        
					        <nav class="tools">
					        	<ul class="user">
				                     
				                     	<li class="search-icon"><a href="#search" id="search-btn"><i class="ss-icon">Search</i></a></li>
				                     
				                 </ul>
				                 <ul class="social">
									














				                 </ul>
				             </nav>
				             
			             
				    </section>
			    </div>
			    
			    
		        	 <div id="sticky-anchor"></div>
		        
			    <section id="sticky-head" class="main no-stick-important">
			        <div class="wrapper">
			            <div class="masthead">
			                
			                <button><i class="ss-icon ss-rows"></i></button>
			                
			                <a href="/"><span class="ir logo">javaworld</span></a>
			            	<!--
			            	<img class="print-only" src="/www.idge.jvw/images/javaworld-logo-print.png">
			            	-->
			            	
			            	<img class="print-only" src="//idge.staticworld.net/jvw/javaworld-logo-print.png">
			            	
			            </div>
			            <div id="reading-tools-wrapper">
		
			                
			                <nav class="tools">
			                    
			                    <ul class="user">
			                    	
			                    	
			                    	
			                    	
			                        
			                    </ul>
			                </nav>
			            </div>
			            
			            
			            	<div class="insider-signin">
			            	
			            		<span class="signin-register">
			            			<a href="/about/learn-about-insider.html"><span class="insider"></span></a> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-signin')" class="js-open-modal signin" data-modal-id="insider-popup">Sign In</a> <span class="divider">|</span> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-form-short')" class="js-open-modal register" data-modal-id="insider-popup">Register</a>
			            		</span>
			            	
			            		<div id="welcome-message" class="insider-list">
				                    <div id="insider-selector">
				                        <div id="insider-welcome" class="label"></div>
				                        
				                        <div class="stories">
				                        	
				                        	<div class="personalization">Hi<span id="person-first-name"></span>! Here are the latest Insider stories.</div>
				                        	
				                        	











	
	
	
	
	
	
	
	
	
	
































































	<ul>
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3534768/java-15-starts-to-take-shape.html">JDK 15: The new features in Java 15</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3533429/3-steps-to-applying-agile-methodologies-in-it-operations.html">3 steps to applying agile methodologies in IT operations</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3532452/a-hands-on-look-at-quantum-computing.html">A hands-on look at quantum computing</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3527416/5-ways-agile-teams-meet-sprint-commitments.html">5 ways agile teams meet sprint commitments </a></li>
				
				
			
		
	</ul>




											
											<div class="sign-out-link">
												<a class="more-insider" href="/insider/">More Insider</a>
												<a class="sign-out" href="javascript://" onclick="IDG.insiderReg.logout()">Sign Out</a>
											</div>
										</div>
										
				                    </div>
				                </div>
				         
			            	</div>
			            	<script>
			            		$('.signin-register').hide();	
			            		$('#welcome-message').hide();
			            	</script>
			            	
			            
			            
			        </div>
			    </section>
			    <section class="tools-expand  ">
			        
			        
			        
			        
			        	
			        	
			        		
					        <form class="search" id="search-form" action="/search">
					            <label for="search-box">Search for</label>
								<input type="text" name="query" id="banner-search-term" value="" class="searchbox-input-class"/>
					            <input type="submit" id="banner-search-submit" value="Go" />
					            <input type="hidden" name="contentType" value="article,resource" />
					            <div class="search-suggest">Suggestions for you</div>
					        </form>
					    
					
			        <div class="user">
			            <form>
			                <label for="login-email">Insider email</label> <input id="login-email" type="text" />
			            </form>
			        </div>
			        
			    </section>
			    
			    
			    
				
				
		    		<div id="sticky-anchor-nav"></div>
		    	
		    	
			    <nav id="sticky-nav" class="main">
			    	<ul class="topnav">
						
						
							
			        		<li>
			        		
			        			
			        				<a href="/category/core-java/" class="hasChildren">Core Java<span class="ss-icon ss-navigatedown"></span></a>
			            		
			            		
			            	
			            		
			            		
				            		<ul class="subnav">
				                		<li><a href="/category/core-java/">All Core Java</a></li>
				            			
				            			
				            				<li><a href="/category/agile-development/">Agile Development</a></li>
				            			
				            			
				            				<li><a href="/category/careers/">Careers</a></li>
				            			
				            			
				            				<li><a href="/category/java-concurrency/">Concurrency</a></li>
				            			
				            			
				            				<li><a href="/category/java/">Java</a></li>
				            			
				            			
				            				<li><a href="/category/java-platform/">Java Platform</a></li>
				            			
				            			
				            				<li><a href="/category/security/">Security</a></li>
				            			
				            			
				            				<li><a href="/category/application-testing/">Software Testing</a></li>
				            			
				            		</ul>
				            	
			        		</li>
						
						
							
			        		<li>
			        		
			        			
			        				<a href="/category/enterprise-java/" class="hasChildren">Enterprise Java<span class="ss-icon ss-navigatedown"></span></a>
			            		
			            		
			            	
			            		
			            		
				            		<ul class="subnav">
				                		<li><a href="/category/enterprise-java/">All Enterprise Java</a></li>
				            			
				            			
				            				<li><a href="/category/apis/">APIs</a></li>
				            			
				            			
				            				<li><a href="/category/analytics/">Analytics</a></li>
				            			
				            			
				            				<li><a href="/category/big-data/">Big Data</a></li>
				            			
				            			
				            				<li><a href="/category/cloud-computing/">Cloud Computing</a></li>
				            			
				            			
				            				<li><a href="/category/development-tools/">Development Tools</a></li>
				            			
				            			
				            				<li><a href="/category/open-source-tools/">Open Source</a></li>
				            			
				            			
				            				<li><a href="/category/scripting-jvm-languages/">Scripting and JVM Languages</a></li>
				            			
				            			
				            				<li><a href="/category/application-development/">Software Development</a></li>
				            			
				            			
				            				<li><a href="/category/web-development/">Web Development</a></li>
				            			
				            		</ul>
				            	
			        		</li>
						
						
							
			        		<li>
			        		
			        			
			        				<a href="/category/learn-java/" class="hasChildren">Learn Java<span class="ss-icon ss-navigatedown"></span></a>
			            		
			            		
			            	
			            		
			            		
				            		<ul class="subnav">
				                		<li><a href="/category/learn-java/">All Learn Java</a></li>
				            			
				            			
				            				<li><a href="/category/design-patterns/">Design Patterns</a></li>
				            			
				            		</ul>
				            	
			        		</li>
						
						
							
			        		<li>
			        		
			        			
			        				<a href="/category/mobile-java/" class="hasChildren">Mobile Java<span class="ss-icon ss-navigatedown"></span></a>
			            		
			            		
			            	
			            		
			            		
				            		<ul class="subnav">
				                		<li><a href="/category/mobile-java/">All Mobile Java</a></li>
				            			
				            			
				            				<li><a href="/category/android/">Android</a></li>
				            			
				            			
				            				<li><a href="/category/ios/">iOS</a></li>
				            			
				            		</ul>
				            	
			        		</li>
						
					</ul>
					
			    		<ul class="secondary">
		           			
		           			










<li><a href="/news/">News</a></li>
<li><a href="/feature/">Features</a></li>
<li><a href="/howto/">How-Tos</a></li>
<li><a href="/blogs/">Blogs</a></li>
<li><a href="/resources/">Resources/White Papers</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
		           			
			    		</ul>
			    	
				</nav>
				
			
			
			
			
			

			
			
				<script>
		    	if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
					$('div.insider-signin').prependTo('section.topics nav.tools');
		    	}
				</script>
			
		    
				<script>
				$(document).ready(function(){
					if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
						$("nav ul li a.hasChildren").attr("href", "#").addClass('notMobile');
						$('nav#sticky-nav ul.secondary').addClass('topnav');
					}
					if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
						$("nav#sticky-nav > ul").switchClass("topnav", "primary");
					}
				});
				</script>
			
			
				
		    	<script>
		    	if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
					$('#sticky-anchor, section.main, section.topics, section.tools-expand, #sticky-anchor-nav, nav.main').insertBefore($('#banner .ad'));
					$(document).ready(function(){
						$('#banner section.tools-expand').addClass('top-margin');
					});
		    	}
				</script>
				
			
			
			
		</header>
		
		
		
		<script>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</script>
		
		




	<div id="insider-popup" class="modal-box ">
	
		<div class="insider-modal-wrapper">
	  
			<div class="modal-header-title">
				<div class="modal-banner-insider"><span class="insider"></span></div>
		    	<div class="modal-close close">×</div>
		  	</div>
		  	
		  	<div class="modal-body">
		  		
		  			
						<script>
$(document).ready(function(){
	$('a[data-link]').click(function() {
		
		  //get this link's dataLink value
		  var dataLink = $(this).attr('data-link');

		  //select the div with the same value
		  var toKeep = 'div[data-link="'+dataLink+'"]';
	
		  //select data-link divs that are not the above div
		  $('div[data-link]').not(toKeep).hide();
		  
		  if($(this).hasClass('link-transition')){
			  $(toKeep).fadeIn(800);
		  } else {
			  $(toKeep).show();
		  }
	
		  //prevent location change
		  return false;
	});
	

});
</script>

					
					
				
		  	</div>
		  	
		  	<div class="modal-footer">
		    	<div class="modal-close close-btn">Close</div>
		  	</div>
		</div>
	  	
	</div>

	<script>
		$(document).ready(function(){

			var appendthis =  ("<div class='modal-overlay modal-close'></div>");
			if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
				$('.modal-box').css({
					//top: ($(window).height() - $(".modal-box").outerHeight()) / 2,
					top: 10,
					left: 0
				});
			}
			
			
			if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
				$('.modal-box').height($(document).height());
				$('.modal-box').css('top','0');
			}
			
			var userAg = navigator.userAgent;

			$('a[data-modal-id]').click(function(e) {
				e.preventDefault();
				$('body').append(appendthis);
				$('.modal-overlay').fadeTo(500, 0.9);
				$('.modal-overlay').height($(document).height());
				var modalBox = $(this).attr('data-modal-id');
				
				if ($(".modal-box").hasClass('triggered') || (userAg.indexOf("Firefox")!=-1)) {
					$('#'+modalBox).fadeIn($(this).data()); // triggered by something other than onclick of link such as scroll to point in window
				} else {
					// IDGMPM-16177
					//if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
						$('#'+modalBox).toggle('slide', {direction: 'up'}, 800);
					//} else {
				   // 	$('#'+modalBox).toggle('slide', {direction: 'left'}, 600);
					//}
				}

				if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
					$("html, body").animate({
			            scrollTop: 0
			        }, 700);
			        
			        
			        $('a.btn.continue-on').click(function() {
			        	$('html, body').animate({
			        		scrollTop: 0
			        	}, 500);
			        });
			        
			        return false;
			        
				}
				if (navigator.userAgent.match(/(iPad)/)) {
					$("html, body").animate({
			            scrollTop: 0
			        }, 500);
				}
			});
		  
		  
			$(".modal-close, .modal-overlay").click(function() {
				$('.select2-drop').css('display','none');
				$(".modal-overlay").fadeOut(500, function() {
					$(".modal-overlay").remove();
				});
				if ($(".modal-box").hasClass('triggered') || (userAg.indexOf("Firefox")!=-1)) {
					$(".modal-box").fadeOut(500);
				} else {
					// IDGMPM-16177
					//if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
						$('.modal-box').toggle('slide', {direction: 'up'}, 800);
					//} else {
					//	$('.modal-box').toggle('slide', {direction: 'left'}, 600);
					//}
				}
				// remove the stylesheet added in header.jsp
				setTimeout(function(){
					$("link.oc-modal").remove();
					$("script.oc-modal").remove();
				}, 1000);
			});
		
		});
	</script>

		
		
		
		
		
		<!-- END PAGE HEADER -->




		
		













<div id="page-wrapper" class="page-wrapper">
	
	













<div id="skinAdTarget"></div>


			
		











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	





	
	
 	


	
	<section role="main" itemscope itemtype="http://schema.org/Article">
	
		
		
		

		<article itemscope itemtype="http://schema.org/Article"  >

		















<!-- Events Header -->

 
 
	
		
		
		
		
		
			
				
   				
   					    			
		
	
	
	
	
	

 
 
 
 
  
   
  
  
 
 












	
	
	
	
	
	
	
	
	
	
	
	
	
	
	


<!-- //end Events Header -->


	
	
	
	
	
	
		
	



	
		
	
	
		


































<script src="/www/js/date-time-moments.js"></script>


	
	
		<script>
		// non-edition sites
		$(document).ready(function() {
			var fullDate = "2020-04-09T03:00-0700";
			var dateFormat = "MMM D, YYYY h:mm a z";
			timeDate = moment(fullDate).tz('America/Los_Angeles').format(dateFormat); // 12 hour format
			document.querySelector(".format-date").textContent = timeDate;
		});
		</script>
	



















	
			
















<header class='cat'>

	
	
	
	
	
	
	
	
	<nav class="breadcrumbs horiz">
		<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
			<li><a class="edition-link-url" href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
			
				
				
					<li><a class="edition-link-url primary-cat-url" href="/category/application-development/" itemprop="url"><span class="primary-cat-name" itemprop="title">Software Development</span></a></li>
				
				
			
		</ul>
	</nav>
	
	
	
	
	
	
	
	
	
	
		
		
			<div class="category"><span class="insider"></span><a class="edition-link-url" href="/analysis" itemprop="genre">Analysis</a></div>
		
	
	

	<h1 itemprop="headline">Coding together apart: Software development after COVID-19</h1>
	
	
	
	
		<section class="deck viewability">
			<h3 itemprop="description">Distance collaboration may become standard practice, aided by group collaboration tools </h3>
		</section>
	
	
	
	
	
	
	
	
			<div class="cat-social">
				
					
				















 



	

				

	
	
		
		
	



	
	


	


<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">

	
		<li class="sosh">
			<a data-socialsite="Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3537391%2Fcoding-together-apart-software-development-after-covid-19.html" target="_blank">
				<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg" />
			</a>
		</li>	
	<li class="sosh">
		<a data-socialsite="Twitter" class="twit-hand" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3537391%2Fcoding-together-apart-software-development-after-covid-19.html&via=javaworldcom&text=Coding+together+apart%3A+Software+development+after+COVID-19" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg" />
		</a>
	</li>
	<li class="sosh">
		<a data-socialsite="Linkedin" href="http://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3537391%2Fcoding-together-apart-software-development-after-covid-19.html&title=Coding+together+apart%3A+Software+development+after+COVID-19" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/linkedin.svg" />
		</a>
	</li>	
	<li class="sosh hide">
			<a data-socialsite="Reddit" href="http://reddit.com/submit?url=https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3537391%2Fcoding-together-apart-software-development-after-covid-19.html&title=Coding+together+apart%3A+Software+development+after+COVID-19" target="_blank">
				<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg" />
			</a>
	</li>	
	<li class="sosh hide">
		<a href="mailto:?Subject=Coding together apart: Software development after COVID-19&Body=Check%20out%20this%20article%20from%20JavaWorld%3A%20https%3A%2F%2Fwww.javaworld.com%2Farticle%2F3537391%2Fcoding-together-apart-software-development-after-covid-19.html" target="_blank" rel="nofollow" id="email-icon">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg" />	
		</a>
	</li>
	<li class="sosh hide print">
		<a href="javascript:window.print();">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg" />
		</a>
	</li>
	<li class="more">
		<div class="more-icon" onclick="document.getElementById('share-tool').className = 'expand';"></div>
	</li>




</ul>
</div>

<script type="text/javascript">
$(document).ready(function() {
	if (twitterHandle != "") {
		$("a[href*=via]").attr("href", function(_, href) {
			  return href.replace(/via=javaworldcom/, "via="+twitterHandle);
		});
	}
	
	//Add Social Share Event Tag in GTM - IDGMPM-17271
	$("a[data-socialsite]").click(function() {
		var dataLayer = window.dataLayer = window.dataLayer || [];
		dataLayer.push({
			'event': 'socialShare', 
		  	'eventCategory': 'Social Share',
		  	'eventAction': $(this).attr("data-socialsite"), 
		  	'eventLabel': window.document.title
		});
		
	});
});
</script>

<script type="text/javascript">
var isValidEmailAddress = isValidEmailAddress || function(emailAddress) {
    var pattern = new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);
    return pattern.test(emailAddress);
};
function encodeQueryData(params) {
	var ret = [];
	for (var paramKey in params) {
		ret.push(encodeURIComponent(paramKey) + "=" + encodeURIComponent(params[paramKey]));
	}
	return ret.join("&");
}
</script>

			</div>
	
	
	

	
		
			
				
				<div class="cat byline vcard author with-image">		
					<div class="byline-wrapper">
						<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
							
						
							
							
							
							
						
















<a href="/author/James-Kobielus/" rel="author" title="James Kobielus"><img  class="bylineImage  imgId100796868 " src="https://images.idgesg.net/images/article/2019/05/jameskobielus_crop-100796868-byline.jpg" width="34" width="34" alt="James Kobielus" itemprop="image" /></a>

						
							
								
							
















<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/James-Kobielus/"><span itemprop="name">James Kobielus</span></a></span>
						</p>
						<p class="dateline">
						
							Contributor, 
								
									
								












<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name"><a href="http://www.infoworld.com/" rel="nofollow" target="_blank">InfoWorld</a></span><meta itemprop="logo" content="https://www.javaworld.com/www.idge.jvw/images/JVW_logo_300x300.png"/></span> <span class="divider break">|</span>
							
	
							<span class="pub-date" class='break-date' itemprop="datePublished" 
							    content="2020-04-09T03:00-0700"><span class="format-date"></span>
								
							</span>
						</p>
					</div>
				</div>
			
		
	
	
		
	
	
		
			<div class="ad viewability" id="viewabilityAdContainer">
				<div id="viewabilityAdUnit">
					
						
					





















	

		
			
			
			
			
			
			
				<div id="topleaderboard" class=" ad-container test">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				
					IDG.GPT.addDisplayedAd("topleaderboard", "true");
					$('#topleaderboard').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: topleaderboard - [971 1115]");
                    
				
				});
				</script>
			
		
	
 	
 
 
				</div>
			</div>
			
		
	
	
	
	
	
</header>




	<div class="constrain-970">
		
		
		
			<div class="insider-snippet-only">
		
		
			
				<div class="lede-container">
					
					
					
						
						
							
				                
				                	
				                	
				                
				                
								
								
								
							
							
							
							
							<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
								<meta itemprop="representativeOfPage" content="1" />
								<meta itemprop="height" content="800" />
								<meta itemprop="width" content="1200" />
					    		
					    		<img data-original="https://images.idgesg.net/images/article/2019/07/cio_cw_remote_worker_digital_nomad_by_jgalione_gettyimages-626172600_2400x1600-100802371-large.jpg" class="lazy" loading="lazy" alt="Coding together apart: Software development after COVID-19" itemprop="contentUrl" itemprop="url" />
					    		
					    		<figcaption>
					    			
					    			
					    				<span class="credit" itemprop="copyrightHolder">
					    					
							    				
							    				JGalione / Getty Images
						    				
				
							    			
							    				
							    				
							    				
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
							    				
							    				
												
											
									
										</span>
					    			
									
					    		</figcaption>
							</figure>
							
				
						
						
					
				</div>
			
			
		
			</div>
		
	



<section class="epo cat-narrow" id="drr-top-ad">

	
	
	
	
	
	
		<div class="ad top-ad">
	
		
		
			
				
					
					
						
					
				
				
				
			





















	

		
			
			
			
			
			
			
				<div id="topimu" class="adunit ad-container test">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				if($(window).width() >= 930) {
					IDG.GPT.addDisplayedAd("topimu", "true");
					$('#topimu').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: topimu - [971 1115]");
                    
				}
				});
				</script>
			
		
	
 	
 
 
		
	
</div>
	
	
	
	
	
	
	
	
	
</section>

</div>







<div class="constrain-970">
	
</div>




<script src="/www/js/deal-modules.js"></script>

		
		



		<section class="bodee">

			
				
				
					












	
		





















<style>
	#drr-container figure.large.video {
		border-bottom: 0 none;
	}
	figure#page-lede.thm-gallery #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 100%;
		height: 100%;
		transition: all 0.5s ease;
	}
</style>
<style>
.jwplayer.jw-state-paused .jw-display {
	display: table !important;
	padding: 0;
}
.jwplayer .jw-display-icon-container {
    float: none;
    padding: 0;
    margin: 0;
}
.jw-flag-small-player .jw-display {
	padding-top: 0px;
}
.jwplayer .jw-display-icon-container .jw-icon-rewind {
	visibility: hidden;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play path,
.jw-state-idle .jw-svg-icon-play path,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay path,
.jw-state-complete .jw-svg-icon-replay path {    
    display: none;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    background-size: contain;
    background-repeat: no-repeat;
    background-color: transparent;
    background-image: url(//idge.staticworld.net/idgtv/btn-play-default.svg);
    background-position: center center;
    bottom: 0;
    border-radius: 0;
    box-shadow: none;
    left: 0;
    margin: auto;
    right: 0;
    top: 0;
}
.jwplayer .jw-display-icon-container .jw-icon,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    height: 81px;
    width: 78px;
}
</style>


	
		
	



	
		<div id="drr-container" class="cat is-insider" itemprop="articleBody">
			<p>Pandemics are not the “new normal” for the human race. As with practically every other type of disaster, we’ve survived them countless times in the past.</p><p>But there’s no doubt we’re living and working through an emergency situation right now. As we try to avoid exposing ourselves to the novel coronavirus, we must also prevent our working lives from stalling out completely. For most professionals, remote collaboration will be our primary fallback method until normality returns.</p><aside class="fakesidebar">
<h4>[ <u><a href="https://www.infoworld.com/article/3533050/wth-oss-knows-how-to-wfh-irl.html">Also on InfoWorld: WTH? OSS knows how to WFH IRL</a></u> ]</h4>
</aside><h2>Tech marketing is in crisis</h2><p>Working remotely can be awkward when your productivity depends on being able to share a physical space with others for at least a few hours per day or week. Tech marketers have been hit particularly hard because a large part of their annual cycles are aligned with conferences and other industry events, <a href="https://www.zdnet.com/article/coronavirus-tech-conference-cancellations-e3-nab-gartner-dell-world-and-more/?ftag=TRE-03-10aaa6b&amp;bhid=20439713773007020840263695991524" rel="nofollow">most of which</a> have been <a href="https://www.techrepublic.com/article/the-latest-cancellations-how-the-coronavirus-is-disrupting-tech-conferences-worldwide/" rel="nofollow">canceled</a>, postponed, or made entirely virtual.</p><p>Indeed, I’ve noticed far fewer tech product releases in the past few months than in a normal spring season. This goes against the pattern I’ve seen practically every year since I entered the IT field in the mid-1980s. Typically, a burst of launches grabs everyone’s attention from late February through early June, until an equal or larger batch of vendor announcements in the fall takes the spotlight.</p>
			













<div class="empty-div"></div>

<div class="tease-promo">
	<p class="tease-title">To continue reading this article register now</p>
	<div class="access-btn"><a class="btn register" href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-form-short')" data-modal-id="insider-popup">Get Free Access</a></div>
	<p class="tease-links">
		<a href="/about/learn-about-insider.html">Learn More</a> &nbsp; Existing Users <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-signin')" data-modal-id="insider-popup">Sign In</a>
	</p>
</div>

			
			<script>
			$(document).ready(function($){
				$(function(){
					$(".signin-register > a.signin, .signin-register > a.register").click(function(){
					    $(".signin-register > a.signin, .signin-register > a.register").removeClass("selected");
					    $(this).addClass("selected");
					    return false;
					});
				});
				
			   if(typeof(IDG.insiderReg.readCookie('nsdr')) == 'undefined' && $thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
				
				$triggered_times = 0;
				
			    $(window).on('scroll', function() {
					if($('.signin-register > a').hasClass('selected')) {
						$triggered_times = 1;
					}
		            var y_scroll_pos = window.pageYOffset;
		            var emptyDiv = $('.empty-div').offset().top;
		            var scroll_pos_test = emptyDiv - 600;
		
		            if(y_scroll_pos > scroll_pos_test && $triggered_times == 0 ) {
		                $triggered_times = 1;   // to make sure the above action triggers only once
		
		                IDG.insiderReg.registerLinkEvent('insider-reg-form-short');
		                $('body').append("<div class='modal-overlay modal-close'></div>");
		                $('.modal-overlay').fadeTo(500, 0.9);
						$('.modal-overlay').height($(document).height());
		                $('#insider-popup.modal-box').fadeIn(500);
		                
		                if (navigator.userAgent.match(/(iPad)/)) {
							$("html, body").animate({
					            scrollTop: 0
					        }, 500);
						}
		            }
			    });
			   }  
			    
			});
			</script>
		
		</div>
		
	
	




<script>
$("body").on('click', 'a[data-product-id]', function() {
	var e = e || window.event;
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var prodName = $(this).attr("data-product-name");
	prodName = prodName.replace("\\'","'"); // to counter the effects of over-escaping
	
	if ( $(this).parents('.slideshow').length > 0 ) {
		var productLinkPosition = "Slideshow";
	} else if ( $(this).parents('.emo-sb').length > 0 ) {
		var productLinkPosition = "Product Sidebar";
	} else if ( $(this).parents('.at-a-glance.top').length > 0 ) {
		var productLinkPosition = "AAG Top";
	} else if ( $(this).parents('.at-a-glance').length > 0 ) {
		var productLinkPosition = "AAG Bottom";
	} else if ( $(this).parents('.quick-hits.medium').length > 0 ) {
		var productLinkPosition = "Quick Hit Medium";
	} else if ( $(this).parents('.quick-hits').length > 0 ) {
		var productLinkPosition = "Quick Hit Full";
	} else if ( $(this).parents('.product-chart').length > 0 ) {
		var productLinkPosition = "Product Chart";
	} else if ( $(this).parents('.emo-list').length > 0 ) {
		var productLinkPosition = "Product List";
	} else {
		var productLinkPosition = "Body Text";
	}
	
	dataLayer.push({
		'event': 'affiliateLink', 
	  	'eventCategory': 'Affiliate Link', // Hardcoded, not dynamic
	  	'eventAction': 'Click', // Hardcoded, not dynamic
	  	'eventLabel': ''+e.target+'', // The URL the affiliate link leads to
	  	'productVendor': $(this).attr("data-bkvndr"), // The vendor of the product
	  	'productManufacturer': $(this).attr("data-bkmfr"), // The manufacturer of the product
	  	'productName': prodName, // The name of the product
	  	'productId': $(this).attr("data-product-id"), // The ID of the product
	  	'productLinkPosition': productLinkPosition // location of product link (Product Sidebar, Product Chart, etc.)
	});
	
	window.permutive.track('AffiliateLinkClick', {
	    category: $(this).attr("data-bkc"),
	    name: prodName,
	    manufacturer: $(this).attr("data-bkmfr"),
	    vendor: $(this).attr("data-bkvndr")
	});
	
});
</script>


	<script>
$("#drr-container a:not('[data-product-id]')").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickParentsUntilDrr = $clickEl.parentsUntil("#drr-container");
	var clickText = $clickEl.text().trim();
	var linkLocation;
	var linkType;
	var regex = new RegExp("cio.com/|csoonline.com/|computerworld.com/|itnews.com/|itworld.com/|infoworld.com/|networkworld.com/|javaworld.com/|techconnect.com/|techhive.com/|macworld.com/|pcworld.com/|greenbot.com/|gamestar.com/|idginsiderpro.com/|idgesg.net/", "i");
	
	if (clickParentsUntilDrr.hasClass("fakesidebar")) {
		linkLocation = "FSB";
	}
	else if (clickParentsUntilDrr.hasClass("end-note")) {
     	 linkLocation = "End Note";
   }
	else {
		linkLocation = "Body";
	}
	
	if (regex.test(clickUrl)) {
	      linkType = "Internal";
	    }
	else {
		linkType = "External";
	}
		
	
	dataLayer.push({
		'event': 'editBodyLink', 
	  	'eventCategory': 'Editorial Body Links',
	  	'eventAction': linkType,
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>


<script>
$("#drr-top-ad .related-promo-wrapper .title > a").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickText = $clickEl.text().trim();
	var linkLocation = "Promo";		
	
	dataLayer.push({
		'event': 'promoModuleLink', 
	  	'eventCategory': 'Promotion module',
	  	'eventAction': 'Click',
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>
	

	
	
	
	
	
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	
	





<script src="/www/js/video/embedder-jwp.js?v=20200407113609"></script>

<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>

















<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>
		

	
	













<style>
@media only screen and (min-width: 60.625em) {
	article .apart.ad.not-lazy {
		margin-left: 0;
		float: right;
	}
}
/* this spaces the ads in the right rail */
@media only screen and ( min-width: 48em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 390px; /*originally 354px*/
	}
	.topDeals.topper {
		margin-top: 390px;
	}
}
@media only screen and ( min-width: 48em ) and ( max-width: 58.063em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 0;
	}
}
@media only screen and ( min-width: 60.625em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 390px; /*originally 354px*/
	}
	.topDeals.topper {
		margin-top: 390px;
	}
}
@media only screen and ( min-width: 48em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 390px;
	}
}
@media only screen and ( min-width: 48em ) and ( max-width: 58.063em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 0;
	}
}
@media only screen and ( min-width: 60.625em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 390px;
	}
}
</style>

<script type="text/javascript">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</script>		



<script>
// this debouce() function is used here and with related-content ribbon-ribbon.jsp
function debounce(func, wait, immediate){
    var timeout;
    return function(){
        var context = this, args = arguments;
        var later = function(){
            timeout = null;
            if (!immediate) func.apply(context, args);
        };
        var callNow = immediate && !timeout;
        clearTimeout(timeout);
        timeout = setTimeout(later, wait);
        if (callNow) func.apply(context, args);
    };
}

let galleryNode; // undefined if element is not found
let mobileDeviceWidth = 0;
let eventDeviceOrientation = "portrait";

if (window.innerWidth > 0) {
	mobileDeviceWidth = window.innerWidth;
} else {
	mobileDeviceWidth = document.documentElement.clientWidth;
}

if ($("figure").hasClass("thm-gallery")) {
	galleryNode = document.querySelector('.thm-gallery .embed-wrapper');
}

var supportsOrientationChange = "onorientationchange" in window,
orientationEvent = supportsOrientationChange ? "orientationchange" : "resize";

window.addEventListener(orientationEvent, function() {
	  // if device is rotated to landscape orientation
	  if (window.orientation === 90 || window.orientation === -90) {
		  eventDeviceOrientation = "landscape";
	  } else {
		  eventDeviceOrientation = "portrait";
	  }
}, false);

if (typeof galleryNode !== 'undefined') {	
	if (mobileDeviceWidth <= 480) {
		window.addEventListener('scroll', debounce(function(e) {
			// if device is rotated to landscape after page load, do not pause and play video!
			if (eventDeviceOrientation !== "landscape") {
				if (isVisible(galleryNode)) {
					jwplayer('bcplayer-gallery').play();
				} else {
			    	jwplayer('bcplayer-gallery').pause();
			  	}
			}			
		}, 5));
	}
}
</script>


	
	
	
	




					










				
			
		
		</section><!-- /.bodee -->

		















	
		
			
				
				
					
						
							
						











<div class="six-column" id="recommended">
	<div class="head">Recommended</div>
	<ul>
		
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
		































































	
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
						
							
						
						
						
						
						
					


















 

<li class=" first">
	
		
			
			
			
			
			
		

























	




	
		



 

	
	
	
		
				
				<figure class="well-img">
					
						
						
							<a  href="/article/3409071/java-challenger-7-debugging-java-inheritance.html"><img  class="lazy small.3x2Image  imgId100795778 " data-original="https://images.idgesg.net/images/article/2019/05/abstract_connections_network_object_ineritance_root_superclass_by_koto_feja_gettyimages-974104916_2400x1600-100795778-small.3x2.jpg" loading="lazy" alt="abstract connections / network / object / root / inheritance / hierarchy" /></a>
						
					
					
					
				</figure>
				
		
		
	

	
	
		
		
		
			
		
		
	
	
	<div class="post-cont">
		
			
								
			
			
		
		<div class="title">













	
		
    	
    		<a  href="/article/3409071/java-challenger-7-debugging-java-inheritance.html">Inheritance versus composition: How to choose</a>
    	
	
</div>
    </div>
    
	    
    
</li>

				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
						
							
						
						
						
						
						
					


















 

<li class=" ">
	
		
			
			
			
			
			
		

























	




	
		



 

	
	
	
		
				
				<figure class="well-img">
					
						
						
							<a  href="/article/3452018/get-started-with-lambda-expressions.html"><img  class="lazy small.3x2Image  imgId100817057 " data-original="https://images.idgesg.net/images/article/2019/11/jw_lambda_expressions_lambda_symbol_abstract_formulas_and_binary_code_by_monsitj_gettyimages-1047349788_2400x1600-100817057-small.3x2.jpg" loading="lazy" alt="Java  >  Lambda expressions  >  Lambda symbol / abstract formulas / binary code" /></a>
						
					
					
					
				</figure>
				
		
		
	

	
	
		
		
		
			
		
		
	
	
	<div class="post-cont">
		
			
								
			
			
		
		<div class="title">













	
		
    	
    		<a  href="/article/3452018/get-started-with-lambda-expressions.html">Get started with lambda expressions in Java</a>
    	
	
</div>
    </div>
    
	    
    
</li>

				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
						
							
						
						
						
						
						
					


















 

<li class=" ">
	
		
			
			
			
			
			
		

























	




	
		



 

	
	
	
		
				
				<figure class="well-img">
					
						
						
							<a  href="/article/3340234/tutorial-series-android-studio-for-beginners.html"><img  class="lazy small.3x2Image  imgId100788152 " data-original="https://images.idgesg.net/images/article/2019/02/jw_android_studio_for_beginners_3x2_1200x800_pkg_idg_google_darkovujic_gettyimages-100788152-small.3x2.jpg" loading="lazy" alt="JavaWorld > Android Studio for Beginners [movile java package]" /></a>
						
					
					
					
				</figure>
				
		
		
	

	
	
		
		
		
			
		
		
	
	
	<div class="post-cont">
		
			
								
			
			
		
		<div class="title">













	
		
    	
    		<a  href="/article/3340234/tutorial-series-android-studio-for-beginners.html">Tutorial series: Android Studio for beginners</a>
    	
	
</div>
    </div>
    
	    
    
</li>

				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
						
							
						
						
						
						
						
					


















 

<li class=" ">
	
		
			
			
			
			
			
		

























	




	
		



 

	
	
	
		
				
				<figure class="well-img">
					
						
						
							<a  href="/article/3379043/what-is-jpa-introduction-to-the-java-persistence-api.html"><img  class="lazy small.3x2Image  imgId100792562 " data-original="https://images.idgesg.net/images/article/2019/04/jw_java_persistence_series_3x2_2400x1600_3_data_center_database_digital_information_blocks_server_traffic_routing_by_ramcreativ_gettyimages-100792562-small.3x2.jpg" loading="lazy" alt="JavaWorld > Persistence [series] > data blocks / data center / database / server traffic routing" /></a>
						
					
					
					
				</figure>
				
		
		
	

	
	
		
		
		
			
		
		
	
	
	<div class="post-cont">
		
			
								
			
			
		
		<div class="title">













	
		
    	
    		<a  href="/article/3379043/what-is-jpa-introduction-to-the-java-persistence-api.html">What is JPA? Introduction to the Java Persistence API</a>
    	
	
</div>
    </div>
    
	    
    
</li>

				
				
			
		
	




		
		
		
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
		

































































		
	</ul>
</div><!-- /.six-column -->
					

				
			
			
		

		
			
				
					<div class="lazyload_ad">
						<code type="text/javascript">
						<!--
						var slotName = 'bottomleaderboard';
						var slotSize = [];
						if ($thm.deviceClass == 'mobile') {
							slotSize = [[300,50],[320,50],[300,250]];
						}
						else if ($thm.deviceClass == 'tablet') {
							slotSize = [[728,90],[468,60]];
						}
						else {
							slotSize = [[728,90],[970,90],[970,250]];
						}
						IDG.GPT.addDisplayedAd(slotName, "true");
						document.write('<div id="' + slotName + '" class="ad-container">');
						consent.ads.queue.push(function(){
							IDG.GPT.defineGoogleTagSlot(slotName, slotSize, false, true);});
						document.write('</div>');
						consent.ads.queue.push(function(){
							$('#' + slotName).responsiveAd({screenSize:'971 1115', scriptTags: []}, true);});
						//-->
						</code>
					</div>
							
	
	


	
		










<link rel="stylesheet" href="/www.idgcsmb/css/tso-links.css?v=20200407113609" />

	<div id="tso-wrapper"><div id="tso" style="display:none"></div></div>
	<script type="text/javascript">
	function renderTSO(ads, requireHttps) {
		$thm.debug("renderTSO:"+ads.length);
		if (ads && ads.length > 0) {
			var selectedAds = selectTSOAds(ads,10);
			if (null != selectedAds && selectedAds.length > 0) {
				var html = "<h3>Sponsored Links</h3>";
				html += "<ul>";
				for (var i=0; i<selectedAds.length;i++) {
					html += "<li>";
					html += "<a href='"+selectedAds[i].url+"'> "+selectedAds[i].title+"</a>";
					if (null != selectedAds[i].pixel && selectedAds[i].pixel.length > 0) {
						html += selectedAds[i].pixel;
					}
					html += "</li>";
				}
				html += "</ul>";
				$("#tso").html(html).show();
			}
		}
	}
	function selectTSOAds(ads,max) {
		if (ads.length <= max) {
			return ads;
		} else {
			var uniq = {};
			var found = 0;
			var selectedAds = [];
			while (found < max) {
				var ad = ads[Math.floor(Math.random()*ads.length)];
				if (uniq[ad.id] != null) {
					continue;
				} else {
					uniq[ad.id] = true;
					found++;
					selectedAds.push(ad);
				}
			}
			return selectedAds;
		}
		return null;
	}
	</script>
	

	
	


		</article>

	</section><!-- /role=main -->

	
	
	

</div><!-- /#page-wrapper -->
		
		












	<link rel="stylesheet" href="/www.idge/css/foot.css?v=20200407113609" />
	<link rel="stylesheet" href="/www.idge.jvw/css/foot.css?v=20200407113609" />





<footer>

    <section class="brand" itemscope itemtype="http://schema.org/Organization">
   	
   		<link itemprop="url" href="http://www.javaworld.com"> 
        <a href="/"><span class="logo">JavaWorld</span></a>
		<span class="tagline"> JavaWorld is the original independent resource for Java developers, architects, and managers.</span>
        
        
        
    </section>
    	
    <section class="topics">
        
			
		
    </section>
    
    
    <section class="about">
		<div class="wrapper"> 
        	<nav class="tertiary" id="ft3">
            	<ul>
            		
















<li><a class="edition-link-url" href="/about/about.html"  >About Us</a>

<li><a class="edition-link-url" href="/about/contactus.html"  >Contact</a>

<li><a class="edition-link-url" href="/about/privacy.html"  >Privacy Policy</a>

<li><a class="edition-link-url" href="/about/cookie-policy.html"  >Cookie Policy</a>

<li><a class="edition-link-url" href="/about/member-preferences.html"  >Member Preferences</a>

<li><a class="edition-link-url" href="https://www.idg.com/advertise-with-us/infoworld/" target="_blank" rel="nofollow" >Advertising</a>

<li><a class="edition-link-url" href="https://www.idg.com/work-here/" target="_blank" rel="nofollow" >IDG Careers</a>

<li><a class="edition-link-url" href="/about/adchoices.html"  >Ad Choices</a>

<li><a class="edition-link-url" href="/about/affiliates.html"  >E-commerce Links</a>

<li><a class="edition-link-url" href="/about/ccpa.html"  >California: Do Not Sell My Personal Info</a>




            	</ul>
        	</nav>
		</div>
	</section>
	
    <section class="copyright">
        <div class="wrapper">
			
        		<img src="https://alt.idgesg.net/images/logos/logo-footer-black.png" alt="IDG Communications" />
        	
        	
        
        	
        	<p><a href="/about/copyright.html">Copyright</a> &copy; 2020 IDG Communications, Inc.</p>
			<div class="network">
				<div id="network-selector">
                <div class="label">Explore the IDG Network <i class="ss-icon tick">descend</i></div>
                <ul>
                	
                		
                		
                	














	
		<li><a href="https://www.cio.com" target="_blank" rel="nofollow">CIO</a></li>
	
		<li><a href="https://www.computerworld.com" target="_blank" rel="nofollow">Computerworld</a></li>
	
		<li><a href="https://www.csoonline.com" target="_blank" rel="nofollow">CSO</a></li>
	
		<li><a href="https://www.idc.com" target="_blank" rel="nofollow">IDC</a></li>
	
		<li><a href="https://www.idg.com" target="_blank" rel="nofollow">IDG</a></li>
	
		<li><a href="https://www.idgconnect.com" target="_blank" rel="nofollow">IDG Connect</a></li>
	
		<li><a href="https://www.infoworld.com" target="_blank" rel="nofollow">InfoWorld</a></li>
	
		<li><a href="https://www.idginsiderpro.com" target="_blank" rel="nofollow">Insider Pro</a></li>
	
		<li><a href="https://www.javaworld.com" target="_blank" rel="nofollow">JavaWorld</a></li>
	
		<li><a href="https://www.networkworld.com" target="_blank" rel="nofollow">Network World</a></li>
	

                </ul>
				</div><!-- /#network-selector -->
			</div><!-- /.network -->
		</div><!-- /.wrapper -->
    </section>
</footer>


<script src="/www/js/jquery/jquery-ui.js"></script>
<script src="/www/js/jquery/jquery.dfp.min.js"></script>
<script src="/www.idge/js/mule/shortstack_nav.js"></script>




	
		
			
		





















	

		
			
			
			
			
			
			
				<div id="mobilewelcomead" class=" ad-container test">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				
					IDG.GPT.addDisplayedAd("mobilewelcomead", "true");
					$('#mobilewelcomead').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: mobilewelcomead - [971 1115]");
                    
				
				});
				</script>
			
		
	
 	
 
 
	



		
	<script src="/www/js/ads/stickyLb.js"></script>
	<script>
	var stickHead = "sticky-head";
	if ( document.querySelector("#non-stick") ) {
		stickHead = "non-stick";
	}
		
		(function(){
			var parallaxArgs = {
				topNavEl: stickHead,
				topNavIsSticky: true,
				leaderboadrdId: 'topleaderboard', 
				adContainer: 'viewabilityAdContainer',
				adUnit: 'viewabilityAdUnit',
				viewabilityTime: 10000
			}
			parallaxLb(parallaxArgs);
		})();
		
	</script>


<script src="/www/js/analytics/tracking.js"></script>
<script src="/www/js/autocomplete.js"></script>


	<script src="/www.idge/js/jquery/plugins/jquery.colorbox-min.js"></script>
	<script src="/www.idge/js/article.js?v=20200407113609"></script>
	
	<script src="/www.idge/js/jquery/responsive-tables.js"></script>
	<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
	<script>
	$(document).ready(function() {
		$("table.tablesorter").tablesorter({
			widgets: ['zebra']
		});
		
		$("table.tablesorter tbody tr").hover(function() {
			$(this).toggleClass("selected");
		});
		
		$("table.tablesorter thead tr th").each(function(){			
			if ($(this).find('.ss-icon').length < 1) {
				$(this).append('<i class="ss-icon"></i>');
			}
		});
		
	});
	</script>
	
		<script src="/www/js/prettify.js"></script>
		<script>prettyPrint();</script>
	




<script src="/www.idge/js/global.js?v=20200407113609"></script>
<script src="/www/js/webfonts/ss-social.js"></script>
<script src="/www/js/webfonts/ss-standard.js"></script>
<script src="/www/js/analytics/brandAnalytics.js"></script>





















<!-- Include here when empty article and when not empty and article is slideshow as this script is included with DRR code in body-base.jsp. -->
<!-- Also do not include on search page with new right rail. OC-1778 -->



<script type="text/javascript">
// -- Load Lazy Advertisement placement as deferred
$("div.lazyload_ad").lazyLoadAd({
        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
        onLoad       : false,       // Callback function on call ad loading
        onComplete   : false,       // Callback function when load is loaded
        timeout      : 1500,        // Timeout ad load
        debug        : false,       // For debug use : draw colors border depends on load status
        xray         : false        // For debug use : display a complete page view with ad placements
}) ;
</script>







<script type='text/javascript'>

			IDG.insiderReg.stepReg();
		

	g_bRequireHttps = true;
	 	var localeId = getLocale();
		$.ajax('/ads/tso?localeId=' + localeId,{
			dataType: 'json',
			success: function(data){
				renderTSO(data.tsoLinks, g_bRequireHttps);
			},
			error: function(jqXHR,error,thrown){
				$thm.debug("TSO AJAX Status: "+error+": "+thrown,true);
			}
		});
	
</script>












	
		
	
	
		
	
	

<!-- Begin comScore Tag -->
<script>
var _comscore = _comscore || [];
_comscore.push(
{ c1: "2", c2: "6035308", c3: "", c5: "Software Development", c6: "Article: Analysis", c15: "3537391" });
(function()
{
	var s = document.createElement("script"), el = document.getElementsByTagName("script")[0];
	s.async = true; s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
	el.parentNode.insertBefore(s, el);
})();
</script>
<noscript>
<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035308&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->


	<!-- LiveRamp Sources -->
	<script src="/www/js/utils/liveRamp.js"></script>
	<!-- End of LiveRamp -->













<script type="text/javascript">
consent.digitalelement.queue.push(function(){
	$thm.logPlEvent({"b":"jvw","e":"view","t":"article","id":"3537391"});
});
</script>

		<div id="loginModal"></div>
		<div id="logoffModal"></div>


		
		
		
		
		<script type="text/javascript">
			a=top;f=self;
			var acceptedDomains = ["lookbookhq.com"];
			var cleanedHost = a.location.hostname.split(".").slice(-2).join(".");
			if(a!=f && acceptedDomains.indexOf(cleanedHost) < 0) {
				a.location=f.location;
			}
		</script>			

		













	</body>
</html>